New To Mac-Forums?

Welcome to our community! Join the discussion today by registering your FREE account. If you have any problems with the registration process, please contact us!

Get your questions answered by community gurus Advice and insight from world-class Apple enthusiasts Exclusive access to members-only contests, giveaways and deals

Join today!

 
Start a Discussion
 

Mac-Forums Brief

Subscribe to Mac-Forums Brief to receive special offers from Mac-Forums partners and sponsors

Join the conversation RSS
OS X - Operating System General OS operation information and support

This is driving me nuts! (OSX keyboard)


Post Reply New Thread Subscribe

 
Thread Tools
vicariousgeorge

 
vicariousgeorge's Avatar
 
Member Since: Feb 13, 2007
Posts: 68
vicariousgeorge is on a distinguished road
Mac Specs: 13" Macbook 2.0GHz, Airport Extreme, 3G iPod Nano

vicariousgeorge is offline
This is something that happens on a daily basis, and it is driving me insane.

Whenever I go to a type field on OSX, every once in a while it will fail to notice the first key that I press.

For example, let's say that I was on apple's website and decided that I wanted to navigate to "mac-forums.com." Easy enough, correct? Not so much. When I move the cursor to the address bar, there is a possibility that when I begin to enter the address, I will end up with "ac-forums.com," rather than "mac-forums.com." For some reason, the first keystroke is not recognized. Needless to say, this is very aggravating.

I've done some troubleshooting, and here are my findings:

* It is not application specific - at first, I thought it may have had something to do with Firefox. However, I've encountered the problem in iChat, Finder, and Spotlight search as well.

* It is not hardware related - This happens on any key, so it is not a loose piece on the keyboard.

* It is not a system resource issue - I have a C2D macbook, and 2GB of ram. Moreover, this occurs when I only have one application open.

* It just started recently - I don't remember having this problem until fairly recently. There are a few applications that I have installed around the time this began: Adobe Creative Suite Web Premium, Handbrake, Roxio Toast 8, and Steermouse. Think any of these may be the problem?


How can I fix this? This seems like one of those irritating issues that can only be resolved with a fresh installation of the OS. I may just wait it out until Leopard, and hopefully it will be fixed.

Thanks in advance.
QUOTE Thanks
cwa107

 
cwa107's Avatar
 
Member Since: Dec 20, 2006
Location: Middletown, Pennsylvania
Posts: 26,599
cwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond repute
Mac Specs: 15" MBP, Core i7/2GHz, 8GB RAM, 480GB Crucial M500 SSD

cwa107 is offline
What happens if you log into a new user account?

Liquid and computers don't mix. It might seem simple, but we see an incredible amount of people post here about spills. Keep drinks and other liquids away from your expensive electronics!
QUOTE Thanks
vicariousgeorge

 
vicariousgeorge's Avatar
 
Member Since: Feb 13, 2007
Posts: 68
vicariousgeorge is on a distinguished road
Mac Specs: 13" Macbook 2.0GHz, Airport Extreme, 3G iPod Nano

vicariousgeorge is offline
Quote:
Originally Posted by cwa107 View Post
What happens if you log into a new user account?

I only have one account
QUOTE Thanks
cwa107

 
cwa107's Avatar
 
Member Since: Dec 20, 2006
Location: Middletown, Pennsylvania
Posts: 26,599
cwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond repute
Mac Specs: 15" MBP, Core i7/2GHz, 8GB RAM, 480GB Crucial M500 SSD

cwa107 is offline
Quote:
Originally Posted by vicariousgeorge View Post
I only have one account
Create a new one, just for testing purposes (you can always delete it later). This way, you can determine whether it's a user-specific setting issue or it's the whole OS.

That would be my first thought before I'd go to reinstall the OS.

Liquid and computers don't mix. It might seem simple, but we see an incredible amount of people post here about spills. Keep drinks and other liquids away from your expensive electronics!
QUOTE Thanks
Leukeh

 
Leukeh's Avatar
 
Member Since: Apr 22, 2007
Location: Sydney, Australia
Posts: 1,174
Leukeh is a jewel in the roughLeukeh is a jewel in the rough
Mac Specs: 13" MBP, 2.26GHz, 8gb RAM

Leukeh is offline
Is it a wireless keyboard? If so, maybe try changing the batteries. That's all I can think of...

Behance Design/Photography Porfolio
QUOTE Thanks
powermacj7

 
powermacj7's Avatar
 
Member Since: Mar 22, 2007
Location: NY NY
Posts: 403
powermacj7 will become famous soon enough
Mac Specs: iMac Duo White

powermacj7 is offline
I had that lag on my PB. I know what you are saying, although I don't have a specific solution, all I did was run my maintenance scripts, cleaned out old cache files, etc. Also, I checked to see what was running (activity monitor) and start-up under System Preferences->User accounts, and got rid of start-up items I did not use.
QUOTE Thanks
vicariousgeorge

 
vicariousgeorge's Avatar
 
Member Since: Feb 13, 2007
Posts: 68
vicariousgeorge is on a distinguished road
Mac Specs: 13" Macbook 2.0GHz, Airport Extreme, 3G iPod Nano

vicariousgeorge is offline
Quote:
Originally Posted by powermacj7 View Post
I had that lag on my PB. I know what you are saying, although I don't have a specific solution, all I did was run my maintenance scripts, cleaned out old cache files, etc. Also, I checked to see what was running (activity monitor) and start-up under System Preferences->User accounts, and got rid of start-up items I did not use.
Where can I find these maintenance scripts?
QUOTE Thanks
PowerBookG4

 
PowerBookG4's Avatar
 
Member Since: Jan 08, 2005
Location: New Jersey
Posts: 6,190
PowerBookG4 has much to be proud ofPowerBookG4 has much to be proud ofPowerBookG4 has much to be proud ofPowerBookG4 has much to be proud ofPowerBookG4 has much to be proud ofPowerBookG4 has much to be proud ofPowerBookG4 has much to be proud ofPowerBookG4 has much to be proud ofPowerBookG4 has much to be proud ofPowerBookG4 has much to be proud of
Mac Specs: Mac Pro 8x3.0ghz 12gb ram 8800GT , MBP 2.16 2GB Ram 17 inch.

PowerBookG4 is offline
http://www.macupdate.com/info.php/id/11582

My Website
Blog
I love my hosting company!
I was on the M-F honor roll for Febuary:2006
QUOTE Thanks
achristo

 
Member Since: Oct 09, 2007
Posts: 4
achristo is on a distinguished road

achristo is offline
Okay...this little problem has inspired me to join the forum. I have been annonyed by the very same issue. I'm downloading OynX as I type and will let you know if it cleans up the problem.
QUOTE Thanks
achristo

 
Member Since: Oct 09, 2007
Posts: 4
achristo is on a distinguished road

achristo is offline
Quote:
Originally Posted by achristo View Post
Okay...this little problem has inspired me to join the forum. I have been annonyed by the very same issue. I'm downloading OynX as I type and will let you know if it cleans up the problem.
Tried it and it didn't work. Any other ideas out there???
QUOTE Thanks
Sawday

 
Sawday's Avatar
 
Member Since: Nov 19, 2006
Location: York, UK
Posts: 1,036
Sawday is a jewel in the roughSawday is a jewel in the roughSawday is a jewel in the rough
Mac Specs: 24" Aluminium, 2.8 GHz, 4Gb RAM. iPad2, iPhone4

Sawday is offline
When you have moved the cursor are you actually clicking (one left click will do) before typing? The first key stroke or click 'confirms' your position (if that makes sense).

The same thing often happens when a dialog box pops up - if you don't click on one of the buttons immediately, when you position the cursor over the button you need to click twice - once to bring the button 'alive' and then once again to activate it.

Happiness is not getting what you want, but wanting what you get.
QUOTE Thanks
vicariousgeorge

 
vicariousgeorge's Avatar
 
Member Since: Feb 13, 2007
Posts: 68
vicariousgeorge is on a distinguished road
Mac Specs: 13" Macbook 2.0GHz, Airport Extreme, 3G iPod Nano

vicariousgeorge is offline
Quote:
Originally Posted by Sawday View Post
When you have moved the cursor are you actually clicking (one left click will do) before typing? The first key stroke or click 'confirms' your position (if that makes sense).

The same thing often happens when a dialog box pops up - if you don't click on one of the buttons immediately, when you position the cursor over the button you need to click twice - once to bring the button 'alive' and then once again to activate it.
While I appreciate the response, it is most likely wrong. When I click in the dialog bog, text field, address bar etc, the position is "confirmed." After that, it will occasionally fail to recognize the next keystroke. Had this been the method of "confirming" that you suggested, it would happen every time as opposed to intermittently. This is most definitely a problem in the OS rather than some intentional occurrence.

Regards
QUOTE Thanks
achristo

 
Member Since: Oct 09, 2007
Posts: 4
achristo is on a distinguished road

achristo is offline
Quote:
Originally Posted by vicariousgeorge View Post
While I appreciate the response, it is most likely wrong. When I click in the dialog bog, text field, address bar etc, the position is "confirmed." After that, it will occasionally fail to recognize the next keystroke. Had this been the method of "confirming" that you suggested, it would happen every time as opposed to intermittently. This is most definitely a problem in the OS rather than some intentional occurrence.

Regards
I can confirm that the 'confirmation' within the text entry box is correct for me also. This annoyance of missing the first character happens on a fairly regular occurrence for me. Just today it has happened a few times.
Maybe an upgrade to Leopard will fix it. I hope so!
QUOTE Thanks
ki99

 
ki99's Avatar
 
Member Since: May 31, 2007
Location: Ontario, Canada.
Posts: 926
ki99 is a jewel in the roughki99 is a jewel in the roughki99 is a jewel in the rough
Mac Specs: Macbook(W) 2GHz, 80GB HD, 1G RAM, Windows XP

ki99 is offline
it happens to me often as well, i always assumed (and still do) that it is just system lag. if it's bugging you THAT much, try a fresh install. i would advise reinstalling the OS every few months too keep it running tip top
QUOTE Thanks
wytey

 
Member Since: Sep 25, 2007
Location: UK
Posts: 61
wytey is on a distinguished road
Mac Specs: MBP 15" 2.4GHz 4Gb OCZ RAM

wytey is offline
could it be that part of your palm is occasionally resting on the trackpad?

are you a light typer? I have problems with a few keys, mainly o t and e, mainly o, but I notice that the keys can be depressed, and still not register if you are light enough. for me, I just got to give each keypress that little bit extra oomph. plug in a USB keyboard, and it is fine sailing, until I unplug it
QUOTE Thanks

Post Reply New Thread Subscribe


« Yet Another Leopard Time Machine Question | Leopard 10.5 - up-to-date »
Thread Tools

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off
Forum Jump

Similar Threads
Thread
Thread Starter
Forum
Replies
Last Post
External Kensington USB Keyboard rdean Other Hardware and Peripherals 0 04-13-2007 10:19 AM
Weirdly Locked Key Combos when Using USB Apple Pro Keyboard dorisdanglehoff Apple Notebooks 0 11-09-2006 09:09 PM
Looking for the right keyboard... Localoid Other Hardware and Peripherals 2 07-05-2006 10:41 AM
MS contingency to buy OSX mass licence Smartz Apple Rumors and Reports 16 03-28-2006 02:40 PM
printing PostScript with OSX davidp158 OS X - Operating System 9 02-09-2005 09:56 PM

All times are GMT -4. The time now is 10:08 AM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
X

Welcome to Mac-Forums.com

Create your username to jump into the discussion!

New members like you have made this community the ultimate source for your Mac since 2003!


(4 digit year)

Already a member?