Results 1 to 4 of 4
  1. #1
    Slow Print Dialog

    Member Since
    Jul 05, 2007
    Posts
    2
    Slow Print Dialog
    Hi

    I've got a problem with a printer I've loaded onto someones computer. Their OS version is 10.4.9.

    The problem is I've connected a new printer up and whenever we select it from the printer list it takes almost 30 seconds for the computer to stop thinking (the colour wheel) once selected. This is from any program. So basically when we choose print, and select the printer from the list it hangs for awhile, then once done we can select the print features and eventually print. The print speed is fine.

    The printer is a 'Fuji Xerox DocuCentre-II C3000', I've used the driver CD supplied and used the supplied PPD installer, I've loaded the printer as an IP printer and have followed the manufactures instructions.
    The print queue created is using the correct PPD file. I've also tried setting the printer up as an Appletalk and Bonjour, but the same thing happens.
    I've also tried this on other macs and the same thing happens. The odd thing is they have other networked printers they use and they don't have to wait almost 30 seconds to use the other printers.

    Has anybody come across anything similar before or have any ideas what it might be? It seems like tis' just taking it's time in locating the PPD, which I will note is in the correct library directory.

    Thanks for any help.

  2. #2
    Slow Print Dialog
    christm's Avatar
    Member Since
    Dec 18, 2005
    Location
    Devon, England
    Posts
    2,288
    Specs:
    ibook g4, imac 2ghz c2d, mbp 2.4ghz c2d - 10.5.1
    try going onto the printer manufacturers website and check for the latest drivers and updates.

  3. #3
    Slow Print Dialog

    Member Since
    Jul 05, 2007
    Posts
    2
    Sorry I should have mentioned, it looks like I've got the latest drivers.

    Thanks

  4. #4
    Slow Print Dialog

    Member Since
    Aug 22, 2008
    Posts
    1
    I am a Systems Engineer for Konica Minolta and many of us have been facing this problem with 10.4.x. The problem is not your Xerox, as much as I'd love to say buy a Konica Minolta to replace it

    The problem is within CUPS in the Mac 10.4.x OS. I'll document the fix for you here. Open Finder, browse to applications, utilities, and launch the Printer Setup Utility. Record your printers because this procedure will wipe them out. From the Printer Setup Utility menu select "Reset Printing System". You will need to enter your password to perform this function. This process will delete your old CUPS config file and restore the 10.4 backup as the new file. So instead of an upgraded config file you have a new one and your printing delay will be gone. Reinstall your printer drivers and your good to go.

    If you don't have the "Reset Printing System" in your menu you can still fix this issue. Go to Finder, applications, utilities, and launch Terminal and go through the steps below.

    $ cd /etc/cups
    $ sudo zsh
    <<enter your password when prompted>>
    # mv cupsd.conf cupsd.conf.mybackup
    # cp cupsd.conf.default cupsd.conf
    # killall -HUP cupsd
    # exit
    $

    This is what we had to do before Apple admitted to this problem and came up with a fix for it.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Bypassing print dialog.
    By fgersch in forum OS X - Operating System
    Replies: 11
    Last Post: 01-30-2014, 08:01 PM
  2. Print Dialog Settings
    By kdzine in forum OS X - Operating System
    Replies: 1
    Last Post: 12-17-2009, 05:27 PM
  3. slow opening print image dialog window
    By mostlylost in forum Apple Desktops
    Replies: 0
    Last Post: 11-18-2009, 04:27 PM
  4. no pages option in print dialog
    By Bree in forum OS X - Operating System
    Replies: 1
    Last Post: 11-12-2008, 08:04 PM
  5. pdf option in print dialog
    By MrGecko in forum OS X - Operating System
    Replies: 5
    Last Post: 12-13-2007, 07:51 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •