Results 1 to 5 of 5
  1. #1

    Member Since
    May 31, 2007
    Peripherals won't mount- G4 OSX 10.3.9
    Mac: G4 667 MHz w/OSX 10.3.9

    Issue: Mac won't mount peripherals- firewire hard drives, or usb camera, or usb printer. All were operating properly for over 6 months but now are getting error message (below). Disk utility sees the disks but won't repair or mount (I tried the repair function 5 times in a row, with restarts, but no luck).

    Error Message: You have inserted a disk containing no volume that Mac OS X can read. to continue with the disk inserted, click ignore. (Button choices= Ignore & Eject).

    DiskWarrior and TechToolPro look like possible options but are expensive. I have install disks for 10.4 and am wondering if it might help for me to update from 10.3 to 10.4?

    I searched the forums/internet for info on this to no avail.
    Any thoughts are truly appreciated- thanks!

  2. #2

    Member Since
    May 31, 2007
    Update: I tried the Tiger update but the dvd isn't being recognized. I also tried running Apple's software update but the .dmg file downloaded from Apple is failing to mount. I see a Basic OS X Troubleshooting post at the head of this forum (File System Check, zapping PRAM, etc.)- would these help with this problem?
    Any thoughts? Thanks!

  3. #3
    Welcome to Mac-Forums, RAllen65. Sorry to hear about your troubles.

    Well you've got nothing to loose. PRAM does sound like a good thing to try. Another is unplug your Power Mac from the wall, let it sit like that for 15 minutes or so, then plug it back in: it might be a case of overcharged capacitors and they can't drain.

    If the PRAM/NVRAM and the unplug trick doesn't work, maybe try this next one, Resetting Cuda/PMU on Power Mac G5, Power Mac G4, Power Macintosh G3.

    Let us know what gives after trying these. Good luck, I hope one of them works.

  4. #4

    Member Since
    May 31, 2007
    G4 with disk mount problem- thanks for suggestion.
    Hi MacHeadCase-
    I tried zapping PRAM and unplugging everything and pressing the little button inside the cpu box- but I'm still getting the message:
    "You have inserted a disk containing no volume that Mac OSX can read. To continue with the disk inserted, click ignore."

    Disk Utility sees the firewire hard drive and after repairing it, I still get the message.

    Anyway, thank you for the suggestion and I'll keep trying to sort this problem out.


  5. #5
    Can you pop in the optical drive Apple's Hardware Test that came with your Mac? It's either on its own CD (older Macs had the diagnostic tool on its own CD) or it is on one of your install CD disks.

    Restart and hold down the C key and when prompted, ask for the Extended Test. This will check all ports, video card, RAM, etc.

    Report back with the results. This is to make sure this isn't a hardware test.

    Also what you might do is create a new user account, log into that new one and see if the problems persist in the new account. If all seems to work in there, it means that there is software in your old user account that is corrupted or causing some type of conflict. If the problems still happen in the new account, it means the conflict is system-wide.

    To help us further, can you recall when this started to happen? Was this right after some software install? Or did you change anything in the system or your account? Did you add any peripherals shortly before?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 5
    Last Post: 05-09-2014, 06:18 PM
  2. Script to mount volume (external drive or disk image) which won't mount..?
    By MaccIngs in forum OS X - Development and Darwin
    Replies: 2
    Last Post: 09-09-2011, 10:05 PM
  3. Trying to mount OSX 10.6 on Windows - is this possible?
    By kevinkenny in forum OS X - Operating System
    Replies: 1
    Last Post: 04-17-2010, 04:28 PM
  4. OSX 10.6 - How to mount a network drive
    By jerryhilbert in forum OS X - Operating System
    Replies: 3
    Last Post: 03-27-2010, 09:21 AM
  5. G3 won't recognise USB peripherals.
    By pgrachev in forum Apple Notebooks
    Replies: 1
    Last Post: 04-27-2007, 04:55 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts