Results 1 to 9 of 9

Thread: POSIX Error 13

  1. #1

    Member Since
    May 09, 2007
    POSIX Error 13
    Each time I try to add an attachment to, or download an attachment from, my Yahoo e-mail account, I receive the following error message from Safari:

    "Safari can’t open the page ' [remainder of URL]'. The error was: 'POSIX error: Permission denied' (NSPOSIXErrorDomain:13) Please choose Report Bug to Apple from the Safari menu, note the error number, and describe what you did before you saw this message".

    I receive similar error messages with other browsers. I am able to browse the Web, run Apple's software update, and the like, otherwise.

    I have repaired permissions, and created and tested this problem with a new user account, and the problem persists. Please advise. Thank you very much.

  2. #2
    Welcome to Mac-Forums, Carnamagos.

    I've briefly googled up the error message and it seems that this could happen because of blocking software like NetBarrier, LittleSnitch, etc.

  3. #3

    giulio's Avatar
    Member Since
    Mar 19, 2007
    NY USA
    iMac 5.1 | iMac 7.1 | iPod Touch | iPod Nano
    Are you surfing through a proxy or a router?
    schweb This has to be one of the best threads ever in MF history...
    Cherokee This gets my vote for most innovative thread on Mac-Forums... ever.

  4. #4

    Member Since
    May 09, 2007

    Thanks for the welcome, and for your response. I am using the NetBarrierX4 firewall, but that does not seem to be the cause of the problem. When I have NetBarrier turned off, or when I am in a different user mode, one in which Netbarrier is not installed, the same error appears.


    No, I am not behind a proxy or a router.

  5. #5
    From what I've seen, it would seem like some IP addresses stay blocked. I have no clue where you should look for this stuff though but thought that if I posted this, it might send you on a winning tangent.

  6. #6

    Member Since
    Oct 27, 2005
    Hi carnamagos,

    Could you do me a favour and check something out, even it it sounds far-fetched?

    I want you to check whether “NetBarrier” has possibly registered the site in the “Block-list”.

    If this is the case - you will need to add the IP of the site to the “Trusted Zone” or whatever NetBarrier calls it..

    Also, could you try zipping the file you are having problems uploading ....

    Right/Ctrl-click the file and select "Create Archive of ..... " This will create a .zip archive of the file and see if you can successfully attach this to an email.

    Also have someone send you an attached .zip file and see if you can download that.

    And finally.....

    Go to:

    YourUserAccount -> Library -> Caches.

    Check whether the Safari folder in there has a little padlock on the icon, if it does, then it's locked.

    This may have been done by Safari Enhancer or something else, to prevent caching and speed things up.

    This will interfere with certain uploading processes.

    Select the Safari folder (inside ~/Library/Caches), and hit Apple-I (Get Info). Uncheck the "Locked" checkbox.

  7. #7

    Member Since
    May 09, 2007

    I appreciate your reply. You were on the right track, but I was not savvy enough to move forward with your suggestion.


    Thank you! You are spot on regarding NetBarrier and the "stop list". I have no idea how or why it happened, but NetBarrier did, in fact, block those sites. Once I removed the blocked URLs from the list, everything began to function normally, again.

    What fooled me is the fact that, even with NetBarrier off, and even when in a newly created account, without NetBarrier running, I received the same result. So, the moral of the story, for anyone who faces this problem in the future and researches this thread:

    1. Check your firewall and its "stop" or "block" settings; and,

    2. Realize that, once a firewall blocks you from connecting to a site, it may well have the site blocked permanently, whether the firewall is running, or not!

    Thanks again to all who replied.

  8. #8

    Member Since
    Oct 27, 2005
    That's fantastic news Carnamagos!!!

  9. #9
    Glad you got it working, Carnamagos.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. time machine error (OSStatus error -5000.)
    By thetrystero in forum OS X - Operating System
    Replies: 0
    Last Post: 01-24-2013, 10:29 PM
  2. Warcraft 3 Frozen Throne Error Building Click error
    By Elayne in forum OS X - Apps and Games
    Replies: 0
    Last Post: 12-18-2011, 03:12 PM
  3. Application Launch error: since shared library error
    By Survive in forum Apple Notebooks
    Replies: 0
    Last Post: 07-15-2010, 06:13 PM
  4. POSIX error
    By lindersville in forum OS X - Operating System
    Replies: 0
    Last Post: 11-02-2009, 11:07 AM
  5. POSIX error
    By anniegill1 in forum Internet, Networking, and Wireless
    Replies: 2
    Last Post: 11-29-2007, 05:34 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts