Results 1 to 5 of 5
  1. #1

    Member Since
    Apr 26, 2007
    Can't Install OS X due to missing receipt
    OK, I have a problem with my MacBook. It seems I can't boot up from the Hard Drive anymore. When I boot up with the OS X Install Disk, I see that my Hard Drive is still there. I tried to use First Aid, but I got a message in red bold letters saying "Error: No valid packages" in red letters. After lurking, I found out I deleted the receipt while I was cleaning it up using Onyx. Little did I know I needed that receipt.
    Now, I can't use First Aid, I can't Partition, etcetcetc...
    The only time I even see the Apple from the boot-up screen is when I have the Install Disk in.
    Does anyone have any idea what I could POSSIBLY do?
    I live in Tokyo, so it's hard to get help for me (My Japanese is bad.) I come to you with my simple request.
    Should and do I have to boot from an External HD? Do I have to just buy a new HD? Do I dare take it to the Apple Store? (Supposedly, they don't understand English)
    Right now, I'm using my brother's PC to get help. hasn't helped a bit. Please, please help me.

    I ran Terminal and typed in some commands someone told me to do...

    here's the URL for what I typed in
    (Looks sloppy in a forum, so I pasted it in Paint)
    It's a picture of essentially what I did.
    Please, please help.
    Here it is:

    Thank you for taking the time to read this.

    -Worried Mac owner

  2. #2

    Member Since
    Mar 11, 2004
    You could do a system archive and install, described in this thread. It refers to OS 10.2, but the thread dates from 2003. Archive and install itself hasn't changed.

    Any and all missing receipt packages would be replaced, along with the system. You'd have to go through the routine of updating the now slightly out-of-date DVD version of the system with Software Update, however.

  3. #3

    Member Since
    Apr 26, 2007
    I can't click on the Options button.
    The hard drive doesn't even appear when I want to try to Select a Destination to install it in, as if it doesn't even exist whatsoever.
    The connections and everything are fine.
    What's going on?

  4. #4

    BIG D 04's Avatar
    Member Since
    Oct 16, 2006
    Birmingham (S), UK
    20" iMac Intel Core Duo 2 (Standard)
    Maybe your Hard Drive is screwed?
    Damien Healy
    iMac 20" OSX 10.4.9 Tiger | |

  5. #5

    Member Since
    Apr 26, 2007
    That's what I'm thinking :-\

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. [Q]Unable to install os x due to
    By ProgrammingExp in forum OS X - Operating System
    Replies: 2
    Last Post: 08-24-2013, 11:20 PM
  2. Mr. Moore from Anchorage, KY… Missing a receipt?
    By indychris in forum iPhone Hardware and Accessories
    Replies: 2
    Last Post: 08-22-2012, 11:05 PM
  3. Can't install SL - missing files?
    By alexhey in forum OS X - Operating System
    Replies: 3
    Last Post: 05-22-2010, 06:16 PM
  4. Replies: 1
    Last Post: 03-13-2010, 10:59 AM
  5. Missing install discs - what do?
    By amagab in forum Apple Desktops
    Replies: 3
    Last Post: 10-12-2006, 04:39 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts