Results 1 to 6 of 6
  1. #1
    Exclamation Disk Permissions: HELP!!
    Ok, here it goes... I have my iMac 17'' 1,25GHz since December, and I've never checked my disk permissions. I know it's stupid, I should do it once every month, or every two weeks, or whatever. I'm doing it this very moment, and... guess what, they are ALL screwed up!!! Yes, every single one of them... It problably isn't something too serious, because my Mac only crashed twice, and in one of those crashes I had inserted some old weird PC backup disc, probably it was that thing that froze my system.
    Anyway, the error in EVERY single permission in my Mac is this:
    "should be -rw-rw-r-- , they are -rw-r--r-- "
    And no, I'm not exaggerating, they all have the same problem. I know what "r", "w" and "x" mean, I've used RedHat w/ Gnome in my old PeeCee for a month a few years ago, and even if I didn't use the terminal I understood how the filesystem worked... It seems that someone that shouldn't be able to write to those files has that permission... Heck! What can I do to correct this?
    And there's more... Is there any chance that my system could get screwed up if I actually fixed them with the disk utility? It works fine the way it is...
    Any thoughts on this subject? (btw, what should I do? )
    Oh, and btw, don't know if this is important... The original Software Backup disc had Jaguar in it, which I used for a few weeks, and then I upgraded to Panther with the disc that also came with the iMac. Can this problem have something to do with the upgrade?

  2. #2

    Member Since
    Jul 22, 2003
    Hamilton College
    20" iMac C2D 2.16ghz, 13" MacBook 2.0ghz, 60gb iPod vid, 1gb nano
    I have those permissions repaired sometimes as well....Do the full repair permissions then try it again to see the errors return
    I don't think you have anything to be worried about

    Did you upgrade to panther or do a clean install...If you upgraded that could cause problems...We always recommend that you do a clean install of it
    Don't forget to use the new User Reputation System

  3. #3

    Padawan's Avatar
    Member Since
    Jul 21, 2003
    Coruscant, Galactic Republic
    14" iBook G3 900/640/40 _ _ Power Macintosh G3 All-In-One 315/768/20 _ _ 20 GB iPod
    Quote Originally Posted by trpnmonkey41
    Do the full repair permissions then try it again to see the errors return
    I don't think you have anything to be worried about
    I agree. After all, that's the whole point of the "Repair Permissions" feature. You shouldn't have any problems after you repair them. In fact, I'd be surprised if your machine didn't actually perform better.

    Do you drive a Civic, Del Sol, or Integra & want more power & tighter steering feel? Click here for my inexpensive DIY Power-Steering Removal Kits.

  4. #4
    no worries about that...all its doing is telling you what wrong before fixing it...every time i fix permissions i get maybe 5 of them like that, tops
    and it's always the wrong permissions on that system sound "submarine.aiff" weird! and when i play it it pops pretty loud at the end
    oh well, its just a silly submarine

  5. #5
    Oh... sh*t! Now I get it...
    Ok... here's the problem... I've been fiddling with some of my apps... Yep, I'm using some haxies, incl. Metallifizer, and Safaricon, a small app for skinning Safari buttons (anyway, you must have already heard of it or even tried it)... Seems that the wrong permissions have to do with resource files...
    "User differs on ./Applications/, should be 0, owner is 501
    Permissions differ on ./Applications/, should be -rw-rw-r-- , they are -rw-r--r-- "
    See? It has to do with that damn Safari buttons! What d'you reckon? Should I just put it all like it was, uninstall Safaricon and repair disk permissions? Or can I just keep using it, and specially, if I do so, will Safari be affected after repairing the permissions (i.e. everything reverting to the default button appearance?)

  6. #6

    rman's Avatar
    Member Since
    Dec 24, 2002
    Los Angeles, California
    2 x 3.0GHz Quad-Core, 6GB OS X 10.6.8 | 15in MacBook Pro 2.2GHz OS X 10.6.8 | 64GB iPad 2 WiFi
    Al lot of the application that are installed on your system some times changes the file and directory permissions. That is why it is a good idea to run the disk utility to repair permission are installing or upgrading software.

    You should not have a problem after running repair permissions. In most cases thing will work better, that is why you hear about it so much.
    Life isn't about waiting for the storm to pass, It's about learning to dance in the rain!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 5
    Last Post: 05-06-2013, 05:51 PM
  2. Disk Utility Can't repair disk permissions
    By CakePie in forum OS X - Operating System
    Replies: 4
    Last Post: 01-23-2012, 03:48 PM
  3. Disk Utility - Repair Disk Permissions
    By SweetPea in forum OS X - Operating System
    Replies: 3
    Last Post: 06-09-2011, 06:11 PM
  4. Verify Disk Permissions (Disk Utility) and Little Snitch?
    By askclifford in forum Apple Desktops
    Replies: 2
    Last Post: 07-23-2010, 01:44 PM
  5. Onyx, Startup Disk Repair, Disk Permissions?
    By jdgti in forum OS X - Operating System
    Replies: 15
    Last Post: 07-24-2007, 02:46 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts