New To Mac-Forums?

Welcome to our community! Join the discussion today by registering your FREE account. If you have any problems with the registration process, please contact us!

Get your questions answered by community gurus Advice and insight from world-class Apple enthusiasts Exclusive access to members-only contests, giveaways and deals

Join today!

 
Start a Discussion
 

Mac-Forums Brief

Subscribe to Mac-Forums Brief to receive special offers from Mac-Forums partners and sponsors

Join the conversation RSS
OS X - Operating System General OS operation information and support

OS 10.4 - OSX updates and MS Office problems/CarbonLib


Post Reply New Thread Subscribe

 
Thread Tools
asmallsol

 
Member Since: Mar 21, 2007
Posts: 5
asmallsol is on a distinguished road

asmallsol is offline
I have a 13inch Macbook. In the past I have been able to update my machine no problem and have ran MS office again with no problems. However last week I get the message saying some stuff needs updates, so I clicked ok. It makes me put my password in and goes to download them. Then when it trys to install them, there is a message that pops up "all (fill in number) updates could not be installed blah blah blah... Sorry, an unexpected error occurred." The updates are iTunes, Quicktime, OSX update, and iPhoto.


Next problem I have encontured is when I try to open up MS word or Excel, I get an error box that says

The application "Excel" could not be launched because of a shared library error: "<Microsoft Excel><CarbonLib><CFMPriv_FindByContent><>"

From what I have read, CarbonLib is something from Pre OSX macs.

For the MS issue, I tried deleteing and reinstalling the program only to result in the same error box.

These two problems happened about the same time so they might be related, I am not sure. If you guys could give me some insight, I would appresiate it.
QUOTE Thanks
MacsWork

 
MacsWork's Avatar
 
Member Since: May 22, 2005
Location: Closer than you think.
Posts: 2,118
MacsWork is just really niceMacsWork is just really niceMacsWork is just really niceMacsWork is just really niceMacsWork is just really nice
Mac Specs: Performa 6116 2GBSCSI 8MB OS 7.5.3

MacsWork is offline
Before reinstalling office be sure to delete the office folder in the applications folder.
QUOTE Thanks
asmallsol

 
Member Since: Mar 21, 2007
Posts: 5
asmallsol is on a distinguished road

asmallsol is offline
I did do that, any other suggestions
QUOTE Thanks
asmallsol

 
Member Since: Mar 21, 2007
Posts: 5
asmallsol is on a distinguished road

asmallsol is offline
alright fooling around, I found the console. here are the errors I get.

When I try and open word or excel I get the following error

Microsoft Office 2004/Microsoft Word: launch failed with error code -2804 (cfragNoLibraryErr) for application -psn_0_28311553\n

and for excel

/Microsoft Office 2004/Microsoft Excel: launch failed with error code -2804 (cfragNoLibraryErr) for application -psn_0_28704769\n

When I try to install any of the updates, I don't get any errors in anything unless I look at the Installer Logs. If I do that (showing errors and progress) I get the following


Mar 22 13:05:42 computer : User picked Easy Install
Mar 22 13:05:42 computer : Choices selected for installation:
Mar 22 13:05:42 computer : Upgrade: "iTunes"
Mar 22 13:05:42 computer : Upgrade: "iTunes"
Mar 22 13:05:42 computer : ================================================== ==============================
Mar 22 13:05:42 computer : Preparing volume "Macintosh HD" for installation
Mar 22 13:05:42 computer : Configuring volume "Macintosh HD"
Mar 22 13:05:43 computer : Preparing local booted disk
Mar 22 13:05:43 computer : Create temporary directory "/private/tmp/iTunesX.pkg.27869PzqJ3c"
Mar 22 13:05:44 computer : run preflight script for iTunes
Mar 22 13:05:44 computer : Install failed: The following install step failed: run preflight script for iTunes
Mar 22 13:05:44 computer : Private/Total = (4.8MB, 63.9MB), Heap/Total = (2.1MB, 17.5MB), Regions(malloc, private) = (28, 29)
Mar 22 13:05:44 computer : It took 1.020505 seconds to unsuccessfully install "iTunes" (1 pkg(s))
Mar 22 13:05:44 computer : It took 1.004831 seconds to Configuring volume "Macintosh HD" (dm prepare*disk)
QUOTE Thanks
asmallsol

 
Member Since: Mar 21, 2007
Posts: 5
asmallsol is on a distinguished road

asmallsol is offline
my update, I called apple up and they had me reinstall macOSX with the archeive function so I didn't loose any files. Fixed both issues.
QUOTE Thanks
MacHeadCase
Guest
 
Posts: n/a

Welocme to Mac-Forums, asmallsol!

Glad it got fixed and that it's up and running well again.

And a big thank you in letting us know how the problem got solved. I'm sure this info will come in very handy for anyone having the same problem as you do! :girl:
QUOTE Thanks

Post Reply New Thread Subscribe


« In Mac OS X, how come files/apps can be renamed while being used? | What are these strange files on my HD ? »
Thread Tools

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off
Forum Jump

All times are GMT -4. The time now is 07:42 PM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
X

Welcome to Mac-Forums.com

Create your username to jump into the discussion!

New members like you have made this community the ultimate source for your Mac since 2003!


(4 digit year)

Already a member?