Mac Forums

Mac Forums (http://www.mac-forums.com/forums/)
-   OS X - Operating System (http://www.mac-forums.com/forums/os-x-operating-system/)
-   -   Help me removed "Help" from context menu (it isn't supposed to be there) (http://www.mac-forums.com/forums/os-x-operating-system/52839-help-me-removed-help-context-menu-isnt-supposed-there.html)

remain 02-02-2007 08:37 AM

Help me remove "Help" from Finder context menu (it isn't supposed to be there)
 
This is what I get if I right-click in a folder. (but not the Desktop)
It could be clicking either on a file/folder or in an empty space in the window.

---
http://img.photobucket.com/albums/v3..._menu_help.png
---

That first item "Help" does absolutely nothing.
I click on it, the menu disappears, and... no reaction.

And according to the replies to my other thread (and according to pictures I've found in Google),
this "Help" item isn't supposed to be there at all in Tiger.

I upgraded recently from 10.3 to 10.4.
I'm guessing this "Help" thing was in 10.3?


Does somebody have an idea?


Edit:
This is very weird, I made a new thread,
but somehow I messed up
and it changed the title of THIS thread.

And now, I can't change the thread title back.
What the heck??

Edit 2:
A moderator deleted my other new thread, apparently.
So I guess I'll just use this thread.


*The 3rd post (by Aptmunich) and 4th post were in reply to the original thread.*

remain 02-03-2007 06:22 PM

Bump.

Aptmunich 02-04-2007 05:48 AM

Hmm, I don't have a Help item in my context menu?

Has it always been there? Have you installed any apps that let you customize the context menu?

Maybe also check this folder to see if any add-ons have been installed:
"/Users/YOURUSER/Library/Contextual Menu Items"

remain 02-04-2007 10:07 AM

Hmm... I upgraded from 10.3 Panther. (I chose "Archive and Install")
Perhaps this is the reason?

Did Panther have a Help item at the top of the folder context menus?
Perhaps this is a remnant from Panther during my upgrade?



I checked Contextual Menu Items in both MY Library and the Library at the root level.

Nothing there.

remain 02-06-2007 01:21 AM

edit: mistake post

NanoBite 02-06-2007 03:24 AM

G'day remain, do you have MacJanitor or OnyX installed? They are maintenance apps and you should run one of them to clear out all the junk that builds up. OnyX (the one I use) will also repair Permissions and Optimise your Mac System. This might get rid of that Help option.

remain 02-06-2007 06:49 AM

Thanks for the suggestions.


I do have OnyX.

I repaired Permissions (albeit with Disk Utility)
and ran the Maintenance stuff with OnyX.

After a few restarts, the Help item is still there, useless as ever.


Got any more ideas? ;P


Does anyone know where the system file that stores the Finder's basic context menu items is?
(assuming there is even one)

I tried the Contextual Menu Items folders but there is nothing there.
So I assume the "Help" item, along with with the other basic items are kept elsewhere.

karudzo 02-06-2007 07:03 AM

Delete this file from YOURUSERNAME/Library/Preferences:
com.apple.finder.plist

You will lose any customizations for Finder, including Help (hopefully).

remain 02-07-2007 01:49 AM

I just tried it.
I backed up that file, then I deleted it and restarted Finder.

And... "Help" is still there!

ARGH! It's refusing to die!

immdb 02-07-2007 05:01 AM

you may be able to remove it with this utility…

http://www.macmod.com/content/view/865/


immdb

immdb 02-07-2007 05:07 AM

I just checked and mine also has help at the top of the list. Hmmm.

remain 02-07-2007 07:33 AM

You're using Tiger, right?

Did you upgrade from Panther as well?

Aptmunich 02-07-2007 04:44 PM

Wow, I was just switching between views in my Finder and I noticed I actually have the help menu there as well.

It seems to only appear when you're in the 'list' view.

Try switching to icon or column view - no 'help' context item. List view 'boom' it's back.

It does seem a little strange and I suppose it could be that we all have the same app installed that is causing this, but I'd guess it's just part of OS X's behaviour.

Why in the world it's there is another question though... I'll ask around at work tomorrow.


All times are GMT -4. The time now is 03:36 AM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.