New To Mac-Forums?

Welcome to our community! Join the discussion today by registering your FREE account. If you have any problems with the registration process, please contact us!

Get your questions answered by community gurus Advice and insight from world-class Apple enthusiasts Exclusive access to members-only contests, giveaways and deals

Join today!

 
Start a Discussion
 

Mac-Forums Brief

Subscribe to Mac-Forums Brief to receive special offers from Mac-Forums partners and sponsors

Join the conversation RSS
OS X - Operating System General OS operation information and support

OS 10.4 - Slow file copy only on ethernet from windows xp network share


Post Reply New Thread Subscribe

 
Thread Tools
Noxian

 
Noxian's Avatar
 
Member Since: Jun 17, 2006
Posts: 542
Noxian is a jewel in the roughNoxian is a jewel in the rough
Mac Specs: MacBook Pro 2.2ghz, 3GB, 250GB - 16GB White iPhone 3G - 2nd Gen 1GB Shuffle

Noxian is offline
I have a strange problem, when ever I try to copy a file from a windows xp share on my home network it goes VERY slow, and its only when I am using ethernet in OSX, if I use wifi it goes alot faster, if I use Bootcamp to boot into windows on my MacBook the ethernet works fine.

Any ideas what I can do to to fix this, There has to be a way to reset the ethernet driver in OSX
QUOTE Thanks
mac57

 
mac57's Avatar
 
Member Since: Apr 29, 2006
Location: St. Somewhere
Posts: 4,560
mac57 has a brilliant futuremac57 has a brilliant futuremac57 has a brilliant futuremac57 has a brilliant futuremac57 has a brilliant futuremac57 has a brilliant futuremac57 has a brilliant futuremac57 has a brilliant futuremac57 has a brilliant futuremac57 has a brilliant futuremac57 has a brilliant future
Mac Specs: iMac 27" 3.4 GHz, 256 GB SSD, 2 TB HDD, 8 GB RAM

mac57 is offline
This sounds like your ethernet link has set itself to 10 Mbps instead of the 100 Mbps (or 1000 Mbps) it is capabile of. I am not sure how to check and reset this on a Mac. Can anyone help?

My Macs: iMac 27" 3.4 GHz, Mac Pro 3.2 GHz, PowerMac G5 Quad 2.5 GHz, G4 Cube with 1.2 GHz Upgrade
My iStuff: 64GB iPhone 5, 64GB iPad4, 30GB iPod Video, 16GB iPod Touch
My OS': Mac OS X Lion, Mac OS X Snow Leopard, Mac OS X Tiger, Mac OS 9.2.2, openSUSE 10.3
I was on the Mac-Forums honor roll for September 2007
QUOTE Thanks
Noxian

 
Noxian's Avatar
 
Member Since: Jun 17, 2006
Posts: 542
Noxian is a jewel in the roughNoxian is a jewel in the rough
Mac Specs: MacBook Pro 2.2ghz, 3GB, 250GB - 16GB White iPhone 3G - 2nd Gen 1GB Shuffle

Noxian is offline
Quote:
Originally Posted by mac57
This sounds like your ethernet link has set itself to 10 Mbps instead of the 100 Mbps (or 1000 Mbps) it is capabile of. I am not sure how to check and reset this on a Mac. Can anyone help?
I have already tried all the possible settings for the transfer rate including half and full duplex, I also checked it on my PC,

It also seems the slow connectivity is only when coping files from one of my xp machines.
QUOTE Thanks
Noxian

 
Noxian's Avatar
 
Member Since: Jun 17, 2006
Posts: 542
Noxian is a jewel in the roughNoxian is a jewel in the rough
Mac Specs: MacBook Pro 2.2ghz, 3GB, 250GB - 16GB White iPhone 3G - 2nd Gen 1GB Shuffle

Noxian is offline
Ok I fixed the problem, Its a strange fix but it worked none the less

I had to reinstall the nic drivers on my XP desktop, then attempt connect to the network share on my MacBook, OS X said that the alias was broken and asked if I wanted to delete it I said yes, It then gave me a error saying I didnt have permisions, I then tried connecting to the share again, this time it was back at full speed, about 2-3 minutes to copy a 700meg file vs the 30-40 minutes I was getting before.

The strange thing is I tried uninstalling the nic then rebooting last night on my xp machine but I guess that didnt do the same as choosing update the drivers :S

Dont ask my why that fixed it but it did, I am sure if I was to talk to someone at apple they would tell me some cache or config file was corrupted and would give me a simple fix for it but oh well.

BTW I love fixing computers, Apple OS X or XP based
QUOTE Thanks
Noxian

 
Noxian's Avatar
 
Member Since: Jun 17, 2006
Posts: 542
Noxian is a jewel in the roughNoxian is a jewel in the rough
Mac Specs: MacBook Pro 2.2ghz, 3GB, 250GB - 16GB White iPhone 3G - 2nd Gen 1GB Shuffle

Noxian is offline
so the problem came back, I tried doing the same thing I did before but it didn't fix it Can anyone tell me how to reset my Ethernet configuration in OS X to factory defaults

I was thinking of doing a Archive and reinstall of OS X, does anyone know if I have to reinstall my apps after?
QUOTE Thanks
Ice Cream Man

 
Member Since: Nov 30, 2006
Location: Camp Douglas WI, for now
Posts: 250
Ice Cream Man has a spectacular aura about
Mac Specs: MacBook Pro 15, 1Gb RAM, 100GBHD, 2 Perfoma636CD, Apple, Apple IIe, + 2 PC, XP Pro 64bit, & ThinkPad

Ice Cream Man is offline
No, no, it's Windows, I'm not entirely sure but I think the Samba interface in windows is specificaly slowed. I think MS wants people only using their protocols. I have the same dificulties sometimes.
QUOTE Thanks
Noxian

 
Noxian's Avatar
 
Member Since: Jun 17, 2006
Posts: 542
Noxian is a jewel in the roughNoxian is a jewel in the rough
Mac Specs: MacBook Pro 2.2ghz, 3GB, 250GB - 16GB White iPhone 3G - 2nd Gen 1GB Shuffle

Noxian is offline
Quote:
Originally Posted by Ice Cream Man View Post
No, no, it's Windows, I'm not entirely sure but I think the Samba interface in windows is specificaly slowed. I think MS wants people only using their protocols. I have the same dificulties sometimes.
Ok why is it slow only on one of my 2 Windows XP computers, on the same network? And why does it work fine for a while then slow down to a crawl and time out file transfers, But I can upload files to the same Windows XP computer with out any problems but I cant download.
QUOTE Thanks
caribiner23

 
caribiner23's Avatar
 
Member Since: Feb 06, 2005
Location: Chicago
Posts: 1,499
caribiner23 is just really nicecaribiner23 is just really nicecaribiner23 is just really nicecaribiner23 is just really nicecaribiner23 is just really nice
Mac Specs: MacBook Pro Retina 13" among far too many other Apple products

caribiner23 is offline
Simple question, but did you turn off your Wifi connection on your Mac when you attempt this?

I've found that if I have both the ethernet and Airport connected and I try to copy to/from my XP machine performance is lousy. I always turn off the Airport on my MacBook before connecting a share to the PC, and that works nicely.
QUOTE Thanks
Noxian

 
Noxian's Avatar
 
Member Since: Jun 17, 2006
Posts: 542
Noxian is a jewel in the roughNoxian is a jewel in the rough
Mac Specs: MacBook Pro 2.2ghz, 3GB, 250GB - 16GB White iPhone 3G - 2nd Gen 1GB Shuffle

Noxian is offline
Quote:
Originally Posted by caribiner23 View Post
Simple question, but did you turn off your Wifi connection on your Mac when you attempt this?

I've found that if I have both the ethernet and Airport connected and I try to copy to/from my XP machine performance is lousy. I always turn off the Airport on my MacBook before connecting a share to the PC, and that works nicely.
I could have sworn I tried that, thinking the same thing you said, but i will try it again, Tonight.
QUOTE Thanks

Post Reply New Thread Subscribe


« MySQL client ODBC install | Some programs simply won't open... »
Thread Tools

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off
Forum Jump

Similar Threads
Thread
Thread Starter
Forum
Replies
Last Post
Burn .dmg file to CD on Windows, use on Mac hollerz1 Running Windows (or anything else) on your Mac 4 01-28-2010 03:22 PM
Powerbook on a Windows wireless network question jptl Internet, Networking, and Wireless 2 12-30-2006 09:51 AM
help with file sharing on windows network djrm Internet, Networking, and Wireless 9 09-14-2006 03:50 PM
Switcher Article in Today's Times studio34 Switcher Hangout 9 08-11-2006 03:10 PM
Windows 2003 Share Problems laxurs OS X - Operating System 0 12-09-2003 03:45 PM

All times are GMT -4. The time now is 10:42 AM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
X

Welcome to Mac-Forums.com

Create your username to jump into the discussion!

New members like you have made this community the ultimate source for your Mac since 2003!


(4 digit year)

Already a member?