New To Mac-Forums?

Welcome to our community! Join the discussion today by registering your FREE account. If you have any problems with the registration process, please contact us!

Get your questions answered by community gurus Advice and insight from world-class Apple enthusiasts Exclusive access to members-only contests, giveaways and deals

Join today!

 
Start a Discussion
 

Mac-Forums Brief

Subscribe to Mac-Forums Brief to receive special offers from Mac-Forums partners and sponsors

Join the conversation RSS
OS X - Operating System General OS operation information and support

OS 10.4 - need some help


Post Reply New Thread Subscribe

 
Thread Tools
unplugged

 
Member Since: Jun 14, 2006
Posts: 140
unplugged will become famous soon enough

unplugged is offline
Ok, here is my story.

I have a MacBook - 2.0Ghz. I had upgraded to 10.4.7 (when released), then to 10.4.8 (this past week) - I had a lot of problems when I updated to 10.4.8. My file permissions were off, opening programs was slow, etc. Then in sleep mode, it would never wake up properly. I could see some image, but the screen was pretty much black and no matter how much i tried to brighten the screen with the key, it would stay dark. So I wiped out the system. Then I did the install and upgraded to 10.4.7. Things were still acting funny, so I wiped it again. No difference. Now I can't even install MS Office, Toast 7, etc without the install stopping half way or not even starting at all.

Is there anyway I can bring back my mac book to the older firmware when I first got it? This is my first Mac purchase and right now i'm no longer happy with it. Any ideas?

MacBook Pro - 2.33Ghz, 2GB, SuperDrive, OS X 10.4.10
http://web.mac.com/mhadjar/
QUOTE Thanks
NanoBite

 
Member Since: Oct 27, 2005
Posts: 4,714
NanoBite is an unknown at this point

NanoBite is offline
Quote:
Originally Posted by unplugged
Ok, here is my story.

I have a MacBook - 2.0Ghz. I had upgraded to 10.4.7 (when released), then to 10.4.8 (this past week) - I had a lot of problems when I updated to 10.4.8. My file permissions were off, opening programs was slow, etc. Then in sleep mode, it would never wake up properly. I could see some image, but the screen was pretty much black and no matter how much i tried to brighten the screen with the key, it would stay dark. So I wiped out the system. Then I did the install and upgraded to 10.4.7. Things were still acting funny, so I wiped it again. No difference. Now I can't even install MS Office, Toast 7, etc without the install stopping half way or not even starting at all.

Is there anyway I can bring back my mac book to the older firmware when I first got it? This is my first Mac purchase and right now i'm no longer happy with it. Any ideas?
Hi, there have been problems for some with this recent update, myself having to uninstall the latest version of QuickTime due to playback issues.

Have you tried verifying/repairing the HD?
QUOTE Thanks
unplugged

 
Member Since: Jun 14, 2006
Posts: 140
unplugged will become famous soon enough

unplugged is offline
I tried everything in Disk Utility

MacBook Pro - 2.33Ghz, 2GB, SuperDrive, OS X 10.4.10
http://web.mac.com/mhadjar/
QUOTE Thanks

Post Reply New Thread Subscribe


« Reset master password with new copy of os x? | Still need help installing »
Thread Tools

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off
Forum Jump

All times are GMT -4. The time now is 10:20 PM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
X

Welcome to Mac-Forums.com

Create your username to jump into the discussion!

New members like you have made this community the ultimate source for your Mac since 2003!


(4 digit year)

Already a member?