Mac Forums

Mac Forums (http://www.mac-forums.com/forums/)
-   OS X - Operating System (http://www.mac-forums.com/forums/os-x-operating-system/)
-   -   Multiple Application Entries in "Open With" (http://www.mac-forums.com/forums/os-x-operating-system/43252-multiple-application-entries-open.html)

ezhangin 10-13-2006 01:49 AM

Multiple Application Entries in "Open With"
 
I really figured this one would already be on here but it didn't show up on search, so here it goes:

Let's say I want to open an audio file in VLC. When I right click to open with VLC I get two entries for VLC (along with 3 quick time players and two iTunes?!). I of course tried repair permissions and this did not get rid of the mysterious multiple applications :oneye: . So here are my theories:

I recently attached an iBook and a MacBook to my computer while they were in firewire mode, do you think my computer is still seeing these applications from other people's computers? (I could use their applications)

Or my other theory which is that maybe something is messed up in my receipts folder but then again I'm not entirely sure what the point of that folder is yet. (Besides seeing what installers have been run)

Anyone got an idea? I could attach a picture but I think this is pretty straightforward.

PowerBookG4 10-13-2006 01:55 AM

I would say delete the .plist files that have to do with the programs that are showing up more then once, maybe one of those files is telling the computer it exists more the once.

The receipts folder is where your permissions are stored, when repairing permissions the computer checks the permissions of the files on your hd compared to what they are in that folder and if they are different the computer fixes it.

ezhangin 10-13-2006 02:02 AM

Hey thanks for the information on the receipts folder!

I deleted the pref file for VLC and it didn't change anything, oh well. I appreciate the help regardless though.

PowerBookG4 10-13-2006 02:17 AM

No problem, that is a weird one though. Hopefully somebody else here will know the answer, I am always looking to grow in knowledge and this is something I would like to know.

ezhangin 10-13-2006 06:41 PM

bump for weird topic

novicew 10-13-2006 06:52 PM

Quote:

Originally Posted by ezhangin
bump for weird topic

In theory it is not possible to have any file with the same name in the same folder. I would assume this is more of a memory problem. Restarting the Mac might help.

ezhangin 10-13-2006 06:58 PM

Maybe, but I love my uptime! :dive:

novicew 10-13-2006 07:08 PM

Type killall Finder in terminal and hit enter. This will refresh Finder.

kersten78 11-08-2007 10:40 PM

Sorry to bump such an old thread, but this is the first one that turned up in search. Has anyone had any luck fixing this issue? It's driving me insane. So far, I've tried restarting, killing Finder via `killall Finder`, and using lsregister to rebuild launch services, i.e. from a superuser terminal:
Code:

root# /System/Library/Frameworks/ApplicationServices.framework/Frameworks/LaunchServices.framework/Support/lsregister -kill -r -domain local -domain system -domain user
So far, no luck. If anyone has had any success cleaning up the "Open With" menu, please let me know.

ezhangin 11-09-2007 11:45 AM

Yup, I fixed it. You have to rebuild/restart (not sure what the correct term is here) launch services database. I used Onyx to do it and it worked.

kersten78 11-09-2007 12:45 PM

Very strange. I wonder why doing it from the command line didn't alleviate the problem.


All times are GMT -4. The time now is 08:23 PM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.