Page 1 of 2 12 LastLast
Results 1 to 15 of 24
  1. #1
    MacInWin
    Guest
    Yosemite and a printer driver that broke
    I have a label printer on my Mac. The driver for the printer installs foomatic-rip, ghostscript and hpijs (the engine of the printer is from H-P, but it's NOT an HP printer, so they don't help). The combination worked well on Mavericks, but when I upgraded to Yosemite, something broke. I am getting a error in the printer que that the job is "Stopped - "Filter" failed" and nothing prints. I looked at the CUPS error log and saw this:

    D [17/Oct/2014:15:40:17 -0400] [Job 7] --> Output goes directly to the renderer now.
    D [17/Oct/2014:15:40:17 -0400] [Job 7] Starting renderer
    D [17/Oct/2014:15:40:17 -0400] [Job 7] renderer PID kid4=766
    D [17/Oct/2014:15:40:17 -0400] [Job 7] renderer command: gs -q -dBATCH -dPARANOIDSAFER -dQUIET -dNOPAUSE -sDEVICE=ijs -sIjsServer=zeo -sDeviceManufacturer="HEWLETT-PACKARD" -sDeviceModel="quicklabel zeo" -dDEVICEWIDTHPOINTS=216 -dDEVICEHEIGHTPOINTS=151 -dDuplex=false -r300 -sIjsParams=Quality:MediaType=1,Quality:Quality=2,Q uality:ColorMode=2,QualityenSet=2,PS:MediaPosition=7 -dIjsUseOutputFD -sOutputFile=- -
    D [17/Oct/2014:15:40:17 -0400] [Job 7] JCL: <job data>
    D [17/Oct/2014:15:40:17 -0400] [Job 7] sh: gs: command not found
    D [17/Oct/2014:15:40:17 -0400] [Job 7] renderer return value: 127
    D [17/Oct/2014:15:40:17 -0400] [Job 7] renderer received signal: 127
    D [17/Oct/2014:15:40:17 -0400] [Job 7] tail process done writing data to STDOUT
    D [17/Oct/2014:15:40:17 -0400] [Job 7] KID4 finished
    D [17/Oct/2014:15:40:17 -0400] [Job 7] Process dying with "The renderer command line returned an unrecognized error code 127.", exit stat: 1
    D [17/Oct/2014:15:40:17 -0400] [Job 7] error: No such file or directory (2)
    D [17/Oct/2014:15:40:17 -0400] [Job 7] The renderer command line returned an unrecognized error code 127.
    D [17/Oct/2014:15:40:17 -0400] [Job 7] Wrote 1 pages...
    D [17/Oct/2014:15:40:17 -0400] [Job 7] PID 759 (/usr/libexec/cups/filter/pstops) exited with no errors.
    D [17/Oct/2014:15:40:17 -0400] [Job 7] Found: %%PageTrailer
    D [17/Oct/2014:15:40:17 -0400] [Job 7] --> Continue DSC parsing now.
    D [17/Oct/2014:15:40:17 -0400] [Job 7] Found: %%Trailer
    D [17/Oct/2014:15:40:17 -0400] [Job 7] --> Continue DSC parsing now.
    D [17/Oct/2014:15:40:17 -0400] [Job 7] Found: %%Pages: 1
    D [17/Oct/2014:15:40:17 -0400] [Job 7] --> Continue DSC parsing now.
    D [17/Oct/2014:15:40:17 -0400] [Job 7] Found: %%BoundingBox: 0 0 151 216
    D [17/Oct/2014:15:40:17 -0400] [Job 7] --> Continue DSC parsing now.
    D [17/Oct/2014:15:40:17 -0400] [Job 7] Found: %%EOF
    D [17/Oct/2014:15:40:17 -0400] [Job 7] --> Continue DSC parsing now.
    D [17/Oct/2014:15:40:17 -0400] [Job 7] Closing renderer
    D [17/Oct/2014:15:40:17 -0400] [Job 7] KID4 exited with status 0
    D [17/Oct/2014:15:40:17 -0400] [Job 7] KID3 exited with status 1
    D [17/Oct/2014:15:40:17 -0400] [Job 7] Renderer exit stat: 1
    D [17/Oct/2014:15:40:17 -0400] [Job 7] Renderer process finished
    D [17/Oct/2014:15:40:17 -0400] [Job 7] Killing process 765 (KID3)
    D [17/Oct/2014:15:40:17 -0400] [Job 7] Process dying with "Error closing renderer", exit stat: 1
    D [17/Oct/2014:15:40:17 -0400] [Job 7] error: Broken pipe (32)
    D [17/Oct/2014:15:40:17 -0400] [Job 7] Error closing renderer
    D [17/Oct/2014:15:40:17 -0400] [Job 7] PID 760 (/usr/libexec/cups/filter/foomatic-rip) stopped with status 1.
    I see the first error is the shell reporting a gs failure, which then seems to ripple down until the job aborts. I am NOT a wiz at this stuff, but does anybody have a suggestion for what is really wrong? Will getting an updated foomatic-rip, gs or hpijl do anything? If so, where might I get such animals safely?

    Thanks in advance!

    EDIT, the smiley face in the log is not really a smiley face, it's a ":" followed by "P".

  2. #2


    Member Since
    Oct 22, 2014
    Posts
    3
    yosemite and foomatic printer driver
    I had a similar problem with my HP PSC750 supplied with a levelone wlan print server.
    The problem ist simply the sandboxing of yosemite. The whole foomatic-software including hpijs and gostscript is normally installed in /usr/local/bin, where cups has no access in yosemite. I solved the problem by copying the whole content of /usr/local/bin into /usr/libexec/cups/filter. In this directory you must remove the link to foomatic-rip in /usr/local/bin before.

    example:

    cd /usr/libexec/cups/filter
    sudo rm foomatic-rip

    cd /usr/local/bin
    sudo cp * /usr/libexec/cups/filter

    (if you have installed a lot of other software in /usr/local/bin, it is better not to copy all files, of course)

  3. #3


    Member Since
    Oct 22, 2014
    Posts
    1
    Hello, I am receiving the same error message with a xerox Workcentre 6015 driver.

    Before I go ahead and try your solution, do you think it is necessary or should I just wait for an update from xerox? I don't really understand what "cups" and "hpijs" is, so am not sure if it would work.

    Thanks

    Edit: forgot to mention that I only get the error when I try to print more than 1 copy. I can press command-P and hit enter all day long, no problem, but I'd like to be able to set e.g. 50 copies and walk away
    Last edited by hamdogger; 10-22-2014 at 02:02 PM. Reason: forgot to include important information

  4. #4
    MacInWin
    Guest
    Quote Originally Posted by wue5 View Post
    I had a similar problem with my HP PSC750 supplied with a levelone wlan print server.
    The problem ist simply the sandboxing of yosemite. The whole foomatic-software including hpijs and gostscript is normally installed in /usr/local/bin, where cups has no access in yosemite. I solved the problem by copying the whole content of /usr/local/bin into /usr/libexec/cups/filter. In this directory you must remove the link to foomatic-rip in /usr/local/bin before.

    example:

    cd /usr/libexec/cups/filter
    sudo rm foomatic-rip

    cd /usr/local/bin
    sudo cp * /usr/libexec/cups/filter

    (if you have installed a lot of other software in /usr/local/bin, it is better not to copy all files, of course)
    Did that, now getting an error that the printer is not installed and to contact the vendor. I gave up, installed Win7 in Parallels, moved my CS6 suite to the Windows machine and am now printing using the Windows driver. It's dead slow compared to the OS X version, but it works.

  5. #5


    Member Since
    Oct 22, 2014
    Posts
    3
    Quote Originally Posted by hamdogger View Post
    Hello, I am receiving the same error message with a xerox Workcentre 6015 driver.

    Before I go ahead and try your solution, do you think it is necessary or should I just wait for an update from xerox? I don't really understand what "cups" and "hpijs" is, so am not sure if it would work.

    Thanks

    Edit: forgot to mention that I only get the error when I try to print more than 1 copy. I can press command-P and hit enter all day long, no problem, but I'd like to be able to set e.g. 50 copies and walk away

    CUPS means Common Unix Printing System, the developing company belongs to apple, hpijs is a printer driver system from hp for linux which has been adapted also to OS X. foomatic-rip is the part of this system which is a so called "filter", a program which has to look what to do with the printing data coming from the application which wants to print, and call the appropriate other programs e.g. ghostscript in order to produce the data format needed by the printer.

    The problem I had and probably all foomatic-rip - users have is that the new version of CUPS (i.e. the printing system of yosemite) is not allowed to execute programs which are not in the directory /user/libexec/cups for security reasons. (this type of restriction is called sandboxing)

    Your problem seems to be something else, otherwise you could not print 1 page.

  6. #6


    Member Since
    Oct 22, 2014
    Posts
    3
    Quote Originally Posted by MacInWin View Post
    Did that, now getting an error that the printer is not installed and to contact the vendor. I gave up, installed Win7 in Parallels, moved my CS6 suite to the Windows machine and am now printing using the Windows driver. It's dead slow compared to the OS X version, but it works.
    I am very sorry that I could not help you, my PSC750 is now running perfectly with foomatic-rip, hpijs, ghostscript and yosemite.
    Did you look whether the whole software-stuff was really in the /usr/libexec/cups/filter directory after the operation?
    I am asking because I myself made a small mistake when I tried it the first time (I typed "filters" instead of "filter") and the result was just a file "filters" in the /usr/libexec/cups directory and not the whole software package in the "/usr/libexec/cups/filter" directory)
    Last edited by wue5; 10-22-2014 at 02:45 PM.

  7. #7


    Member Since
    Oct 24, 2014
    Posts
    3
    Yosemity sends hpijs go plity
    Hey Mr. MacInWin

    This is another approach.
    Close to the one of wue5, but more specific.
    And it worked for me.

    Actually I did not feel like copying everything from local/bin to cups/filter.

    So, what is there ?
    There are some gs*-files in usr/local/bin.
    There is the original of the foomatic-rip
    There is hpijs.
    Which might be the full load of the hpijs printing solution.

    I copied these files
    ( meaning : all files starting with gs, then foomatic-rip and hpijs )
    over to usr/libexec/cups/filter
    (I renamed the foomatic-rip-link in the target dir before, but…).

    AND THAT DID IT.

    When testing, a first time the printer driver will say it has to correct access
    (I guess it is foomatic-rip, which is not in his line of way to see things),
    which it does and then is ready to print on the next go.
    And luckily everything finds everything.


    on my tab:

    I have a HP Deskjet 1220C (the one that does A3)
    and think it is a BITTER PILL,
    that HP can not support this machine on actual OSXs ( for years now ),
    just because Apple goes cups.
    The printer was expensive and a PRO style gadget
    and - most important - still works perfectly.
    They built it to last and then the wind blew them elsewhere.
    So… Go your way HP. And thanks to the guys who did hpijs.

    mitch

  8. #8
    MacInWin
    Guest
    Thanks. Those files were copied, but as I said, now when I choose the printer from within Photoshop, it says I need to install the driver, which was the entire purpose of moving the files. So as I said, I've given up and go the virtual windows machine route. It's very slow, but I'm getting used to it.

    I tried deleting the printer and adding it back, but it reports that the printer driver is improperly installed. When I reinstall the driver, the files go to the OLD location again and the original problem of failing filter appears. I'm in an endless do-loop, but I do appreciate the support. It just isn't working.

  9. #9


    Member Since
    Oct 24, 2014
    Posts
    3
    Josy and the hip js
    I copied, I did not move.
    There still might be someone to look for things in /usr/local/bin.

  10. #10
    MacInWin
    Guest
    Yeah, I tried both and get different results. With the COPY the original problem remained of "filter failure" then when I moved, it said the driver wasn't installed. I reinstalled the driver and filter failure returned. So now I have the files in both locations and get the Filter Failed report on the printer queue. I suspect the driver has hard coded the path to the library, so that when I move it, it fails and looks uninstalled and when I have it in the expected locations I run into the problem wue5 described. So, basically, I'm stuck. For now, it's Win7 or nothing.

  11. #11


    Member Since
    Oct 24, 2014
    Posts
    3
    Josy and the printer flippers
    Well. Luckily enough. It worked for me.
    Using the latest edition of hpijs (saying 3.10.6.15).
    But of course the risk - that there are links you can not satisfy that (simple) way - is high.
    And of course - I would be very happy to see a Josy’s edition of hpijs.

    I was using the default PCL-driver in the meantime.
    If you block it on 600dpi, the quality is ok. (300 is just awful!)
    Just won't give you color.

    mitch

  12. #12


    Member Since
    Nov 04, 2014
    Posts
    2
    Printers are not responding after installing Yosemite
    I have a Mac Pro, I installed Yosemite and now my printer at home, a Minolta pagePro 1350W is not responding. At work, the HPs are not responding and the RICOH copy machines either. All gives this message. stopped "Filter" failed

  13. #13
    MacInWin
    Guest
    Yep. That's it. Here is a link to something that MIGHT work: https://discussions.apple.com/thread...art=0&tstart=0

    It didn't work for me, but it has worked for others to get rid of the Filter failure. Good luck with it, it's about all I've found to try.

  14. #14


    Member Since
    Nov 04, 2014
    Posts
    2
    I just tried your suggestion and I had to follow the directions in the scrip downloaded and it did made my PagePro 1350w to work. Do not expect a file lie othetrs it will be a text with instruction to follow, like writing the password for the computer administrator and accepting to modify the printer. WOW I am so happy> Let's see if it works for the rest of my printers and copy machine at work. Thaks again!

  15. #15


    Member Since
    Nov 07, 2014
    Posts
    1
    Thumbs up Excellent Fix
    I used your example to add a Samsung ML-1430 to three Yosemite Macs using the foomatic/gdi driver. Thank you.

    QUOTE
    cd /usr/libexec/cups/filter
    sudo rm foomatic-rip

    cd /usr/local/bin
    sudo cp * /usr/libexec/cups/filter
    QUOTE

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. My mac (OS X Yosemite) won't read my printer driver through my USB Superdrive
    By Zeline_Z in forum Other Hardware and Peripherals
    Replies: 5
    Last Post: 04-06-2015, 07:02 PM
  2. printer driver
    By james tc in forum Other Hardware and Peripherals
    Replies: 6
    Last Post: 03-13-2015, 11:56 AM
  3. Yosemite Broke Vim??
    By gmark99 in forum macOS - Operating System
    Replies: 4
    Last Post: 11-06-2014, 07:28 PM
  4. Broke Printer
    By ssej in forum Switcher Hangout
    Replies: 3
    Last Post: 05-07-2014, 03:14 PM
  5. Printer driver for Fuji Xerox printer, please help!
    By riverteeth in forum Other Hardware and Peripherals
    Replies: 2
    Last Post: 04-19-2008, 12:20 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •