New To Mac-Forums?

Welcome to our community! Join the discussion today by registering your FREE account. If you have any problems with the registration process, please contact us!

Get your questions answered by community gurus Advice and insight from world-class Apple enthusiasts Exclusive access to members-only contests, giveaways and deals

Join today!

 
Start a Discussion
 

Mac-Forums Brief

Subscribe to Mac-Forums Brief to receive special offers from Mac-Forums partners and sponsors

Join the conversation RSS
OS X - Operating System General OS operation information and support

OS 10.4 - Having a bit of a visual problem after installing new fonts.


Post Reply New Thread Subscribe

 
Thread Tools
herkalees

 
Member Since: Jan 17, 2006
Location: Beverly, Massachusetts
Posts: 31
herkalees is on a distinguished road
Mac Specs: 2011 MacBook Pro; 8GB RAM; 256GB SSD; 27" Thunderbolt Display

herkalees is offline
I installed a good amount of new fonts today, mostly .ttfs. Soon after, I noticed a couple of my apps were acting funny (see attachments).

iTunes is completely daffy, and Mail seems to have some spacing issues (notice the blue circles in the attachment).

After seeing how iTunes' new font-of-choice was something that looked Chinese or Japanese, I opened Font Book and deleted all things chinese/japanese/korean. After re-opening iTunes, it's still screwy.

Is there something I can do to fix the issues you'll see in the attachments?
Attached Images
File Type: gif Picture-2.gif (190.4 KB, 17 views)
File Type: gif Picture-3.gif (138.5 KB, 15 views)
QUOTE Thanks
deus_ex_machina

 
deus_ex_machina's Avatar
 
Member Since: Aug 06, 2004
Location: Tejas
Posts: 1,720
deus_ex_machina is just really nicedeus_ex_machina is just really nicedeus_ex_machina is just really nicedeus_ex_machina is just really nicedeus_ex_machina is just really nice
Mac Specs: 2GHz Mac Mini 2GB RAM 160GB 10.6.2 | MDD DP 1.25GHz G4 1.5GB RAM 10.4.11 | 233MHz iMac G3 10.3.9

deus_ex_machina is offline
looks like it got in your system fonts and it searched for replacements. I'd go into you actual system folder and check it out for sure.
QUOTE Thanks
shetz

 
shetz's Avatar
 
Member Since: Feb 22, 2006
Location: Philippines
Posts: 57
shetz is on a distinguished road
Mac Specs: 2 X 2.66 GHz Dual-Core Intel Xeon 2GB RAM Mac OS X 10.5

shetz is offline
Had a bit of a problem (myself) with fonts before, after I upgraded from Jaguar to Tiger. The fonts in Safari became Malaylum, or something like it. Nothing was readable; the fonts in Mail got messed up too. Restarting proved to fix the Mail problem, but not for Safari. Luckily, I made a new folder inside Library/Fonts labeled "Added Fonts," and after deleting the said added fonts, my system returned to normal. What I did afterwards, was to painstakingly add fonts (that I was unsure of, not the ones that I'd added and used before in Jag) one (or two) at a time, restart, and check that my Apps didn't get screwed up. My system worked fine afterwards.

Hope this helps. :yinyang:
Attached Images
File Type: jpg Fonts-Folder.jpg (44.1 KB, 6 views)
File Type: jpg Added-Fonts-Folder.jpg (35.1 KB, 4 views)

He who laughs last will often find that he has no one to laugh with.
QUOTE Thanks
deus_ex_machina

 
deus_ex_machina's Avatar
 
Member Since: Aug 06, 2004
Location: Tejas
Posts: 1,720
deus_ex_machina is just really nicedeus_ex_machina is just really nicedeus_ex_machina is just really nicedeus_ex_machina is just really nicedeus_ex_machina is just really nice
Mac Specs: 2GHz Mac Mini 2GB RAM 160GB 10.6.2 | MDD DP 1.25GHz G4 1.5GB RAM 10.4.11 | 233MHz iMac G3 10.3.9

deus_ex_machina is offline
Quote:
Originally Posted by shetz
Had a bit of a problem (myself) with fonts before, after I upgraded from Jaguar to Tiger. The fonts in Safari became Malaylum, or something like it. Nothing was readable; the fonts in Mail got messed up too. Restarting proved to fix the Mail problem, but not for Safari. Luckily, I made a new folder inside Library/Fonts labeled "Added Fonts," and after deleting the said added fonts, my system returned to normal. What I did afterwards, was to painstakingly add fonts (that I was unsure of, not the ones that I'd added and used before in Jag) one (or two) at a time, restart, and check that my Apps didn't get screwed up. My system worked fine afterwards.

Hope this helps. :yinyang:
I also ceased to use FontBook and opted for Extensis Suitcase, which is a far better font app IMHO.
QUOTE Thanks
shetz

 
shetz's Avatar
 
Member Since: Feb 22, 2006
Location: Philippines
Posts: 57
shetz is on a distinguished road
Mac Specs: 2 X 2.66 GHz Dual-Core Intel Xeon 2GB RAM Mac OS X 10.5

shetz is offline
Quote:
Originally Posted by deus_ex_machina
I also ceased to use FontBook and opted for Extensis Suitcase, which is a far better font app IMHO.
Yeah, FontBook blows chunks, it was too dang slow (kept having to refresh and refresh and refresh and...). Incidentally, I haven't used Extensis Suitcase since OS 9; the removal of the font limit restriction (from OS 9) allowed me to easily add and remove fonts without worry. By managing my fonts manually, I know what fonts I have installed, and can save myself the hassle of picking and knowing what fonts are active, disabled, etc.

Still @ herkalees, unless you're very familiar with your fonts, I suggest you opt for deus_ex's suggestion about Suitcase. It might be exactly what you need.

He who laughs last will often find that he has no one to laugh with.
QUOTE Thanks
herkalees

 
Member Since: Jan 17, 2006
Location: Beverly, Massachusetts
Posts: 31
herkalees is on a distinguished road
Mac Specs: 2011 MacBook Pro; 8GB RAM; 256GB SSD; 27" Thunderbolt Display

herkalees is offline
Thanks guys, I sorted it out the hard way
QUOTE Thanks

Post Reply New Thread Subscribe


« iSync with sony ericsson | Questions about deleting user folder and another about trash bin »
Thread Tools

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off
Forum Jump

Similar Threads
Thread
Thread Starter
Forum
Replies
Last Post
Installing fonts - little help? tafika OS X - Operating System 2 06-24-2005 12:31 PM
Bit Torrent problem nobody can solve.. phatsew Schweb's Lounge 11 02-09-2005 01:52 AM
Problem Installing OS X idlingmike OS X - Operating System 1 12-19-2004 12:56 AM
Installing True Type Fonts edgar OS X - Operating System 0 11-03-2004 11:08 AM
fonts problem idea3 OS X - Operating System 0 05-17-2004 09:05 PM

All times are GMT -4. The time now is 02:28 PM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
X

Welcome to Mac-Forums.com

Create your username to jump into the discussion!

New members like you have made this community the ultimate source for your Mac since 2003!


(4 digit year)

Already a member?