New To Mac-Forums?

Welcome to our community! Join the discussion today by registering your FREE account. If you have any problems with the registration process, please contact us!

Get your questions answered by community gurus • Advice and insight from world-class Apple enthusiasts • Exclusive access to members-only contests, giveaways and deals

Join today!

 
Start a Discussion
 

Mac-Forums Brief

Subscribe to Mac-Forums Brief to receive special offers from Mac-Forums partners and sponsors

Join the conversation RSS
OS X - Operating System General OS operation information and support

Hyperlink email address in email body


Post Reply New Thread Subscribe

 
Thread Tools
Kaitches

 
Member Since: Jun 04, 2014
Posts: 3
Kaitches is on a distinguished road

Kaitches is offline
when I type an email address into the body of a mail (I'm using Mac mail), it automatically hyperlinks the email address, but not the entire address. In the below example it typically only underlines bob@atkinson.co instead of underlining the entire address: bob@atkinson.co.za
How can I make it recognise the entire address?
QUOTE Thanks
MBP17•David

 
MBP17•David's Avatar
 
Member Since: Feb 04, 2014
Location: East Midlands, UK
Posts: 426
MBP17•David is a jewel in the roughMBP17•David is a jewel in the roughMBP17•David is a jewel in the rough
Mac Specs: MBP17 2010 8GB 2x960GB SSDs 10.9.4 • MBA11 2010 4GB 128GB 10.9.4 • TC 2TB • TV • iOS bunch

MBP17•David is offline
It should hyperlink the entire address, unless there's a gap between co. and za
Mail certainly does not discriminate against dual TLD - I know, as most of my domains are (co.uk, org.uk, me.uk, etc, etc)
Even doing something silly, like adding a few TLDs one after another, doesn't break the hyperlink:


actual Mail screenshot

Depending on your 'Composing' settings, you might not see hyperlinks underlined, while typing, until you save the draft or post the message. Have you tried to send it to yourself to see if the entire email address comes up underlined "on the other end"?

Dvid
QUOTE Thanks
Kaitches

 
Member Since: Jun 04, 2014
Posts: 3
Kaitches is on a distinguished road

Kaitches is offline
There is definitely no space - I've had this problem for a year or more. Yes, I have emailed it to myself and it does not appear all underlined.
It underlines as I type, but just stops when I get to the . for .za
QUOTE Thanks
MBP17•David

 
MBP17•David's Avatar
 
Member Since: Feb 04, 2014
Location: East Midlands, UK
Posts: 426
MBP17•David is a jewel in the roughMBP17•David is a jewel in the roughMBP17•David is a jewel in the rough
Mac Specs: MBP17 2010 8GB 2x960GB SSDs 10.9.4 • MBA11 2010 4GB 128GB 10.9.4 • TC 2TB • TV • iOS bunch

MBP17•David is offline
I've tried every possible combination of plain and rich text formats and a few other settings, but couldn't replicate the problem ...

As far, as I can see, there's no option to remove hyperlink from an email address in Mail, unlike other apps (and rightly so, of course), therefore no settings to play with as such.

What version of OS X and Mail are you running? Maybe someone with exact same setup can help ...

Dvid
QUOTE Thanks
Kaitches

 
Member Since: Jun 04, 2014
Posts: 3
Kaitches is on a distinguished road

Kaitches is offline

osx 10.9.3
QUOTE Thanks
MBP17•David

 
MBP17•David's Avatar
 
Member Since: Feb 04, 2014
Location: East Midlands, UK
Posts: 426
MBP17•David is a jewel in the roughMBP17•David is a jewel in the roughMBP17•David is a jewel in the rough
Mac Specs: MBP17 2010 8GB 2x960GB SSDs 10.9.4 • MBA11 2010 4GB 128GB 10.9.4 • TC 2TB • TV • iOS bunch

MBP17•David is offline
Quote:
Originally Posted by Kaitches View Post

osx 10.9.3
Well, that's what I have, but whatever I did, Mail always handles email hyperlinks correctly ...

Sorry I can't be of help

Dvid
QUOTE Thanks
pm-r

 
Member Since: Oct 16, 2010
Location: Brentwood Bay, BC, Canada
Posts: 474
pm-r is a jewel in the roughpm-r is a jewel in the rough

pm-r is offline
Maybe I just used Eudora for too long and still can't get Mail to work as I expect with Mavericks and all up to date, and I don't think I've evert been able to get an email address hyperlinked, at least while composing a message.

Adding an email address just sits in the message as plain text, and using Rich Text doesn't change anything.

So maybe we need to read up with some of the suggestions here:

How to Prevent Mac OS X Mail From Breaking Links in Emails - About Email

How to Insert a Link in an Email With Mac OS X Mail

What to Do When Mountain Lion Mail Fails to Auto-Complete Email Addresses

So I'm with the OP here!!
QUOTE Thanks

Post Reply New Thread Subscribe


« Search in Mail | Apple rant... slow down with the updates »
Thread Tools

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off
Forum Jump

Similar Threads
Thread
Thread Starter
Forum
Replies
Last Post
Email address extractor with filtering dcree OS X - Apps and Games 0 05-28-2014 03:26 PM
Reply mail sends from the wrong address mrotsliah OS X - Apps and Games 3 03-27-2014 09:03 PM
email - Configuring a mac.com address on a Samsung phone michelangelo Internet, Networking, and Wireless 1 03-26-2014 07:37 PM
email address book earley Switcher Hangout 6 03-20-2014 10:07 PM

All times are GMT -4. The time now is 08:15 AM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
X

Welcome to Mac-Forums.com

Create your username to jump into the discussion!

New members like you have made this community the ultimate source for your Mac since 2003!


(4 digit year)

Already a member?