Mac Forums

Mac Forums (http://www.mac-forums.com/forums/)
-   OS X - Operating System (http://www.mac-forums.com/forums/os-x-operating-system/)
-   -   iMac not sleeping (http://www.mac-forums.com/forums/os-x-operating-system/311631-imac-not-sleeping.html)

kathmat 05-22-2014 11:51 AM

iMac not sleeping
 
Hi - recently I have been having terrible problems with my iMac either not voluntarily sleeping after the 15 minute energy saving period, or on being put to sleep manually, waking up at a random time for no reason. I have checked my account/login items in preferences and could see nothing that would cause this, and do not have "wake for network access" selected. Any suggestions please as to what is causing this and what I can do to fix it? My iMac is in the bedroom and being awakened at two in the morning to a room filled with light feels like an episode from Close Encounters of the Third Kind. Thanks

nickyr 05-22-2014 12:58 PM

if there are absolutely no apps running then could it be a problem with your mouse perhaps?

try turning the mouse off and see if the problem still exists.

chscag 05-22-2014 01:26 PM

Try resetting your iMac's SMC (system management controller). It's easy to do:

Shut it down completely. Remove the AC plug from the outlet and let the machine set that way for about 15 minutes. Plug it back in, boot, and then reset all your power settings and sleep times once again. See if that works and let us know.

kathmat 05-22-2014 01:44 PM

Quote:

Originally Posted by nickyr (Post 1584094)
if there are absolutely no apps running then could it be a problem with your mouse perhaps?

try turning the mouse off and see if the problem still exists.

Oh! Swansea!! A thousand years since I have been there. Fond memories :) Sorry off topic, got carried away. Actually the mouse did occur to me, and one of the things I tried before posting was turning it off, but the problem continued. After posting however, I not only turned the mouse off, but turned bluetooth off as well, and on returning to the computer an hour later, it was still asleep.

I am going to have to try this again and see what happens. I am currently using a magic mouse and prior to this was using just a regular "hard-wired" Apple mouse when my last cordless died. I did not have the problem with the connected mouse.

Bit of a bother having to turn bluetooth off every time I am going to be away from the computer for more than an hour, but if that is what it takes...

Thank you.

kathmat 05-22-2014 01:46 PM

Quote:

Originally Posted by chscag (Post 1584112)
Try resetting your iMac's SMC (system management controller). It's easy to do:

Shut it down completely. Remove the AC plug from the outlet and let the machine set that way for about 15 minutes. Plug it back in, boot, and then reset all your power settings and sleep times once again. See if that works and let us know.

Thank you,

I will also try this once I am through with my current project. I don't want to shut it down now as I will lose the history on all open Photoshop files.

Raz0rEdge 05-22-2014 01:47 PM

The iMac doesn't wake up on mouse movement, only on mouse/trackpad/keyboard click.

nickyr 05-22-2014 01:47 PM

it probably hasn't changed much!!!

kathmat 05-22-2014 01:52 PM

iMac not sleeping
 
Quote:

Originally Posted by Raz0rEdge (Post 1584121)
The iMac doesn't wake up on mouse movement, only on mouse/trackpad/keyboard click.

True - but so far turning bluetooth off did seem to help. Fortunately I work primarily with a Wacom stylus, so just use that to turn the bluetooth back on. Then wait while the Magic Mouse once again becomes connected. Must say - not terribly impressed with the Magic Mouse.

Thank you.

harryb2448 05-22-2014 05:43 PM

What you describe Kath also happens with my 2012 iMac when either the trackpad (ditched the mouse) or keyboard batteries are getting low, less that 85% in System Preferences. The batteries seem to hold and hold at 100%, but when they start sliding they go really fast.

kathmat 05-22-2014 06:04 PM

Quote:

Originally Posted by harryb2448 (Post 1584158)
What you describe Kath also happens with my 2012 iMac when either the trackpad (ditched the mouse) or keyboard batteries are getting low, less that 85% in System Preferences. The batteries seem to hold and hold at 100%, but when they start sliding they go really fast.

My keyboard is not wireless. Can't say I am too thrilled with the performance of wireless devices. I know they free up USB ports and as it is I have to use a hub because I have two printers, a scanner, a Wacom table, the keyboard, various pen drives and a "Passport" external drive attached to my computer, but I find that the performance of wireless items are never the same. However, I am positive that my problem is bluetooth related, as I disabled the bluetooth twice since my last post and both times my iMac slept like a baby. The minute I enabled it - boom! The random waking up was back.

When my current work project is finished though and I am able to shut down Photoshop, I will try what chscag suggested and see if that helps.
Oi! Oi! Oi! ;D

kathmat 05-27-2014 10:09 AM

Quote:

Originally Posted by chscag (Post 1584112)
Try resetting your iMac's SMC (system management controller). It's easy to do:

Shut it down completely. Remove the AC plug from the outlet and let the machine set that way for about 15 minutes. Plug it back in, boot, and then reset all your power settings and sleep times once again. See if that works and let us know.

Hello :)
I still have not been able to try your suggestion (Photoshop history and all that...) BUT, while poking around this morning, I went into the advanced settings on "bluetooth" since I know that is where the problem originates. I unchecked the "allow bluetooth to wake computer", and since I do not have a wireless keyboard, and can still wake by hitting a key, that has definitely done the trick with regards to its waking. I have not been able to see if it goes to sleep on its own as I have not been away from the computer for the 15 minutes required. Well I have... but I was just testing the wake up feature so put it to sleep on my own. Just happy that it is not waking up. Labor Omnia Vincit! or in more current lingo - High five!

kathmat 05-29-2014 07:15 PM

Quote:

Originally Posted by chscag (Post 1584112)
Try resetting your iMac's SMC (system management controller). It's easy to do:

Shut it down completely. Remove the AC plug from the outlet and let the machine set that way for about 15 minutes. Plug it back in, boot, and then reset all your power settings and sleep times once again. See if that works and let us know.

Hi,

I was finally able to follow your instructions today, and while disabling the bluetooth wake feature did indeed cure the waking problem I was having, my Mac was still not going to sleep. In addition to doing as you suggested, I also changed the outlet plug that I was using on my APC surge protector that the Mac is hooked up to (I normally have it plugged into "master" but have noticed problems with that from time to time) to one of the non master plugs. Hallelujah my baby is now sleeping peacefully and not waking up until requested to do so.

Thank you very much, as this was starting to drive me quite bonkers.

chscag 05-29-2014 07:40 PM

Quote:

Hallelujah my baby is now sleeping peacefully and not waking up until requested to do so.
Great. Thanks for posting back and letting us know. Enjoy that nice Miami weather! :)


All times are GMT -4. The time now is 03:25 PM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.