New To Mac-Forums?

Welcome to our community! Join the discussion today by registering your FREE account. If you have any problems with the registration process, please contact us!

Get your questions answered by community gurus Advice and insight from world-class Apple enthusiasts Exclusive access to members-only contests, giveaways and deals

Join today!

 
Start a Discussion
 

Mac-Forums Brief

Subscribe to Mac-Forums Brief to receive special offers from Mac-Forums partners and sponsors

Join the conversation RSS
OS X - Operating System General OS operation information and support

Wifi-connection problems


Post Reply New Thread Subscribe

 
Thread Tools
electracat

 
Member Since: Apr 10, 2010
Posts: 6
electracat is on a distinguished road

electracat is offline
Hi everyone,
So, I have a Macbook from 2011. About two months ago, my long-time router died. I bought a new one, and I had trouble loading certain web pages, plus it was very slow. My friend had no trouble with his PC, though Google was acting weird for both of us. I then got another router, and my Mac is still very slow on it, though all pages load. My speeds are: 1.5mbps download, 4.5 upload. Friends who come over get 25mbps download. Also, my Mac gets about 20mbps download with other networks.
So...what does this mean? I just installed Mavericks and increased RAM (and now the Mac is faster, but still has trouble with lots of downloads and Netflix), I had a Mac expert look at the thing, and we still can't figure out why 1) my Mac cannot do well with my network when others can, and 2) my Mac connects fine to other networks.
Any advice welcome! Thanks a lot. Oh, and I've tried Firefox, and it's a little faster (was also having trouble playing Netflix on Safari--suddenly won't play well or load well on that, but does pretty ok on Firefox). Still the slow download and upload speeds.
Thanks so much for any advice!
QUOTE Thanks
harryb2448

 
harryb2448's Avatar
 
Member Since: Nov 28, 2007
Location: Nambucca Heads Australia
Posts: 18,141
harryb2448 has a reputation beyond reputeharryb2448 has a reputation beyond reputeharryb2448 has a reputation beyond reputeharryb2448 has a reputation beyond reputeharryb2448 has a reputation beyond reputeharryb2448 has a reputation beyond reputeharryb2448 has a reputation beyond reputeharryb2448 has a reputation beyond reputeharryb2448 has a reputation beyond reputeharryb2448 has a reputation beyond reputeharryb2448 has a reputation beyond repute
Mac Specs: iMac i5 2.7GHz, 16GB memory, OS 10.10.1

harryb2448 is offline
Reset the router and set up a new account, and in wireless opt for the 5GHz band if it is a dual band router.

Hang on to those original install discs like grim death! Using OS X.7 or later make a bootable USB thumb drive before running Installer!
QUOTE Thanks
electracat

 
Member Since: Apr 10, 2010
Posts: 6
electracat is on a distinguished road

electracat is offline
Thanks. Do you mean set up a new Mac account? I've already reset the router many times, but it's still slow.
QUOTE Thanks
harryb2448

 
harryb2448's Avatar
 
Member Since: Nov 28, 2007
Location: Nambucca Heads Australia
Posts: 18,141
harryb2448 has a reputation beyond reputeharryb2448 has a reputation beyond reputeharryb2448 has a reputation beyond reputeharryb2448 has a reputation beyond reputeharryb2448 has a reputation beyond reputeharryb2448 has a reputation beyond reputeharryb2448 has a reputation beyond reputeharryb2448 has a reputation beyond reputeharryb2448 has a reputation beyond reputeharryb2448 has a reputation beyond reputeharryb2448 has a reputation beyond repute
Mac Specs: iMac i5 2.7GHz, 16GB memory, OS 10.10.1

harryb2448 is offline
Did you set it up for the 5GHz band and a new Account in System Preferences > Network?

Hang on to those original install discs like grim death! Using OS X.7 or later make a bootable USB thumb drive before running Installer!
QUOTE Thanks
electracat

 
Member Since: Apr 10, 2010
Posts: 6
electracat is on a distinguished road

electracat is offline
I don't have a dual-band router...
QUOTE Thanks
harryb2448

 
harryb2448's Avatar
 
Member Since: Nov 28, 2007
Location: Nambucca Heads Australia
Posts: 18,141
harryb2448 has a reputation beyond reputeharryb2448 has a reputation beyond reputeharryb2448 has a reputation beyond reputeharryb2448 has a reputation beyond reputeharryb2448 has a reputation beyond reputeharryb2448 has a reputation beyond reputeharryb2448 has a reputation beyond reputeharryb2448 has a reputation beyond reputeharryb2448 has a reputation beyond reputeharryb2448 has a reputation beyond reputeharryb2448 has a reputation beyond repute
Mac Specs: iMac i5 2.7GHz, 16GB memory, OS 10.10.1

harryb2448 is offline
Sorry thought any new router would be dual band however proceed with a new account under Network and fingers crossed. Obviously from your description it is a computer network problem rather than your service.

Hang on to those original install discs like grim death! Using OS X.7 or later make a bootable USB thumb drive before running Installer!
QUOTE Thanks
electracat

 
Member Since: Apr 10, 2010
Posts: 6
electracat is on a distinguished road

electracat is offline
Thanks for the help! But, sorry, I'm a bit illeterate in these matters: Do you mean, create a new network after reinstalling the router? Can I create a new network with present router? How do I do this? Thanks for your help!! Sorry if I sound rather dumb...
QUOTE Thanks
electracat

 
Member Since: Apr 10, 2010
Posts: 6
electracat is on a distinguished road

electracat is offline
Help..!

I just tested the Mac with another network, and the speeds were much greater...So, it's definitely in how it connects to my home network. So strange!

Any other ideas? Very grateful...
QUOTE Thanks

Post Reply New Thread Subscribe


« What would keep re-enabling sleep mode? | Easiest way to install Windows »
Thread Tools

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off
Forum Jump

Similar Threads
Thread
Thread Starter
Forum
Replies
Last Post
Getting internet (probably wifi) on my Mac Pro durangotang Apple Desktops 27 04-21-2014 02:29 AM
Epson WF-2540 WIFI goes offline frequently JimInSD Other Hardware and Peripherals 7 04-12-2014 06:01 PM
Problems with wifi on Macbook Pro Retina late 2013 chparigi Apple Notebooks 1 03-30-2014 02:20 PM
Iphone 5s Microphone Distorts Live Video liberator32 iPhone Hardware and Accessories 4 03-18-2014 08:34 AM
iPhone 4S 16 GB Storage and Wifi Issues sahmed974 iPhone Hardware and Accessories 1 03-15-2014 10:20 PM

All times are GMT -4. The time now is 12:09 PM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
X

Welcome to Mac-Forums.com

Create your username to jump into the discussion!

New members like you have made this community the ultimate source for your Mac since 2003!


(4 digit year)

Already a member?