Results 1 to 4 of 4

Thread: Canon MP 600

  1. #1


    Member Since
    Jan 16, 2013
    Location
    Jessheim, norway
    Posts
    2
    Specs:
    2,9 GHz Intel Core i7, 8 GB 1600 MHz DDR3, 250GB SDD, OS X 10.9.2 (13C1021)
    Canon MP 600
    Unable to install the downloaded drivers from Canon. (Easy-PhotoPrint EX v. 4.5.0 (OS X 10.7/10.8/10.9) Running OSX 10.9.2.
    Seems like the driver installation in System tools does not recognize the downloaded drivers.

  2. #2


    Member Since
    Jan 16, 2013
    Location
    Jessheim, norway
    Posts
    2
    Specs:
    2,9 GHz Intel Core i7, 8 GB 1600 MHz DDR3, 250GB SDD, OS X 10.9.2 (13C1021)
    Help, anyone?

  3. #3

    chscag's Avatar
    Member Since
    Jan 23, 2008
    Location
    Fort Worth, Texas
    Posts
    48,782
    Specs:
    Late 2013 27" iMac, iPad 3, iPhone 6s+, iPhone 6+, 3 iPods, El Capitan
    Canon driver installation is more difficult than it should be. What you might have to do is first remove the printer and installed drivers and start over with the new ones. I had to do that on several occasions with my Canon printer that I had.

  4. #4


    Member Since
    Dec 11, 2010
    Location
    Chicago
    Posts
    1,474
    Specs:
    late 2012 mini w/SSD
    It says here that the driver for the MP600R is available on Apple's servers for auto-download. Is yours the 600R model?
    http://support.apple.com/kb/ht3669#canon-inkjet

    Apple has changed the way we get drivers for most compatible printers. They keep current drivers on their server and it gets auto-downloaded and installed when we Add the printer in Print & Scan prefs (or in a print dialog if it's a shared printer).
    If your Mac isn't doing that for you, you should Reset the Printing System, which rebuilds the database of available printers, plus other stuff.
    OS X Mavericks: Reset the printing system
    Last edited by gsahli; 05-19-2014 at 11:32 PM.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Canon Navigator for Canon MP560 stopped working
    By radiomother in forum Other Hardware and Peripherals
    Replies: 5
    Last Post: 02-05-2013, 07:15 PM
  2. Replies: 2
    Last Post: 09-10-2009, 06:00 PM
  3. Anybody with a Treo 600?
    By skye in forum Schweb's Lounge
    Replies: 5
    Last Post: 02-25-2007, 02:59 PM
  4. Print Quality of the Canon IP3000, relative to other Canon models??
    By VakeJ in forum Other Hardware and Peripherals
    Replies: 0
    Last Post: 03-06-2005, 02:59 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •