New To Mac-Forums?

Welcome to our community! Join the discussion today by registering your FREE account. If you have any problems with the registration process, please contact us!

Get your questions answered by community gurus • Advice and insight from world-class Apple enthusiasts • Exclusive access to members-only contests, giveaways and deals

Join today!

 
Start a Discussion
 

Mac-Forums Brief

Subscribe to Mac-Forums Brief to receive special offers from Mac-Forums partners and sponsors

Join the conversation RSS
OS X - Operating System General OS operation information and support

avoid auto-correct one time


Post Reply New Thread Subscribe

 
Thread Tools
jimka_2001

 
Member Since: May 07, 2014
Posts: 6
jimka_2001 is on a distinguished road

jimka_2001 is offline
When I type a word in safari (or several other places) on my macbook which the system thinks is misspelled, it pops up a small dialog showing my the auto correction. If I press space, the word I typed gets replaced by the suggested text.

How can I avoid this replacement and keep the word I typed?

I have seen that I can click the little x in the side of the pop-up, but this is very inconvenient for a touch typeset to have to move the hands and find the little x.

I tried pressing CMD-space, shift-space, cntl-space, and fn-space, but none of these works.

I DONT WANT to disable autocorrect globally nor locally. I JUST want to avoid auto-correct for the word I just now typed.

Thanks for the help.
Jim
QUOTE Thanks
harryb2448

 
harryb2448's Avatar
 
Member Since: Nov 28, 2007
Location: Nambucca Heads Australia
Posts: 16,922
harryb2448 has a reputation beyond reputeharryb2448 has a reputation beyond reputeharryb2448 has a reputation beyond reputeharryb2448 has a reputation beyond reputeharryb2448 has a reputation beyond reputeharryb2448 has a reputation beyond reputeharryb2448 has a reputation beyond reputeharryb2448 has a reputation beyond reputeharryb2448 has a reputation beyond reputeharryb2448 has a reputation beyond reputeharryb2448 has a reputation beyond repute
Mac Specs: iMac i5 2.7GHz OS X.9.4

harryb2448 is offline
G'day and welcome to the forums.

Helps if we know your computer and operating system. But with Safari open, try going to Edit > and uncheck Check Spelling While Typing.

Hang on to those original install discs like grim death! Using OS X.7 or later make a bootable USB thumb drive before running Installer!
QUOTE Thanks
jimka_2001

 
Member Since: May 07, 2014
Posts: 6
jimka_2001 is on a distinguished road

jimka_2001 is offline
I'm using a macbook, and no I don't want to disable autocorrection. I just want to avoid correcting the word I just typed. I still want it to check words and offer me the correction.
QUOTE Thanks
harryb2448

 
harryb2448's Avatar
 
Member Since: Nov 28, 2007
Location: Nambucca Heads Australia
Posts: 16,922
harryb2448 has a reputation beyond reputeharryb2448 has a reputation beyond reputeharryb2448 has a reputation beyond reputeharryb2448 has a reputation beyond reputeharryb2448 has a reputation beyond reputeharryb2448 has a reputation beyond reputeharryb2448 has a reputation beyond reputeharryb2448 has a reputation beyond reputeharryb2448 has a reputation beyond reputeharryb2448 has a reputation beyond reputeharryb2448 has a reputation beyond repute
Mac Specs: iMac i5 2.7GHz OS X.9.4

harryb2448 is offline
Do as suggested and when finished hit 'Check Document Now'.

Hang on to those original install discs like grim death! Using OS X.7 or later make a bootable USB thumb drive before running Installer!
QUOTE Thanks
MBP17•David

 
MBP17•David's Avatar
 
Member Since: Feb 04, 2014
Location: East Midlands, UK
Posts: 394
MBP17•David is a jewel in the roughMBP17•David is a jewel in the roughMBP17•David is a jewel in the rough
Mac Specs: MBP17 2010 8GB 2x960GB SSDs 10.9.4 • MBA11 2010 4GB 128GB 10.9.4 • TC 2TB • TV • iOS bunch

MBP17•David is offline
Go through rejecting auto correction once more, and secondary click on the word (while it is still underlined as misspelled), then select Learn Spelling - it will be added to your default dictionary and you won't see auto correction for it again.

Dvid
QUOTE Thanks
jimka_2001

 
Member Since: May 07, 2014
Posts: 6
jimka_2001 is on a distinguished road

jimka_2001 is offline
hi Harry, no I don't want spell checking nor autocorrection disabled. I like it. I just don't want to have to click on that little x to avoid an autocorrection. Isn't there a hotkey which will effectively click the little x for me?

Jim
QUOTE Thanks
jimka_2001

 
Member Since: May 07, 2014
Posts: 6
jimka_2001 is on a distinguished road

jimka_2001 is offline
Quote:
Originally Posted by MBP17•David View Post
Go through rejecting auto correction once more, and secondary click on the word (while it is still underlined as misspelled), then select Learn Spelling - it will be added to your default dictionary and you won't see auto correction for it again.
It would be great if there were a key sequence for just avoiding the replacement and avoiding modifying the dictionary. My instinct is shift-space or cntl-space or cmd-space. but alas neither of these works :-(
QUOTE Thanks
MBP17•David

 
MBP17•David's Avatar
 
Member Since: Feb 04, 2014
Location: East Midlands, UK
Posts: 394
MBP17•David is a jewel in the roughMBP17•David is a jewel in the roughMBP17•David is a jewel in the rough
Mac Specs: MBP17 2010 8GB 2x960GB SSDs 10.9.4 • MBA11 2010 4GB 128GB 10.9.4 • TC 2TB • TV • iOS bunch

MBP17•David is offline
Quote:
Originally Posted by jimka_2001 View Post
It would be great if there were a key sequence for just avoiding the replacement and avoiding modifying the dictionary
Why? Either the word is spelled correctly, but not present in any of the main dictionaries, used by your system, say an unusual surname, or one of those 'cute spelling' corporate names, or it is misspelled, right?

Anyway, if you prefer to keep getting an auto correct suggestion, and rejecting it every time, rather than just once, all you have to do is to hit [esc] key, once you get the blue suggestion with the little x ...

Dvid
QUOTE Thanks
jimka_2001

 
Member Since: May 07, 2014
Posts: 6
jimka_2001 is on a distinguished road

jimka_2001 is offline
Quote:
Originally Posted by MBP17•David View Post


Anyway, if you prefer to keep getting an auto correct suggestion, and rejecting it every time, rather than just once, all you have to do is to hit [esc] key, once you get the blue suggestion with the little x ...
Thanks David for the attempt to help, but what you suggest is actually the opposite of what I want. If I press ESC or SPACE it gives me the auto-correction. I don't want the autocorrection in this case, I just want the thing I typed. And I don't want it going in the dictionary. And I don't want to move my fingers from the keyboard and find the little clickable x. And I don't want to disable auto-correction globally. I JUST want the thing I just typed this time.
QUOTE Thanks
jimka_2001

 
Member Since: May 07, 2014
Posts: 6
jimka_2001 is on a distinguished road

jimka_2001 is offline
Quote:
Originally Posted by MBP17•David View Post
Why? Either the word is spelled correctly, but not present in any of the main dictionaries, used by your system, say an unusual surname, or one of those 'cute spelling' corporate names, or it is misspelled, right?
Why? there are several reasons. 1) the suggested spelling might not be the correct one and I want to correct the spelling myself. 2) it might just be a sequence of letters for some one-off purpose (I don't want these in the dictionary). 3) it might be a foreign word which I need this once but don't want in the dictionary. 4) It might be a foreign word which is missing some accent characters and I don't want the accent characters.
QUOTE Thanks
MBP17•David

 
MBP17•David's Avatar
 
Member Since: Feb 04, 2014
Location: East Midlands, UK
Posts: 394
MBP17•David is a jewel in the roughMBP17•David is a jewel in the roughMBP17•David is a jewel in the rough
Mac Specs: MBP17 2010 8GB 2x960GB SSDs 10.9.4 • MBA11 2010 4GB 128GB 10.9.4 • TC 2TB • TV • iOS bunch

MBP17•David is offline
Quote:
Originally Posted by jimka_2001 View Post
what you suggest is actually the opposite of what I want. If I press ESC or SPACE it gives me the auto-correction
On a few rare occasions I get the iOS-style blue auto-correction suggestion, in Mavericks on my MB Pro, mostly in search and address fields, pressing escape key dismisses it, and pressing space bar accepts it.

Dvid
QUOTE Thanks

Post Reply New Thread Subscribe


« malware or something else | OSX 10.7.5 Crash on shutdown »
Thread Tools

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off
Forum Jump

Similar Threads
Thread
Thread Starter
Forum
Replies
Last Post
Moved and Time Capsule won't update Ghost Rider Other Hardware and Peripherals 0 05-04-2014 09:03 PM
Time Machine and Linux Dual-boot timinak OS X - Operating System 4 04-04-2014 08:26 PM
Time machine destroys current mail accounts.plist. dev77 OS X - Operating System 0 03-26-2014 02:14 PM
Can Time Machine use two hd halfmonkey Other Hardware and Peripherals 1 03-21-2014 12:51 PM
Time Machine and ext hd back up halfmonkey Apple Desktops 1 03-20-2014 12:22 PM

All times are GMT -4. The time now is 06:10 AM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
X

Welcome to Mac-Forums.com

Create your username to jump into the discussion!

New members like you have made this community the ultimate source for your Mac since 2003!


(4 digit year)

Already a member?