Mac Forums

Mac Forums (http://www.mac-forums.com/forums/)
-   OS X - Operating System (http://www.mac-forums.com/forums/os-x-operating-system/)
-   -   avoid auto-correct one time (http://www.mac-forums.com/forums/os-x-operating-system/311221-avoid-auto-correct-one-time.html)

jimka_2001 05-07-2014 05:49 PM

avoid auto-correct one time
 
When I type a word in safari (or several other places) on my macbook which the system thinks is misspelled, it pops up a small dialog showing my the auto correction. If I press space, the word I typed gets replaced by the suggested text.

How can I avoid this replacement and keep the word I typed?

I have seen that I can click the little x in the side of the pop-up, but this is very inconvenient for a touch typeset to have to move the hands and find the little x.

I tried pressing CMD-space, shift-space, cntl-space, and fn-space, but none of these works.

I DONT WANT to disable autocorrect globally nor locally. I JUST want to avoid auto-correct for the word I just now typed.

Thanks for the help.
Jim

harryb2448 05-07-2014 05:53 PM

G'day and welcome to the forums.

Helps if we know your computer and operating system. But with Safari open, try going to Edit > and uncheck Check Spelling While Typing.

jimka_2001 05-07-2014 05:56 PM

I'm using a macbook, and no I don't want to disable autocorrection. I just want to avoid correcting the word I just typed. I still want it to check words and offer me the correction.

harryb2448 05-07-2014 06:11 PM

Do as suggested and when finished hit 'Check Document Now'.

MBP17•David 05-07-2014 06:15 PM

Go through rejecting auto correction once more, and secondary click on the word (while it is still underlined as misspelled), then select Learn Spelling - it will be added to your default dictionary and you won't see auto correction for it again.

jimka_2001 05-07-2014 06:16 PM

hi Harry, no I don't want spell checking nor autocorrection disabled. I like it. I just don't want to have to click on that little x to avoid an autocorrection. Isn't there a hotkey which will effectively click the little x for me?

Jim

jimka_2001 05-07-2014 06:47 PM

Quote:

Originally Posted by MBP17•David (Post 1581997)
Go through rejecting auto correction once more, and secondary click on the word (while it is still underlined as misspelled), then select Learn Spelling - it will be added to your default dictionary and you won't see auto correction for it again.

It would be great if there were a key sequence for just avoiding the replacement and avoiding modifying the dictionary. My instinct is shift-space or cntl-space or cmd-space. but alas neither of these works :-(

MBP17•David 05-07-2014 07:21 PM

Quote:

Originally Posted by jimka_2001 (Post 1582002)
It would be great if there were a key sequence for just avoiding the replacement and avoiding modifying the dictionary

:\ Why? Either the word is spelled correctly, but not present in any of the main dictionaries, used by your system, say an unusual surname, or one of those 'cute spelling' corporate names, or it is misspelled, right?

Anyway, if you prefer to keep getting an auto correct suggestion, and rejecting it every time, rather than just once, all you have to do is to hit [esc] key, once you get the blue suggestion with the little x ...

jimka_2001 05-08-2014 02:16 AM

Quote:

Originally Posted by MBP17•David (Post 1582007)
:\

Anyway, if you prefer to keep getting an auto correct suggestion, and rejecting it every time, rather than just once, all you have to do is to hit [esc] key, once you get the blue suggestion with the little x ...

Thanks David for the attempt to help, but what you suggest is actually the opposite of what I want. If I press ESC or SPACE it gives me the auto-correction. I don't want the autocorrection in this case, I just want the thing I typed. And I don't want it going in the dictionary. And I don't want to move my fingers from the keyboard and find the little clickable x. And I don't want to disable auto-correction globally. I JUST want the thing I just typed this time.

jimka_2001 05-08-2014 02:18 AM

Quote:

Originally Posted by MBP17•David (Post 1582007)
:\ Why? Either the word is spelled correctly, but not present in any of the main dictionaries, used by your system, say an unusual surname, or one of those 'cute spelling' corporate names, or it is misspelled, right?

Why? there are several reasons. 1) the suggested spelling might not be the correct one and I want to correct the spelling myself. 2) it might just be a sequence of letters for some one-off purpose (I don't want these in the dictionary). 3) it might be a foreign word which I need this once but don't want in the dictionary. 4) It might be a foreign word which is missing some accent characters and I don't want the accent characters.

MBP17•David 05-08-2014 03:34 AM

Quote:

Originally Posted by jimka_2001 (Post 1582043)
what you suggest is actually the opposite of what I want. If I press ESC or SPACE it gives me the auto-correction

On a few rare occasions I get the iOS-style blue auto-correction suggestion, in Mavericks on my MB Pro, mostly in search and address fields, pressing escape key dismisses it, and pressing space bar accepts it.


All times are GMT -4. The time now is 07:18 AM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.