Results 1 to 6 of 6

Thread: iPhoto problem

  1. #1

    Member Since
    Jul 27, 2011
    iPhoto problem
    Yesterday I removed Mavericks from my MacBook because (a) my MacBook appears to be too old to handle it, (b) I cannot run Logic Pro 9 in Mavericks.

    I clean-installed Mountain Lion. Logic 9 works now!

    HOWEVER, when I try to use iPhoto now, it says my iPhoto version is too new and will not run in Mountain Lion--GO FIGURE!

    Does anyone know a solution other than another clean-instal?


  2. #2

    osxx's Avatar
    Member Since
    Jan 19, 2008
    houston texas
    09 MBP 8GB ram 500GB HD OS 10.9 32B iPad 4 32GB iPhone 5 iOs7 2TB TC Apple TV3
    iPhoto is part of iLife and a clean install will not bring that back you have to run the iPhoto version that matches the OS either re-install from backup or purchase from App Store.

  3. #3

    chas_m's Avatar
    Member Since
    Jan 22, 2010
    Victoria, BC
    Mid-2012 MBP (16GB, 1TB HD), Monoprice 24-inch second monitor, iPhone 5s 32GB, iPad Air 2 64GB
    The problem may or may not be the iPhoto application and is more likely to be the iPhoto library which actually got upgraded. If that's the case, I'm afraid I have no idea what you can do about that.

  4. #4

    Member Since
    Jul 27, 2011
    Thanks for the good advice people..I will take it further…Charlie

  5. #5

    Member Since
    Jul 27, 2011
    Hi Chas_M

    It looks like you're right. I tried to restore iPhoto from backup but it's giving me the same result.

    I will take it to Genius Bar …. they must fix it.



  6. #6

    Member Since
    Jul 27, 2011
    Hi all

    Follow up to this post by me:

    I took my Macbook to Genius Bar and for the first time ever, the "genius" got it wrong. Very disappointing. However I called the Apple help line and the fellow who answered fixed my problem.

    The genius said that the only way to fix it was to do a thanks!!! I would have to find all the data since the restore point and recover bit by bit, as I understand it. She said either that or purchase the iPhoto version I required. Sorry, why?! I didn't cause the problem…Apple's Mavericks was the problem…it will not work 100% on my 5 1/2 yr old MacBook. She was adamant there was no other solution, so really her problem is her attitude. She should have thought: (a) It's not his fault, it's a Mac issue; (b) there HAS to be a solution that does not incur cost to me.

    My attitude was that there HAS to be an easier way. There was:

    The helpline did not charge me because I correctly insisted the problem was not of my making and not because my hardware.

    The solution: I will explain as well as I can and I hope it's correct:
    Because I had opened my iPhoto LIBRARY using Mavericks iPhoto, the library was permanently altered in a way that prevented use of the older iPhoto version.

    (Mavericks is the first OS that includes iPhoto in the package).

    However we created a new, empty library, fetched the old iPhoto application from my backup, transferred the old photos to the new library folder, and voila!

    I felt I should let the community know, in case someone else has same problem. Call the help line if my explanation is not clear.


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. iphoto new problem
    By amatze in forum Apple Desktops
    Replies: 11
    Last Post: 03-28-2014, 01:53 PM
  2. problem with Iphoto
    By Gertie in forum OS X - Operating System
    Replies: 2
    Last Post: 02-19-2013, 11:01 AM
  3. The problem with iPhoto
    By wizardchef in forum OS X - Apps and Games
    Replies: 6
    Last Post: 08-08-2012, 12:15 AM
  4. iphoto problem
    By tinlizzy2 in forum Switcher Hangout
    Replies: 3
    Last Post: 04-24-2012, 05:59 PM
  5. iPhoto problem
    By robbiemullen in forum OS X - Apps and Games
    Replies: 0
    Last Post: 09-08-2007, 02:17 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts