Results 1 to 6 of 6
  1. #1

    Member Since
    Apr 23, 2011
    Install Mavericks Error
    I went install Mavericks on my iMac (upgrade from Mac OS 10.7.5) and it failed with the following error:

    "OS X can't be installed on the disk Macintosh HD because a recovery system can't be created."

    Any suggestions as to why this has happened and how to fix? Hope I don't have to redownload the whole thing again...

  2. #2

    osxx's Avatar
    Member Since
    Jan 19, 2008
    houston texas
    09 MBP 8GB ram 500GB HD OS 10.9 32B iPad 4 32GB iPhone 5 iOs7 2TB TC Apple TV3
    Not knowing any other info about your Mac does it have enough free space on the hard drive.

  3. #3

    chscag's Avatar
    Member Since
    Jan 23, 2008
    Fort Worth, Texas
    27" iMac i5, 3.2 GHz, iPad 3, iPhone 5c, iPhone 6+, 3 iPods, El Capitan
    See the following thread in the MacRumors Forum: LINK

  4. #4

    Member Since
    Apr 23, 2011
    Thanks. The error message in that thread is precisely the error that I am getting.

    I have followed the instructions here:

    Deleting the Mac OS X 10.7 Lion “Recovery HD” Partition

    After opening Terminal and running this command:

    diskutil eraseVolume HFS+ Blank /dev/disk0s3

    "diskutil list" returns the following:

    0: GUID_partition_scheme *251.0 GB disk0
    1: EFI 209.7 MB disk0s1
    2: Microsoft Basic Data Macintosh HD 125.0 GB disk0s2
    3: Apple_HFS Blank 650.0 MB disk0s3
    4: Microsoft Basic Data WIN7 125.1 GB disk0s4

    Which command do I run to merge disk0s3 with disk0s2?

    I tried "diskutil mergePartitions HFS+ Macintosh HD disk0s2 disk0s3", but it didn't work.

  5. #5

    Member Since
    Apr 23, 2011
    After deleting the recovery partition, I can no longer boot into Mac OS. When I hold down the Option button while booting, there is no longer an option to boot into Mac OS - only Windows. When I boot into Windows, I can see my Mac OS partition and the deleted blank partition in explorer. How do I recover from here?

  6. #6

    harryb2448's Avatar
    Member Since
    Nov 28, 2007
    Nambucca Heads Australia
    iMac i5 2.7GHz, 16GB memory, OS 10.11
    Think you have killed the OS X installation. Trust you had burnt to a USB thumb drive prior to running the Installer, or you have a backup on an external hard drive?
    Hang on to those original install discs like grim death! Using OS X.7 or later make a bootable USB thumb drive before running Installer!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Can't install Mavericks
    By Punkyclown in forum OS X - Operating System
    Replies: 3
    Last Post: 05-16-2014, 09:09 PM
  2. Accidental Mavericks Install
    By SeaDragon in forum OS X - Operating System
    Replies: 12
    Last Post: 01-30-2014, 11:20 AM
  3. Clean Install of Mavericks?
    By V6Pony in forum OS X - Operating System
    Replies: 5
    Last Post: 12-19-2013, 03:45 PM
  4. mavericks issuing error messages - disk not ejected properly
    By Textmail in forum OS X - Operating System
    Replies: 7
    Last Post: 11-05-2013, 09:06 AM
  5. Mavericks clean install?
    By AlanSr in forum OS X - Operating System
    Replies: 11
    Last Post: 07-12-2013, 11:35 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts