New To Mac-Forums?

Welcome to our community! Join the discussion today by registering your FREE account. If you have any problems with the registration process, please contact us!

Get your questions answered by community gurus Advice and insight from world-class Apple enthusiasts Exclusive access to members-only contests, giveaways and deals

Join today!

 
Start a Discussion
 

Mac-Forums Brief

Subscribe to Mac-Forums Brief to receive special offers from Mac-Forums partners and sponsors

Join the conversation RSS
OS X - Operating System General OS operation information and support

iCalendar (on iMAC) posts wrong times


Post Reply New Thread Subscribe

 
Thread Tools
FEisenberg

 
Member Since: Mar 26, 2014
Posts: 6
FEisenberg is on a distinguished road

FEisenberg is offline
Sorry if this is a duplicate, my first message seems to have disappeared. When I accept invites to my iMAC calendar all save to the wrong time (an hour later than they are scheduled). And some disappear. I was using iCloud calendar then tried Google calendar but both have the same problem. Any thoughts on how to fix this? Thanks
QUOTE Thanks
chscag

 
chscag's Avatar
 
Member Since: Jan 23, 2008
Location: Fort Worth, Texas
Posts: 43,794
chscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond repute
Mac Specs: 27" iMac i5, 3.2 GHz, iPad 3, iPhone 5c, 3 iPods, Yosemite

chscag is offline
Make sure the current date and time are set correctly on your iMac and that you're setup for daylight savings time. (should be automatic) System Preferences, Date & Time. Also check to see if you're using the correct time zone for your location. If you're using the wrong time zone that would cause the one hour error.
QUOTE Thanks
FEisenberg

 
Member Since: Mar 26, 2014
Posts: 6
FEisenberg is on a distinguished road

FEisenberg is offline
Thanks very much. Unfortunately, I did all of the things you recommended - DST, Date and Time and time zone. It still doesn't work. And I updated all of the above on my iPhone, my iPad and my iMAC - all 3 share the calendar. Any other advice?
QUOTE Thanks
MacInWin

 
MacInWin's Avatar
 
Member Since: Jul 07, 2008
Location: Winchester, VA
Posts: 3,866
MacInWin has a brilliant futureMacInWin has a brilliant futureMacInWin has a brilliant futureMacInWin has a brilliant futureMacInWin has a brilliant futureMacInWin has a brilliant futureMacInWin has a brilliant futureMacInWin has a brilliant futureMacInWin has a brilliant futureMacInWin has a brilliant futureMacInWin has a brilliant future
Mac Specs: 2011 MBP, 2008 iMac, iPhone 5S, iPad mini, 13" MBP and MacMini

MacInWin is offline
In Calendar/Preferences/Advanced, is the Turn on time zone support box checked or not? According to Apple, the description of that option is, "Change the time zone for all events in the top-right corner of Calendar, and choose a different time zone for individual events." I'm not sure exactly what that means, but I tested that if that box is ticked and you have a time zone in the upper right corner of Calendar, that the appointments will now show in THAT timezone, not yours. So if that upper right display is off by one timezone, your meetings will show for THAT zone.
QUOTE Thanks
chscag

 
chscag's Avatar
 
Member Since: Jan 23, 2008
Location: Fort Worth, Texas
Posts: 43,794
chscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond repute
Mac Specs: 27" iMac i5, 3.2 GHz, iPad 3, iPhone 5c, 3 iPods, Yosemite

chscag is offline
Good catch Jake. I remember another fellow who had that checked and his calendars were off by the number of hours difference for the time zone he had chosen.
QUOTE Thanks
MacInWin

 
MacInWin's Avatar
 
Member Since: Jul 07, 2008
Location: Winchester, VA
Posts: 3,866
MacInWin has a brilliant futureMacInWin has a brilliant futureMacInWin has a brilliant futureMacInWin has a brilliant futureMacInWin has a brilliant futureMacInWin has a brilliant futureMacInWin has a brilliant futureMacInWin has a brilliant futureMacInWin has a brilliant futureMacInWin has a brilliant futureMacInWin has a brilliant future
Mac Specs: 2011 MBP, 2008 iMac, iPhone 5S, iPad mini, 13" MBP and MacMini

MacInWin is offline
Heh! Been there, done that, got the scars...just a matter of remembering which scar goes with which "adventure."
QUOTE Thanks
kdqlx

 
kdqlx's Avatar
 
Member Since: Apr 26, 2013
Location: Miami Currently
Posts: 16
kdqlx is on a distinguished road
Mac Specs: MBPro mid 2012, 2.7Gh Intel i7, OS X 10.9.5 (13F34) Maverick, 16Gb

kdqlx is offline
I use the time zone support option since some weeks I travel to another time zone and click into my calendar in that time zone. Works great but my question/issue is this...

When I set up an appointment/meeting the dialog box to enter the event, location, time, etc. comes up always in GMT instead of the set time zone, there is a floating time zone option but I don't know how to set the floating time zone option AS DEFAULT so I don't always have to select a time zone or think in GMT.

Any ideas how to set the default setting from GMT to floating?

Thx for any suggestions.

My experience and opinions, not responsible for anything...
-kdqlx
QUOTE Thanks
kheiderman

 
Member Since: Jun 07, 2013
Location: Tucson AZ
Posts: 31
kheiderman is on a distinguished road
Mac Specs: MBP OS10.9.3 Intel core i7 8GB 1333 MHZ DDR3 iPhone 4 30GB ipod 160 Gb iPod

kheiderman is offline
Quote:
Originally Posted by FEisenberg View Post
Thanks very much. Unfortunately, I did all of the things you recommended - DST, Date and Time and time zone. It still doesn't work. And I updated all of the above on my iPhone, my iPad and my iMAC - all 3 share the calendar. Any other advice?
When I create an event on my MBP calendar it arbitrarily sets the time usually between 8am to 5pm. I have to manually click on the incorrect time and am given the option to replace it. This may not be the best solution but it works. Good luck.
QUOTE Thanks

Post Reply New Thread Subscribe


« mp4.infovid | How Best To Use Time Machine Backup of Two OS »
Thread Tools

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off
Forum Jump

Similar Threads
Thread
Thread Starter
Forum
Replies
Last Post
iMac hard disk failure after 18 months - not amused PeterMac Apple Desktops 30 04-05-2015 10:46 AM
iPad can see iMac but iMac can't see iPad janalowe iPad Hardware and Accessories 6 06-06-2014 11:50 PM

All times are GMT -4. The time now is 07:55 PM.

Powered by vBulletin
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
X

Welcome to Mac-Forums.com

Create your username to jump into the discussion!

New members like you have made this community the ultimate source for your Mac since 2003!


(4 digit year)

Already a member?