Mac Forums

Mac Forums (http://www.mac-forums.com/forums/)
-   OS X - Operating System (http://www.mac-forums.com/forums/os-x-operating-system/)
-   -   Need Help Upgrading MacBook Air to Mavericks (http://www.mac-forums.com/forums/os-x-operating-system/309516-need-help-upgrading-macbook-air-mavericks.html)

monjanger 03-16-2014 02:51 PM

Need Help Upgrading MacBook Air to Mavericks
 
I recently found a MacBook Air in a closet that I had put it and forgot about it, then I found it and started using it again. I am trying to get it up to date but have some problems: screen starts going darker when I am typing sometimes, sound doesn't work and I can not get it to update to mavericks. Let me talk about the upgrade to mavericks. Right now I have the version 10.5.8. Every time I download the software for a newer version (I am using snow leopard I think), it says "This software requires Mac OS X 10.6" or 10.9 ETC. Anyone know why? I know for mavericks you have to download it off the App Store, but the App Store is in the 10.6.6 update. So? And when I download Mavericks off the Apple.com page (When I search for software update's it shows none, weird right. Am I missing something.) It says "This update requires OS X version 10.9. Please help, I am not so good with MacBook Air's so walk me through it step by step. Thanks. ;D

McBie 03-16-2014 03:11 PM

First thing you need to clarify is the type of Macbook Air ( Model / CPU / RAM .... )
Mavericks can only be installed from the App Store, so you need to get the OS to a level of Snow Leopar to ensure you can use the App. Store.

Cheers ... McBie

harryb2448 03-16-2014 04:35 PM

And then if the MacBook will actually handle Mavericks, you will need a current Apple ID. Just Google.

chas_m 03-17-2014 04:54 AM

Quote:

Originally Posted by monjanger (Post 1572486)
Right now I have the version 10.5.8. Every time I download the software for a newer version (I am using snow leopard I think)

Nope. 10.5.8 is Leopard; Snow Leopard is 10.6.

Call Apple, buy a Snow Leopard DVD for $20. Get an external optical drive or use "remote disc" to install Snow Leopard on this machine, then use Software Upgrade to get it to 10.6.8.

If this is an original (2008) MBA, then you can only go as high as Lion (10.7.5). If this is a "Late 2008" aka "Nvidia 2008" model (released in October of 2008), then you can upgrade all the way to Mavericks, as you can with any later model. But not until you upgrade to 10.6.8.

bobtomay 03-17-2014 05:17 AM

link

Mac OS X 10.6 Snow Leopard - Apple Store (U.S.)


All times are GMT -4. The time now is 06:42 AM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.