Results 1 to 5 of 5
  1. #1


    Member Since
    Aug 19, 2013
    Posts
    4
    Deleted disk utility, cant reinstall
    In short, clean my mac decide to delete a whole bunch of things IT SHOULDN'T HAVE and now I have a hard drive i need to format and CANT because one of those programs was DISK UTILITY. I updated to 10.8.4 and that did not solve the problem. I cannot find my mac disk, and I have tried using pacifist to reinstall the packets to no avail. Any other ideas?

    My windows hard drive is still working, is there any way I can format a Hard drive for MAC use FROM windows?

    Thanks

  2. #2

    TattooedMac's Avatar
    Member Since
    May 19, 2009
    Location
    Waiting for a mate . . .
    Posts
    8,437
    Specs:
    21" iMac 2.9Ghz 16GB RAM - 10.11.3, iPhone6s & iPad Air 2 - iOS 9.2.1, ATV 4Th Gen tvOS, ATV3
    HAve you tried Booting into the recovery Partition and using Disk Utility there ?? Hold down ⌘R on restart and boot to the recovery Partition, then follow the prompts until your in Utilities and you will find Disk Utility from the Menu Bar and take it from there.

    I find it bizarre that you deleted Disk Utility as you would of got "This Application is used by the OS and cant be Deleted" Error.
    The only way for that to be done is to change permissions of the App, and a Admin Password.

    HTH
    Dont forget to use the Reputation System if someone has helped you out !!!
    Arguing with a zealot is only slightly easier than tunneling through a mountain with your forehead!!!!!
    MoTM ☆☆☆

  3. #3


    Member Since
    Aug 19, 2013
    Posts
    4
    Its crazy. Also deleted Terminal and a few others.

    I cannot reboot into recovery either. I think im just going to have to find the usb and reformat

  4. #4

    Raz0rEdge's Avatar
    Member Since
    Jul 17, 2009
    Location
    MA
    Posts
    8,554
    Specs:
    27" i7 iMac, 24" iMac, 13" Macbook Air, iPhone 6S, iPod Nano 7th GeniPad 3
    You don't really need to run programs like CleanMyMac and it's kin to do any sort of clean up (especially by removing system applications)..You might want to look into OnyX just to clear up some caches and stuff..that's all the maintenance you need..

    The Recovery Console (and why exactly can't you get back into it?) would just allow you to run Disk Utility from there, it wouldn't restore it on your installation..

    Looks like a re-install is in order for you to get back the system apps..
    --
    Regards
    ...Ashwin



    Be sure to read the Community Guidelines | The more information you provide, the better answers you get, remember GIGO.

  5. #5

    cradom's Avatar
    Member Since
    Feb 14, 2004
    Location
    Groves, Texas
    Posts
    4,551
    Specs:
    21in. iMac 10.11 --- HP win 10
    Just curious: would it be possible to drop to Terminal in Recovery mode and cp Disk Utility from the recovery partition to the regular partition?

    Edit: In case anyone's interested, it is possible. Tried it today, worked fine. Question is, is it the same version as in the last update? Forgot to look at that before I deleted it. Also need to use cp -r since the app is really a directory.
    Delusions are often functional. A motherís opinions about her childrenís beauty, intelligence, goodness, et cetera ad nauseam, keep her from drowning them at birth.
    -Lazarus Long

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Disk repair utility during reinstall doesn't work!
    By LadyLavaLamp in forum OS X - Operating System
    Replies: 1
    Last Post: 05-24-2012, 03:29 AM
  2. Deleted Quicktime 7 - Can't Reinstall??
    By l0gan0 in forum OS X - Apps and Games
    Replies: 1
    Last Post: 06-22-2010, 12:21 PM
  3. Disk Utility-Repair disk = erase disk?
    By mundane bob in forum OS X - Apps and Games
    Replies: 6
    Last Post: 09-01-2009, 06:16 PM
  4. Deleted Disk Utility and Terminal!
    By TennsDog in forum OS X - Operating System
    Replies: 2
    Last Post: 01-11-2009, 03:19 PM
  5. Disk utility deleted all partitions! (External HD)
    By sub533 in forum OS X - Operating System
    Replies: 1
    Last Post: 01-05-2008, 09:17 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •