Anybody had problems with Bing occupying their start page in Firefox? I post this because there are some very annoyed complaints all over the web.
There's a simple solution:
Firefox >
Preferences >
in the Home page Box type: Mozilla Firefox Start Page >
click restore to default.

Simple.