Page 1 of 2 12 LastLast
Results 1 to 15 of 20
  1. #1
    Internet Sharing

    Member Since
    Jun 20, 2013
    Posts
    11
    Internet Sharing
    Hello mates

    I've been fighting with this for a couple days now, and I'm starting to get desperate.

    So here is the deal: I'm trying to share my Internet from Ethernet to other computers using Wifi. In the past, I have not had any problems doing this, it's just about checking the right boxes right?

    Well, now, I have this iMAC with Mac OS X 10.7.5, and the problem is that all the checkboxes in the Settings -> Sharing -> Internet Sharing screen are disabled. I cannot check any of the boxes listing the ports I want to use to share my Internet. Therefore, I cannot check the box for Wifi and I cannot start the sharing service.

    Have any of you solved such a weird problem? I called the Apple service, and they were unable to provide a solution...

    This is the printscreen of what I see: http://img824.imageshack.us/img824/9659/vqe5.jpg

    Thank you guys
    J

  2. #2
    Internet Sharing
    chas_m's Avatar
    Member Since
    Jan 22, 2010
    Location
    Victoria, BC
    Posts
    18,933
    Specs:
    Mid-2012 MBP (16GB, 1TB HD), Monoprice 24-inch second monitor, iPhone 5s 32GB, iPad Air 2 64GB
    Did you unlock the lock with your admin password?


  3. #3
    Internet Sharing

    Member Since
    Jun 20, 2013
    Posts
    11
    Hi mate! Thanks, and yes I did; I have admin rights on this iMac. Im not a super user, but I have admin rights indeed. I have a local admin user, and a network admin user, and it-s the same for both... What do you think?

  4. #4
    Internet Sharing
    chas_m's Avatar
    Member Since
    Jan 22, 2010
    Location
    Victoria, BC
    Posts
    18,933
    Specs:
    Mid-2012 MBP (16GB, 1TB HD), Monoprice 24-inch second monitor, iPhone 5s 32GB, iPad Air 2 64GB
    And you're sure your computer is connected to the Internet by an Ethernet connection and not Wi-Fi?

  5. #5
    Internet Sharing

    Member Since
    Jun 20, 2013
    Posts
    11
    Absolutely sure... iMac is connected to Ethernet, other devices would connect to Internet through the iMac via wifi. Weird isnt it??? And this sucks because I want to set up a proxy in the iMac, and if the sharing is not working, I'm hopeless!

  6. #6
    Internet Sharing
    chas_m's Avatar
    Member Since
    Jan 22, 2010
    Location
    Victoria, BC
    Posts
    18,933
    Specs:
    Mid-2012 MBP (16GB, 1TB HD), Monoprice 24-inch second monitor, iPhone 5s 32GB, iPad Air 2 64GB
    Have you run any maintenance lately? Might be time to do that. We recommend Onyx or its sibling Maintenance as good, free solutions there.

    Have you tried creating another admin account (just for troubleshooting), logging into that and seeing if it works there?

  7. #7
    Internet Sharing

    Member Since
    Jun 20, 2013
    Posts
    11
    Yep! Even tried with a the account of a colleague... and nada again...

  8. #8
    Internet Sharing

    Member Since
    Jun 20, 2013
    Posts
    11
    I just activated the root account and tried... SAME PROBLEM!

    But it seems there is an antivirus installed (Symantec); could this be messing things up??

  9. #9
    Internet Sharing
    mrplow's Avatar
    Member Since
    Oct 01, 2007
    Location
    UK
    Posts
    6,759
    Specs:
    27" iMac i7 (2011) 10.10, iPhone6, iPad Air 2, AppleTV2
    Personally I'd uninstall that. But at the very least temporarily disable it and try again
    External hard disk acquisition addict - but admitting the problem is the first step to a robust backup

    Please use the reputation system if you think you've been helped - top right of this post

  10. #10
    Internet Sharing

    Member Since
    Jun 20, 2013
    Posts
    11
    Thanks mrplow. Ill do that and post the results.

  11. #11
    Internet Sharing
    Slydude's Avatar
    Member Since
    Nov 15, 2009
    Location
    North Louisiana, USA
    Posts
    8,530
    Specs:
    2.8 GHz MacBook Pro 10.10.2, 8 GB mem, iPhone 6+
    Here's another thought. Not sure if this is an issue but I think it's possible. Go into System Preferences and check the Network pane. Which interface is listed first Airport/Wireless or Ethernet? Make sure Ethernet is first.
    Sylvester Roque Former Contributing Editor About This Particular Macintosh

    "Got Time to breathe. You got time for music." Denver Pyle as Briscoe Darling

  12. #12
    Internet Sharing
    Strukt's Avatar
    Member Since
    Jul 14, 2008
    Location
    Norway
    Posts
    365
    Specs:
    rMBP 15" / 2.6GHz / 16GB / 512GB
    I would bet it is the symantec software. Get rid of it.

    Considering you have done the stuff you say yo do..
    My Blog: Apple Laptops

  13. #13
    Internet Sharing

    Member Since
    Jun 20, 2013
    Posts
    11
    I uninstalled Symantec, repared the permissions with disk utilty, and nothing... this is frustrating... I even gave read and write permissions to everyone to the folder /Library/Preferences/SystemConfiguration, and the checkboxes are still locked... Im desperate...

  14. #14
    Internet Sharing
    mrplow's Avatar
    Member Since
    Oct 01, 2007
    Location
    UK
    Posts
    6,759
    Specs:
    27" iMac i7 (2011) 10.10, iPhone6, iPad Air 2, AppleTV2
    Can you post a screenshot of your network page from system prefs and from the sharing page as above?
    External hard disk acquisition addict - but admitting the problem is the first step to a robust backup

    Please use the reputation system if you think you've been helped - top right of this post

  15. #15
    Internet Sharing

    Member Since
    Jun 20, 2013
    Posts
    11
    There is some progress.

    I copied the file com.apple.nat.plist file to my SystemConfiguration folder from my Macbook pro, where I have the settings for InternetSharing and it works. Then, on the iMac, the computer with the problem, I executed the command sudo launchctl load -w /System/Library/LaunchDaemons/com.apple.InternetSharing.plist on Terminal, and even though the checkboxes are still disabled, the Internet Sharing seems to be ON.

    However, the sharing is not real because I see no new wifi network appearing, and the icon of the sharing (normally an up arrow) is not there (see the pictures)

    http://imageshack.us/photo/my-images/541/0lhb.jpg/

    http://imageshack.us/photo/my-images/713/e38p.jpg/

    F$%%&%^ THIS!!!! But thank you all... I will not rest until I fix this

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. iphone cannot connect internet via internet sharing on MacBookPro
    By bilbilbo in forum OS X - Operating System
    Replies: 3
    Last Post: 11-23-2014, 09:34 AM
  2. My HTC Wildfire will connect to internet sharing but won't connect to the internet.
    By Nicholas1501 in forum Internet, Networking, and Wireless
    Replies: 0
    Last Post: 09-05-2012, 08:05 PM
  3. Internet Sharing
    By Indy89 in forum Internet, Networking, and Wireless
    Replies: 2
    Last Post: 11-12-2009, 05:29 AM
  4. Wireless Bridging Tiger to Leopard; Wimax Internet Connection; Internet Sharing
    By papayajelly in forum Internet, Networking, and Wireless
    Replies: 2
    Last Post: 05-27-2009, 03:37 AM
  5. HELP- Internet Sharing Off
    By Kuturagi in forum Internet, Networking, and Wireless
    Replies: 1
    Last Post: 12-30-2006, 04:11 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •