Results 1 to 11 of 11
  1. #1

    Member Since
    Mar 30, 2013
    iMac not starting, even from installation CD
    Hi folks,

    I'm having trouble with an iMac about year 2007 that refuses to boot. It displays the light grey screen with the rotating wheel.
    After a few minutes, a black popup asks to reboot the computer.

    I used an Apple USB keyboard and an Apple USB mouse for my tests.
    All other devices like USB external hard drive or wireless mouse were disconnected.

    I tried all possible key combinations I knew, as listed here
    Mac OS X Startup Shortcuts
    excepted the "Command R".

    I also had done the fsck -yf disk checking.

    According to customer, the system runs under OS X 10.6.8.
    His installation CDs are however 10.4.8.
    I don't know if the difference comes from upgrades that the customer has done himself or by some IT people.

    I observed that the installation CD from 10.4.8 does not launch when pressing the C key from the very beginning.
    I can hear the compact disk rotating fast at the beginning, but then it gets much quieter.
    After a few minutes, the monitor still displays the light grey screen. Not any CD splash screen that I could expect.

    When running the system in Single-User Mode, the last messages printed are:
    wl0 : Broadcom BCM4328 802.11 Wireless Controler
    Got boot device = IOService (...)
    FireWire (OHCI) TI ID 8025 built-in now active, GUID 0019e3fffe9855fe; max speed S800,
    BSD root : disk0s2, major 14, minor 2
    [Bluetooth: CSRHID Transition Single User waiting WindowServer launchd 1 launchd 1 *** launchd[1] has started up. ***
    AppleYukon2: Marvell Yukon Gigabit Adapter 88E8053 Singleport Copper SA
    AppleYukon2: RxRingSize <= 1024, TxRingSize 256, RX_MAX_LE 1024, TX_MAX_LE 768, ST_MAX_LE 3228
    Then the black and white screen stays.

    When starting the system in verbose mode, I get more or less the same messages than in single user mode.
    Between the two "AppleYukon2" lines, this line is additionally printed:
    CSRUSBBlueHCIController :: setupHardware super returned 0
    I suspect some problem with the Bluetooth; could it be?

    Contrarily to Apple's installation CD, Knoppix (a live CD based on Linux) launches and works without problem.
    Knoppix was able to recognise the USB keyboard, but not a wireless one.

    After mounting the computer hard drive (which system was GPT) under Knoppix, I could see that the following folders and file structure:
    	|_Firmware.scrap  size: 15729264
    	|_._EfiUpdaterApp2.efi  size:4096
    	|_.LOCKED_IM61_0093_07B.fd  size:4096
            |_EfiUpdaterApp2.efi  size: 107536
            |_LOCKED_IM61_0093_07B.fd  size: 2097151
    If I remember, all files listed were from 2007.

    I expected I could see other files, but I could not, probably because of the GPT system.

    Later, I plugged some external hard drive which is used by my customer for backup purposes.
    The system was also GPT and Knoppix was not able to list its files.
    But plugging the same hard drive to a MacBook showed that it contained files.

    I know that my customer has been previously using wireless mouse from Microsoft and the problem seems having occured after the mouse battery replacement.
    His wireless keyboard was original from Apple.

    I'm a bit lost about what to try now.

    Can anyone help ? Thank you very much.

  2. #2

    bobtomay's Avatar
    Member Since
    Dec 22, 2006
    Texas, where else?
    15" MBP '06 2.33 C2D 4GB 10.7; 13" MBA '11 1.8 i7 4GB 10.10; 21" iMac '13 2.9 i5 8GB 10.10; 5s & 5c
    I'd try resetting the PRAM

    See if that will get it to boot.

    If not, those slot load optical drives are notorious for the lens getting dusty - take a can of air and shoot 3-4 quick bursts through the slot in different directions and see if that will enable it to boot from the CD.

    Also try holding the option key while booting with the CD.

    If you can get it to boot from the CD, head for Disk Utilities in the Utilities menu and run the Repair Disk on the drive until it comes back saying nothing was repaired or it tells you it's not repairable.

    If he's got a current backup, you could load 10.4 on it and let the customer order a new 10.6 disc from Apple online store ($20) if he can't find the original.
    Hopefully the above may get it fixed for them.
    I cannot be held responsible for the things that come out of my mouth.
    In the Windows world, most everything folks don't understand is called a virus.

  3. #3

    harryb2448's Avatar
    Member Since
    Nov 28, 2007
    Nambucca Heads Australia
    iMac i5 2.7GHz, 16GB memory, OS 10.11
    A mid 2007 iMac, if you are sure of the model, came originally with OS X.4.10 system install discs so X.4.8 discs simply would not boot the machine but will work on a say 2006 model iMac. May well be a failed optical drive., using the Command + R will only work on later operating systems, Lion and Mountain lion.
    Hang on to those original install discs like grim death! Using OS X.7 or later make a bootable USB thumb drive before running Installer!

  4. #4

    dtravis7's Avatar
    Member Since
    Jan 04, 2005
    Modesto, Ca.
    iMac late 2007 10.11.b4, iMac 2008 10.10.5, Macbook2007 10.7.5, Mac Mini 10.7.5, iPhone 3GS Note 8!!
    Is it a Mid or Late 2007? What speed is the CPU? That One screen you are getting sounds like a Kernel Panic which could be anything from the OS being messed up or a hardware issue like bad RAM. Is that black popup a screen in several languages telling you to restart?

    Also are you HOLDING DOWN the C key or just pressing and letting go? You have to keep the C key down till the loading screen comes up.

  5. #5

    Member Since
    Mar 30, 2013
    Thanks to all of you for your answers.

    Yes, the black popup is a screen in several languages telling to restart.

    Concerning resetting the PRAM, I had tried it, but it did not solve the problem.

    I believe the RAM should be OK for two reasons :firstly, the customer was unaware of what RAM is, secondly the CD of Knoppix loads in the RAM without problem.

    Yes, I holded the C key down quite a while, about one and half a minute I think.

    The customer could find a 10.6 disk too, but believed it was for an iBook.
    Should I try with this one ?

    I don't know if the iMac is a mid or late 2007.

    Can someone paste what should display in verbose mode just after the AppleYukon2 lines ?
    This may help to know where does the OS stops loading.

  6. #6

    chscag's Avatar
    Member Since
    Jan 23, 2008
    Fort Worth, Texas
    27" iMac i5, 3.2 GHz, iPad 3, iPhone 5c, iPhone 6+, 3 iPods, El Capitan
    Try starting the iMac in Safe Mode. Press and hold down the shift key as soon as you hear the boot sound. Keep holding it until the Apple appears on the screen. Let us know if that works.

  7. #7

    Member Since
    Mar 30, 2013
    @chsag: No, holding the shift key doesn't work.

    The hardware diagnostic ("D") also does not work, nor does holding "Command+R" keys down.

    When inserting a CD and pressing "Command+C", we can hear the CD rotating. Then, during about 1 or 2 minutes, we can hear that the CD is being read, hoping that it loads into RAM. But no CD splash screen.
    After a few minutes, everything becomes quiet, and the light grey screen with the multilingual black popup comes again.

    I'm not totally sure about which version of OS X is currently installed.
    Could a difference between installed version and the version on the CD make the CD stop loading ?
    As being more familiar to PCs, I expected licences questions were handled separately from the installation media. Something like the Windows registration key. Is this handled differently with computers from Apple ?

    I tried with installation CDs of OS X 10.4, 10.5 and 10.6 and none displays any splash screen.

    How can I check which version of OS X is installed ?

    When purchasing a CD, do I have to select the same version of OS X that the computer originally came with or should I purchase a newer version ?

    Also, should I purchase the newest version or can it be too hungry for a computer from year 2007 ?

    Thank you very much.

  8. #8

    Member Since
    Mar 30, 2013
    Well. I read somewhere that OS X installation CDs can only work with the hardware they came with.
    This could explain the problem if none of the CDs was the right one.

    So, I have some questions :

    1) Is this true that OS X installation CD only works with the computer it came together ?

    2) Is this because drivers for other types of Apple computers were removed by Apple on each CD ?

    3) Is there some way to know to which computer does an OS X install CD belong to ?

    4) What happens when purchasing a new CD / DVD? Must I be careful about the hardware, or will it contain all necessary drivers for all kinds of Apple computers?

    Please pardon my ignorance, but coming from Windows, I got familar activating Windows with a licence key. But seems that Apple has a different way to manage licences.

    Thank you very much for your help.

  9. #9

  10. #10

    Member Since
    Mar 30, 2013
    Thank you "gsahli" for the much interesting link you pointed.

    The original grey install disk were the 10.4 version, aka "Tiger", but I assume the iMac was upgraded later.

    Now, how do I know if the iMac is PowerPC or Intel, as both existed in 2007 ?

    If based on Intel, is it wise to upgrade to Lion from an USB FlashDrive or will the Mac be too slow afterwards ?

    What about second-hand retail DVDs of Tiger, Leopard or Snow Leopard and second-hand USB FlashDrives of Lion ?
    Will they work ?
    How to get a licence legally if I get a second hand retail OS dvd or key ?

    Also, why are two prices displayed on Apple's site for OS X Mountain Lion 29$ / 69$ ?
    Does the first one correspond to an upgrade from the previous version ?

    And on this page, , I see one more price of ~20$.
    Does this correspond to a download install ?

    Are there extra costs then to install the OS in French ?

    Sorry for my many questions but I still don't have a clear vision about the "ecosystem".

  11. #11

    harryb2448's Avatar
    Member Since
    Nov 28, 2007
    Nambucca Heads Australia
    iMac i5 2.7GHz, 16GB memory, OS 10.11
    The last PowerPC iMac was the late 2005 model 17" model number A1145. The PowerPC models cannot run OS X.6 Snow Leopard, Intel only. Mountain Lion is $20 and maybe the $69 version comes pre-installed on a flash drive?
    Hang on to those original install discs like grim death! Using OS X.7 or later make a bootable USB thumb drive before running Installer!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 2
    Last Post: 08-30-2014, 07:42 PM
  2. Replies: 4
    Last Post: 08-26-2012, 11:13 PM
  3. Imac G5 not starting up..
    By lehelx in forum Apple Desktops
    Replies: 27
    Last Post: 06-18-2010, 06:55 AM
  4. iMac G3 not starting up
    By bruceg in forum Apple Desktops
    Replies: 8
    Last Post: 07-08-2004, 03:10 PM
  5. iMac G3 not starting up
    By bruceg in forum Apple Desktops
    Replies: 1
    Last Post: 03-30-2004, 01:58 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts