Results 1 to 4 of 4
  1. #1

    Member Since
    Mar 30, 2013
    Mac OS not loading and asking to reboot
    Hi folks,

    I'm facing a problem with an iMac (year ~2007) that doen't start correctly.

    I can hear the gong. Then light grey screen with the logo from Apple displays.
    After a few seconds, the "loading" icon appears and the computer does nothing like if it was loading and looking for some driver.

    After two or three minutes, a dark grey popup appears, asking to reboot the computer.

    I tried the following :

    1) Disconnected devices like external hard drive, external speakers, keyboard and mouse.

    2) Reconnected keyboard and mouse and rebooted the computer with the following keys hold down : Apple + Alt + P + R

    Nothing happened. I could not ear the gong two or four times like I read somewhere; only once just after the computer started.

    3) Rebooted the computer with "Apple+S" keys hold down.
    and ran the "fsck -yf" command.

    The drive was reported being OK, but a short message in capital letters
    also told that changes were done. I cannot remember the exact message.

    This total checkup time for the hard drive was about 2 minutes.
    The drive is probably around 500 Gb from what I was told.

    4) Tried to boot in verbose mode. The last messages that were printed were about Aironet
    So, I assume some problem either with Aironet or with devices that come later.
    I can remember having seen something like an IP address.
    This make me think the problem could occur after WLAN was set.

    5) Tried to boot with the X key hold down. No change.

    6) Tried rebooting from the Mac OS X installation compact disk, by holding down the C key. We can hear the typical sound of the CD that boots, but nothing happens and afterwards, the iMac still seems to try booting form the hard drive.

    Had some problem ejecting the CD from the keyboard; worked only if the eject key was hold down very soon after some reboot.

    7) Tried changing the batteries from the wireless keyboard, but no improvement.
    The battery from the wireless mouse was changed recently and the mouse shows some red light.

    8) Tried booting from Knoppix CD version 6.7.
    Knoppix loads but I cannot use the keyboard then; I assume that Knoppix doesn't have the right driver for the wireless keyboard.

    Unfortunately, I don't have yet a classical "wire-keyboard" yet to test.

    I could not perform a memtest with Knoppix, as the keyboard was not recognized by Knoppix.

    9) Tried running again the computer in verbose mode by holding down "Apple + V" after reboot, but the console black and white screen does not display anymore.
    The computer still freeze at loading.

    The iMac does not have any socket for a classical keyboard.
    On the rear side are just USB sockets as well as few other ones.

    I'm not scared by console mode commands if necessary, although I currently have more experience with Linux and Windows than with BSD systems.

    Thank you very much for your help.

  2. #2

    chscag's Avatar
    Member Since
    Jan 23, 2008
    Fort Worth, Texas
    27" iMac i5, 3.2 GHz, iPad 3, iPhone 5c, iPhone 6+, 3 iPods, El Capitan
    The iMac does not have any socket for a classical keyboard.
    On the rear side are just USB sockets as well as few other ones.
    I have no idea what you mean by a "classical keyboard". Your iMac came from the factory with either a USB wired keyboard or wireless. Almost any inexpensive wired (USB) keyboard will work. You really need a wired keyboard to perform tests.

    Since FSCK reported that changes were made, you should have run the test again until it reports that everything is OK.

  3. #3

    Member Since
    Mar 30, 2013
    I meant a keyboard with a PS/2 connector. I don't know if they were used for iMacs in old times, but they were very common for PC users.

    Thanks for the two tricks. I'll try again with an USB keyboard.

  4. #4

    bobtomay's Avatar
    Member Since
    Dec 22, 2006
    Texas, where else?
    15" MBP '06 2.33 C2D 4GB 10.7; 13" MBA '14 1.8 i7 8GB 10.11; 21" iMac '13 2.9 i5 8GB 10.11; 6S
    There is no PS2 port on your Mac. For testing you need any wired (USB) keyboard.
    With a PS2 keyboard you would need the PS2 to USB adapter - the few PS2 keyboards that can still be found typically come with that adapter. Most Windows machines have not had a PS2 connection for some number of years either.

    Does this Mac have the original memory or new?
    I cannot be held responsible for the things that come out of my mouth.
    In the Windows world, most everything folks don't understand is called a virus.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. can't reboot my Mac
    By Albert2 in forum OS X - Operating System
    Replies: 1
    Last Post: 07-12-2015, 08:28 PM
  2. Replies: 7
    Last Post: 05-15-2015, 07:20 PM
  3. Mac OS 10.7.3 Reboot Issues
    By sbfalex in forum OS X - Operating System
    Replies: 4
    Last Post: 05-14-2012, 12:14 AM
  4. Old 202 I Mac reboot!
    By FromTheDarkSide in forum OS X - Operating System
    Replies: 1
    Last Post: 10-13-2011, 08:34 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts