Results 1 to 4 of 4
  1. #1

    Member Since
    Sep 28, 2012
    Help required -- deleted system/wheel from sharing and permissions
    So I just did a big clean up on my hard drive of old files, and wanted to see how much space I now have left on my HD - I right-clicked on Macintosh HD > Get Info.

    Under Sharing & Permissions I noticed a strange User listed named "wheels". Afraid that someone had accessed my computer or was somehow sharing on my network, I went ahead like an idiot and deleted the "wheels" user without first researching what it was all about.

    Now I cannot boot, nor can I reinstall my OS because it says permission is denied.

    I really don't know what to do at this point, I am hoping that there is a command in terminal that can undo deleting wheel/system.

    I would very much appreciate the assistance, i'm starting to go a little batty.

    Thank you

  2. #2

    Member Since
    Sep 28, 2012
    I should also say that every time i boot with option, or off the snow leopard installation disc, the options for "verify disk permissions" and "repair disk permissions" cannot be clicked.

    Help would be greatly appreciated

  3. #3

    bobtomay's Avatar
    Member Since
    Dec 22, 2006
    Texas, where else?
    15" MBP '06 2.33 C2D 4GB 10.7; 13" MBA '14 1.8 i7 8GB 10.11; 21" iMac '13 2.9 i5 8GB 10.11; 6S
    try this - link
    I cannot be held responsible for the things that come out of my mouth.
    In the Windows world, most everything folks don't understand is called a virus.

  4. #4

    Member Since
    Aug 20, 2013
    Lightbulb accidental deletion of "wheel" user group from sharing permissions
    to anyone referencing this article because they just deleted wheel from sharing and permissions...

    before trying sudo chown :wheel / in terminal
    or trying boot recovery disc
    or trying BatChmod

    first try clicking on the cog to the right of the + - beneath the name | privilege list.
    the cog should allow you to revert to previous settings in sharing and permissions.

    i just made the mistake of deleting wheel, d'oh!
    and read all i could find online about restoring it.
    i tried the sudo in terminal but my password would not be accepted.
    i was trying my admin pass, i should have tried my root pass instead.
    before attempting more complex methods of recovery, i clicked the cog
    that is between the + - and the (unlocked) lock symbol beneath
    the sharing and permissions list of Name | Privilege

    and it allowed me to revert to previous, instantly "wheel" came back in the list
    between system and everyone, as it had been before i made the mistake of deleting it.

    this solution may not work for everyone, but it did work for me, and saved me from
    having to try more complex methods of recovery to restore "wheel" successfully.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Authentication Required, Disk Permissions Repaired, but no dice.
    By StylePolice in forum macOS - Operating System
    Replies: 4
    Last Post: 01-14-2012, 03:19 PM
  2. Mac Host files? system/wheel/everyone?
    By trellaine in forum macOS - Operating System
    Replies: 2
    Last Post: 10-26-2011, 08:48 PM
  3. Visual Studio - Emulation or Op system required?
    By TranquilEclipse in forum Running Windows (or anything else) on your Mac
    Replies: 2
    Last Post: 10-28-2010, 02:37 AM
  4. iTunes Home Sharing - help required...
    By martyp in forum macOS - Apps and Games
    Replies: 10
    Last Post: 05-19-2010, 02:38 PM
  5. admin rights/permissions help required
    By vokeyuk in forum Other Hardware and Peripherals
    Replies: 5
    Last Post: 01-27-2007, 06:37 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts