Mac Forums

Mac Forums (http://www.mac-forums.com/forums/)
-   OS X - Operating System (http://www.mac-forums.com/forums/os-x-operating-system/)
-   -   Time Machine freeze/never end backing up (http://www.mac-forums.com/forums/os-x-operating-system/285505-time-machine-freeze-never-end-backing-up.html)

indris 09-27-2012 07:46 AM

Time Machine freeze/never end backing up
 
I have a problem w Time Machine 6 months now. Both on 10.6.8 and 10.8.2
It starts to back up on an external FW-drive (2T). In went OK for a year or so. Suddenly i starts backing up and stops at a random amount og MB/GB.
Just deleted alot of old backups to create space, but no change.


Macbook Pro, 2.66 GHz Intel Core 2 duo, 4GB 1067 MHz DDR3.

chscag 09-27-2012 12:04 PM

Run a verify check on your external hard drive with Disk Utility. The drive may have errors which may be why TM is stopping.

indris 09-27-2012 03:32 PM

it was examined and found OK by Disk Utility. Forgot to mention...

ane66879 09-28-2012 10:00 AM

I am having the same issues with my macbook pro. So yesterday I went to Apple to get some help (I was there for an hour). What they said is to first going onto the external hard drive you are using to back up and delete the file that says current or running or something like that (it is under the folder for your computers backup. you should also see folders dated with your last backups in that folder.) To delete that file you may have to restart your computer to be able to fully delete it (after you put it in the trash). That didn't get the issue for me, so then he had me go under disk utility and select my macbook pro's hard drive and run repair disk permissions. Then try deleting that file that is on the external hard drive again and give time machine another shot. (this also didn't do it for me) So Apple said if that didn't work to reset home folder permissions and aci's. To do this you restart your computer while holding command r down until the apple logo appears. Then the computer starts into a weird looking mode. (it will almost look like it is starting normally, but don't worry, it isn't) Then you go to the top bar and select the utilities drop down menu and open terminal. Then type resetpassword (yes, one word) and that will open a new window and you pick your internal hard drive then you select the user and then at the bottom of the window, you can reset the home folder. This is the last thing they told me to try, but it didn't work for me either. I am still were I started, except for a wiped external hard drive (the guy at Apple wanted to do that just to make sure it wasn't the drive, but I don't think it wasn't necessary). If anyone has some ideas on where to go after this, please help me.

ane66879 09-28-2012 11:35 PM

I believe I figured out what the issue is on my Macbook Pro. I got into the main drive (where you can see every file on the drive and I did this by right clicking on applications in a finder window and then selecting open enclosing folder). Then I looked through all of the different folders and I found that I don't have permission to even view many of them. So to fix it I select the folder and right click on it and select get info. Then I scroll to the bottom of that window, click the lock (and I removed my password to make it faster and there are so many folders for me it has saved me tons of time) to allow me to change the settings and then under sharing and permissions it shows "system" (who has read and write capabilities) and then "everyone" (No Access). Then click on the drop down menu for my permissions and select read and write then close the window. I haven't completed every folder yet and I may not get done with it till tomorrow, but it seems to be working (I was able to backup 14 KB instead of 6KB). I will post later if it ended up working or not. If anyone has a better way of changing all of these permissions, please post a reply. I hope this helps.

ane66879 09-29-2012 12:21 AM

That seemed to help a little, but that isn't the issue. I need some new ideas to try. It is looking like Mac OS 10.7.5 is the issue, not my files or anything.

indris 10-01-2012 05:47 AM

The r restart routine didnt work for me. It looked, like you said, as an ordinary boot-up, only that it opened all the programs that where open before restart as well. Went to utility, opened terminal and typed resetpassword and got the message - command not found. Permisions as you mention in second relpy was OK.

ane66879 10-01-2012 09:37 AM

I went to Apple again and he told spotlight on my computer to re-index my internal hard drive. I don't know if it will work yet (as it takes some time for it to re-index) but I will let you know when it is done and I have tried backing it up again. You can also try telling time machine to not back up the system files and if there is an issue there it will go around it.

indris 10-01-2012 10:56 AM

funny. Now i tried just for the hell of it to rebuild the disk (disk utility) both on the drive-level and the partition-level (although the backup disk only has one partition...) and then suddenly it backed up without trouble!!!!


All times are GMT -4. The time now is 06:52 AM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.