Results 1 to 3 of 3
  1. #1

    Member Since
    Sep 26, 2012
    Mac OS X 10.5.8 (9L31a) upgrade
    I have an imac Mac OS X 10.5.8 (9L31a),
    Model Name: iMac
    Model Identifier: iMac8,1
    Processor Name: Intel Core 2 Duo
    Processor Speed: 2.4 GHz
    Number Of Processors: 1
    Total Number Of Cores: 2
    L2 Cache: 6 MB
    Memory: 1 GB
    Bus Speed: 1.07 GHz
    Boot ROM Version: IM81.00C1.B00
    SMC Version (system): 1.29f1
    Serial Number (system): W884357LZE2
    Hardware UUID: 909184E2-BB23-5EA0-A2EC-9B959C86125E

    And I need to upgrade my operating system. Seems I need snow leopard before lion. Snow leopard wont instal. any suggestions? Can I upgrade?

  2. #2

    Raz0rEdge's Avatar
    Member Since
    Jul 17, 2009
    27" i7 iMac, 24" iMac, 13" Macbook Air, iPhone 5 & 5S, iPod Nano 7th Gen, iPad 2 16GB WiFi, iPad 3
    Do you have a copy of Snow Leopard that you are trying to install? What errors are you getting specifically? Your machine supports Mountain Lion (the latest release) as long as you upgrade your memory from 1GB to more. You should do that anyway since RAM is relatively cheap these days. You can go up to 4GB which should be fine with ML.

    Now you do have to download ML from the Mac App Store, but if you have a friend with a Mac that's Snow Leopard and newer, you could use your Apple ID on their machine to download it, or you can go to an Apple Store and see if they can help with that..

    Be sure to read the Community Guidelines | The more information you provide, the better answers you get, remember GIGO.

  3. #3

    pigoo3's Avatar
    Member Since
    May 20, 2008
    2011 13" MBP 2.3ghz, 8gig ram, OS 10.8.5
    Quote Originally Posted by HoldThePromise View Post
    Seems I need snow leopard before lion.
    Yes & no. 2-3 months ago this was true. You needed SL installed (minimum of 10.6.6) to access the Mac App Store (MAS). Then you could download Lion (OS 10.7). But now…Lion is no longer available on the MAS…since OS 10.8 "Mountain Lion was released. So even having Snow Leopard (OS 10.6.6) installed won't help to get Lion.

    If your eventual goal is to install OS 10.7 "Lion"…you need to call Apple at their 800 number (not retail Apple Stores).

    Quote Originally Posted by HoldThePromise View Post
    Snow leopard wont instal. any suggestions? Can I upgrade?
    If you have a retail Snow Leopard install disk (whitish disk with a photo of a Snow Leopard on it)…it most definitely will install.

    - Nick
    - Too many "beachballs", read this: Beachballs
    - Computer seems slower than it used to? Read this for some slow computer tips: Speedup
    - Almost full hard drive? Some solutions. Out of Space
    - Apple Battery Info. Battery

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. can't upgrade browser because can't upgrade mac
    By Japple79 in forum OS X - Operating System
    Replies: 79
    Last Post: 11-27-2014, 10:15 AM
  2. Replies: 2
    Last Post: 08-13-2012, 06:50 PM
  3. Replies: 1
    Last Post: 01-21-2011, 04:06 PM
  4. mac upgrade ?
    By chihiro in forum Schweb's Lounge
    Replies: 15
    Last Post: 08-06-2007, 04:21 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts