My daughter left my BMP in sleep mode and run out of battery, I discovered when I turn it on and found it started from hibernation state but the loading bar stayed on the left and nothing happened. Reboot a couple of times, no changes. I thought disk was dead. I boot from my Snow Leopard CD-ROM and run Disk Utility, HD had node errors, reformatted HD and reinstalled SL. Then after instalation it asked to restore security copy, then I said yes, and connected my external HD and restored from the last Lion backup. At this point all seemed to be alright. Then I reboot and problems started. SL didn't boot, BMP turned on, screen stayed in gray background, no turning wheel, sounds from HD like hardware startup test in a loop. Tried to boot from CD-ROM (boot+"C") but didn't boot from CD-ROM.

Later I realized my mistake was to restore a Lion backup over SL.

I read in Apple Support pressing ALT key let choose boot drive. I tried this, and a button labeled EFI showed in the middle of the gray screen, click, and after a while it loaded a Utility with some tools: Restore Lion, Disk Utility, and some others. I tried Restore Lion, but it answered it wasn't possible. Then I went to Disk Utility and tried to erase the HD, it started erasing it but stopped at some point with an error with something like "Hard Drive can't be erased", then the HD icon disappeared from the list of available drives. I then reboot to try again to boot from CD-ROM, but now no CD-ROM boot possible, boot with ALT key shows EFI icon but do nothing when clicking on it now. So I got stuck.

Next day I took with my MBP to Apple local Service (I live in Santiago, Chile), they told me my MBP (A1211, late 2006) was discontinued by Apple so they couldn't give me help. They only advised me to replace the HD, but no key why the HD was dead.

Replacing the HD is the only solution or can I get my HD again operative with some trick?

Why I can't boot from CD-ROM now?
Is the problem related with the HD firmware when I restored Lion backup over a SL system?
Can I get some HD firmware restored for SL using some software to be run from a USB pendrive?

Thanks for any ideas.