New To Mac-Forums?

Welcome to our community! Join the discussion today by registering your FREE account. If you have any problems with the registration process, please contact us!

Get your questions answered by community gurus Advice and insight from world-class Apple enthusiasts Exclusive access to members-only contests, giveaways and deals

Join today!

 
Start a Discussion
 

Mac-Forums Brief

Subscribe to Mac-Forums Brief to receive special offers from Mac-Forums partners and sponsors

Join the conversation RSS
OS X - Operating System General OS operation information and support

Safari Issues! Help!


Post Reply New Thread Subscribe

 
Thread Tools
Guinea-pig

 
Guinea-pig's Avatar
 
Member Since: Jun 07, 2012
Location: England
Posts: 2
Guinea-pig is on a distinguished road
Mac Specs: 10.6.8 2010 Macbook Pro

Guinea-pig is offline
I have a rather irritating issue with my safari....Sometimes when I try to go onto a website, safari redirects my page to something random. Secondly, a lot of the time, Safari refuses to load some web pages...for example - I would click on Facebook and the blue bar at the top freezes halfway...half an hour later - it works fine again. And thirdly, many pictures don't load on safari as well. I have a Macbook Pro 2010 10.6.8. Please help!
QUOTE Thanks
Daoudmac

 
Member Since: Jun 07, 2012
Posts: 1
Daoudmac is on a distinguished road

Daoudmac is offline
Quote:
Originally Posted by Guinea-pig View Post
I have a rather irritating issue with my safari....Sometimes when I try to go onto a website, safari redirects my page to something random. Secondly, a lot of the time, Safari refuses to load some web pages...for example - I would click on Facebook and the blue bar at the top freezes halfway...half an hour later - it works fine again. And thirdly, many pictures don't load on safari as well. I have a Macbook Pro 2010 10.6.8. Please help!
I'm having the same issues across the board on my Mac Pro desktop and MacBook Pro, I think its due to the recent update of 5.1.7. Before that update all ran well and smooth, since then I have experienced the same issues you list as well.
QUOTE Thanks
Guinea-pig

 
Guinea-pig's Avatar
 
Member Since: Jun 07, 2012
Location: England
Posts: 2
Guinea-pig is on a distinguished road
Mac Specs: 10.6.8 2010 Macbook Pro

Guinea-pig is offline
It's good to know I'm not the only one....hopefully Apple will figure this out soon!
QUOTE Thanks

Post Reply New Thread Subscribe


« Network problems between OSX Lion and Windows 7 | iMac in RAID-0 »
Thread Tools

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off
Forum Jump

Similar Threads
Thread
Thread Starter
Forum
Replies
Last Post
OS X Lion Bug: Safari guzzling massive amounts of RAM OneMoreThing... Apple Rumors and Reports 33 08-01-2011 10:07 PM
Safari lagging issues on 10.7 lion Knapp40 OS X - Apps and Games 3 07-27-2011 06:48 AM
Safari 4 Beta Issues kwt_2000 OS X - Apps and Games 90 08-01-2009 05:02 AM
Safari 4 beta issues rsherid OS X - Apps and Games 26 06-17-2009 10:59 PM
Safari ISSUES!!! chrisb2999 OS X - Operating System 1 01-30-2006 02:36 PM

All times are GMT -4. The time now is 10:37 AM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
X

Welcome to Mac-Forums.com

Create your username to jump into the discussion!

New members like you have made this community the ultimate source for your Mac since 2003!


(4 digit year)

Already a member?