Results 1 to 8 of 8
  1. #1


    Member Since
    Jun 05, 2012
    Posts
    3
    Extremely slow Internet on iMac, but ok on iPad
    In the last week or so, Internet access on my iMac has got slower and slower, both using Safari and Google Chrome. Now, nothing completes loading - the blue stripe gets part way across the "address" but then gets stuck. This happens when connected to my router via Ethernet or AirPort or both. But Internet access works fine on my iPad and on my children's (Windows) laptops. Help!

  2. #2


    Member Since
    Mar 09, 2011
    Posts
    751
    Specs:
    mbp 15 2009, mbp 13 2010
    could you reset the modem ? see how it works.

  3. #3


    Member Since
    Jun 05, 2012
    Posts
    3
    I have turned off router and turned it back on again - it used to help a bit but now has no effect. Ditto turning the iMac off, leaving it overnight and turning back on (and router and iMac off and on together).

  4. #4


    Member Since
    Mar 09, 2011
    Posts
    751
    Specs:
    mbp 15 2009, mbp 13 2010
    which model year is your imac ? could you use ethernet cable link from router to your imac, see how it works.

  5. #5


    Member Since
    Jun 05, 2012
    Posts
    3
    Thanks.

    I bough the iMac in 2010.

    I have been using same Ethernet cable since I bought the iMac.

  6. #6


    Member Since
    Jun 22, 2012
    Posts
    2
    I wish I could help, but I'm here bc I have the exact same problem. We bought our iMac 5 days ago. Internet has gotten slower and slower until now it's totally stuck. iPad and compaq laptop work fine. It's just the iMac. I've spent countless hours on the phone with apple support and they finally told me last night to return the iMac to best buy and exchange it for another one. Not sure if I want another one, this machine costs way to much to have so many problems so soon.

  7. #7


    Member Since
    Aug 10, 2011
    Posts
    53
    Have you tried flushing your history, cleaning out cached sites, resetting the browsers to defaults, making sure you have the latest OS updates? This is where I would definitely start. If your ipad is working fine, sounds like you have a browser issue.

  8. #8


    Member Since
    Jun 22, 2012
    Posts
    2
    Hopefully that will work for you, it didn't for me.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. iMac internet is extremely slow
    By bca in forum Apple Desktops
    Replies: 3
    Last Post: 12-03-2012, 03:09 PM
  2. My internet became extremely SLOW on my MacBook Pro
    By sasha007 in forum Internet, Networking, and Wireless
    Replies: 0
    Last Post: 12-22-2008, 10:20 PM
  3. New MBP. Extremely Slow Internet
    By sandaddiction in forum Internet, Networking, and Wireless
    Replies: 4
    Last Post: 10-14-2008, 05:55 PM
  4. Extremely Slow Internet
    By wesley7777 in forum Internet, Networking, and Wireless
    Replies: 12
    Last Post: 08-24-2008, 01:31 AM
  5. Wireless Internet is extremely slow
    By Cosmic in forum Apple Notebooks
    Replies: 8
    Last Post: 07-30-2008, 04:21 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •