Results 1 to 7 of 7
  1. #1


    Member Since
    May 18, 2012
    Posts
    6
    Exclamation Updated software and..... No itunes, Iphoto, mail, safari, or software updater
    Hey all,
    I own an iMac, which runs os x 10.6.8 with an Intel core. A few days ago, I updated lots of software (including the not-so-recent security update) iTunes, Safari, and a few others I don't remember. I let that run overnight, and when I came back in the morning, have my applications had stopped working. Thos listed in the title are the main ones, but there a a few other (including Utorrent, Avaast, Pacifist, and Zipeg so far) which are not built-in and were not included in the update.Due to its far-reaching consequences, I'd hedge my bets on it being due to the security update, but I have no proof. Google proved fruitless, so now I'm appealing for help. (For any smart-arses wondering how I can use google without safari, Chrome + firefox work fine)
    So far I have tried:
    - Deleting all the com.apple.x.plist files for the relevant apps
    - Deleting iPhoto entirely (it worked for one person)
    - repairing disk permissions

    And if I don't here from anyone, I'm going to try reinstalling OS X.

  2. #2

    RavingMac's Avatar
    Member Since
    Jan 07, 2008
    Location
    In Denial
    Posts
    7,894
    Specs:
    4GB Mac Mini 2012, 13" MBA, 15" MacBook Pro OSX 10.7, 32 GB iPhone 3GS, iPad2 64gb 3G
    Have you tried downloading the combo updater and installing that?
    http://support.apple.com/kb/DL1399
    I've always wanted to be smart, handsome and modest. But, I guess I'll have to be satisfied with two out of three . . .

  3. #3


    Member Since
    May 18, 2012
    Posts
    6
    Question
    Tried that, it hasn't helped.
    However, rebooting gave me another symptom : My macs loading time, both for the whole os, and the individual accounts, was more than tripled compared to normal.

  4. #4

    chscag's Avatar
    Member Since
    Jan 23, 2008
    Location
    Fort Worth, Texas
    Posts
    48,502
    Specs:
    Late 2013 27" iMac, iPad 3, iPhone 6s+, iPhone 6+, 3 iPods, El Capitan
    Before deciding on reinstalling Snow Leopard, I suggest doing a verify and if necessary, repair of your hard drive. Boot the machine with your Snow Leopard DVD and enter Disk Utilities. Click on the First Aid tab and run a verify and repair for the hard drive.

    It's possible your hard drive is acting up and that may be the reason for all your difficulties.

  5. #5


    Member Since
    May 18, 2012
    Posts
    6
    I already tried that, as mentioned in my original post. TY anyway.

    It turns out that the update failed for some reason ( I don't know why) leaving me without a web kit framework. By the time I had deleted and reinstalled safari, it re-added the required framework. Problem solved.

  6. #6


    Member Since
    Jan 22, 2010
    Location
    Victoria, BC
    Posts
    20,911
    Specs:
    Mid-2012 MBP (16GB, 1TB HD), Monoprice 24-inch second monitor, iPhone 5s 32GB, iPad Air 2 64GB
    Moral of the story: when leaving a large download to run overnight, DISABLE your energy saver settings.

  7. #7


    Member Since
    May 18, 2012
    Posts
    6
    Aye......

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Safari, itunes and software updater all dont work
    By Macmaxxx in forum OS X - Operating System
    Replies: 7
    Last Post: 02-01-2011, 05:07 PM
  2. Problem with Software Updater
    By clarhanson in forum Apple Notebooks
    Replies: 11
    Last Post: 03-30-2010, 10:01 PM
  3. Software Updater does nothing!!
    By wlshyd in forum OS X - Operating System
    Replies: 3
    Last Post: 01-02-2009, 02:46 AM
  4. Software Updater
    By UncSki1218 in forum Running Windows (or anything else) on your Mac
    Replies: 3
    Last Post: 01-17-2006, 10:40 PM
  5. Questions about software updater
    By jwizz95 in forum Switcher Hangout
    Replies: 0
    Last Post: 10-17-2005, 02:59 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •