New To Mac-Forums?

Welcome to our community! Join the discussion today by registering your FREE account. If you have any problems with the registration process, please contact us!

Get your questions answered by community gurus Advice and insight from world-class Apple enthusiasts Exclusive access to members-only contests, giveaways and deals

Join today!

 
Start a Discussion
 

Mac-Forums Brief

Subscribe to Mac-Forums Brief to receive special offers from Mac-Forums partners and sponsors

Join the conversation RSS
OS X - Operating System General OS operation information and support

Wireshark


Post Reply New Thread Subscribe

 
Thread Tools
cbrun

 
Member Since: Mar 26, 2012
Posts: 1
cbrun is on a distinguished road

cbrun is offline
New to Mac ... simply trying to get wireshark running. Piece of cake on a PC, but with the MAC it pretends to start, then nothing. Google for help gets me lots of hits, but no clear answers. Some say to do something called Macports, but when I try to load it, and I tried all the animals (Lepords, Lions, etc), each said it was wrong. I am running 10.6.4.

Some answers deal with running from the command line, and that atleast brings up the Wireshark window, but them fails. I get:

coabrunltam002:~ root# /Applications/Wireshark.app/Contents/MacOS/Wireshark
2012-03-26 12:47:57.241 defaults[1717:903]
The domain/default pair of (kCFPreferencesAnyApplication, AppleAquaColorVariant) does not exist
2012-03-26 12:47:57.251 defaults[1718:903]
The domain/default pair of (kCFPreferencesAnyApplication, AppleHighlightColor) does not exist
dyld: Library not loaded: /usr/X11/lib/libfreetype.6.dylib
Referenced from: /Applications/Wireshark.app/Contents/Resources/bin/wireshark-bin
Reason: Incompatible library version: wireshark-bin requires version 13.0.0 or later, but libfreetype.6.dylib provides version 10.0.0
coabrunltam002:~ root#


then told to do something with permissions, but that is where it loses me. No clear instructions as to do what with what permissions.

About to load windows on this thing unless someone can help! Just kidding, really though would appreciate any advice.
QUOTE Thanks
RavingMac

 
RavingMac's Avatar
 
Member Since: Jan 07, 2008
Location: In Denial
Posts: 7,449
RavingMac has a reputation beyond reputeRavingMac has a reputation beyond reputeRavingMac has a reputation beyond reputeRavingMac has a reputation beyond reputeRavingMac has a reputation beyond reputeRavingMac has a reputation beyond reputeRavingMac has a reputation beyond reputeRavingMac has a reputation beyond reputeRavingMac has a reputation beyond reputeRavingMac has a reputation beyond reputeRavingMac has a reputation beyond repute
Mac Specs: 4GB Mac Mini 2012, 13" MBA, 15" MacBook Pro OSX 10.7, 32 GB iPhone 3GS, iPad2 64gb 3G

RavingMac is offline
I've never tried WireShark, but one question I have is why are you running 10.6.4 rather than 10.6.8?

Possible OS updates my address the issues you are having.

If I were given just one wish it would be . . . that I could have three more wishes!
QUOTE Thanks
vansmith

 
vansmith's Avatar
 
Member Since: Oct 19, 2008
Location: Ottawa
Posts: 17,107
vansmith has a reputation beyond reputevansmith has a reputation beyond reputevansmith has a reputation beyond reputevansmith has a reputation beyond reputevansmith has a reputation beyond reputevansmith has a reputation beyond reputevansmith has a reputation beyond reputevansmith has a reputation beyond reputevansmith has a reputation beyond reputevansmith has a reputation beyond reputevansmith has a reputation beyond repute
Mac Specs: 2012 13" MBP (2.5 i5, 8GB)

vansmith is online now
Your version of freetype is outdated. Update to 10.6.8 - this may update freetype (hopefully).

As a note - 10.6.x is Snow Leopard (Leopard is 10.5 and Lion is 10.7).

Important Links: Community Guidelines : Use the reputation system if you've been helped.
M-F Blog :: Write for the blog
Mac-Forums Investigates MacKeeper - Confused about MacKeeper? Take a look at this review.
QUOTE Thanks
alcom4x

 
Member Since: Jan 24, 2012
Posts: 20
alcom4x is on a distinguished road
Mac Specs: iMac 27" i5 3.1GHz/12GB RAM/1GB 6970

alcom4x is offline
Mine works fine under lion 10.7.3 Perhaps you should try reinstalling it?
QUOTE Thanks
mdfuller

 
mdfuller's Avatar
 
Member Since: Nov 01, 2007
Location: Sconie
Posts: 1,217
mdfuller is a jewel in the roughmdfuller is a jewel in the roughmdfuller is a jewel in the rough
Mac Specs: 15-inch MacBook Pro

mdfuller is offline
I had issues with interfaces not showing up until I did a sudo chown <user> /dev/bpf* from Terminal. Not sure if this will help you out or not.
QUOTE Thanks
BrianLachoreVPI

 
BrianLachoreVPI's Avatar
 
Member Since: Feb 24, 2011
Location: Maryland
Posts: 3,742
BrianLachoreVPI has a brilliant futureBrianLachoreVPI has a brilliant futureBrianLachoreVPI has a brilliant futureBrianLachoreVPI has a brilliant futureBrianLachoreVPI has a brilliant futureBrianLachoreVPI has a brilliant futureBrianLachoreVPI has a brilliant futureBrianLachoreVPI has a brilliant futureBrianLachoreVPI has a brilliant futureBrianLachoreVPI has a brilliant future
Mac Specs: March 2011 15" MBP 2.3GHz i7 Quad Core 8GB Ram | Mid 2011 27" iMac 3.4 GHz i7 16 GB RAM 2 TB HDD

BrianLachoreVPI is offline
Interesting. I actually hadn't brought up Wireshark since updating to Lion - it took a while to come up - and sent my processor into overdrive for a bit - but then it came up fine. Took about 2 min on my machine for some reason...

You have to have the X11 Terminal available. Installing Wireshark on Apple OSX
QUOTE Thanks

Post Reply New Thread Subscribe


« Deleting bookmarks - Firefox and Safari | Dropbox/iDisk alternative »
Thread Tools

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off
Forum Jump

Similar Threads
Thread
Thread Starter
Forum
Replies
Last Post
Anyone get wireshark to work on win7 bootcamp? rude_rudeboy Internet, Networking, and Wireless 0 05-01-2011 04:16 PM
WireShark Error - No Interfaces - MAC OS X 10.5 Max Avion Internet, Networking, and Wireless 8 04-16-2011 12:14 AM
trying to install Wireshark xtine OS X - Apps and Games 0 02-07-2010 04:01 PM
WireShark - no interface listed jag5cof OS X - Apps and Games 1 03-21-2009 08:15 AM
Wireshark troubles dieselpwr Internet, Networking, and Wireless 1 10-09-2007 09:15 PM

All times are GMT -4. The time now is 09:23 AM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
X

Welcome to Mac-Forums.com

Create your username to jump into the discussion!

New members like you have made this community the ultimate source for your Mac since 2003!


(4 digit year)

Already a member?