Results 1 to 3 of 3

Thread: Leopard 10.5.6

  1. #1

    Member Since
    Mar 01, 2012
    Leopard 10.5.6
    Hello everyone
    Ido not have any experience with mac being new to the mac system use,
    I have a powermac G5 duo and have just ordered a new copy of Leopard 10.5.6.
    My question is can I run this oxs on my G5 A11777EMC 2023.
    I hope that some one can give me an answer, as I can only return the software if it is unopened. and I would hate to open it, try to load it and then find that it will not run on the system

  2. #2

    dtravis7's Avatar
    Member Since
    Jan 04, 2005
    Modesto, Ca.
    iMac 2010 27" QuadI7, iMac 2008 10.10.5, Macbook2007 10.7.5, Mac Mini 10.7.5, iPhone 3GS Note 8!
    Is the 10.5.6 you purchased a full retail version or just a DVD that came with another Mac and is Gray? If it's the full retail then yes it will run fine on your G5 2.0 Dual!

    10.5 Leopard is the last version of OSX that will run on your Power PC G5. After you install run Software Update and it will update to 10.5.8.

  3. #3

    Member Since
    Mar 01, 2012
    Leopard 10.5.6
    thanks Travis,
    Yeah it is a full retail version, that I have ordered, and it sure is a relief knowing that it will work
    Thanks again

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Dual boot, Upgrading leopard to snow leopard. Issue?
    By DINI22 in forum Running Windows (or anything else) on your Mac
    Replies: 2
    Last Post: 02-03-2012, 11:05 PM
  2. VMware Fusion update lets users virtualize Leopard, Snow Leopard (MacWorld)
    By Lifeisabeach in forum Apple Rumors and Reports
    Replies: 16
    Last Post: 11-22-2011, 05:20 PM
  3. Replies: 2
    Last Post: 08-10-2011, 03:00 PM
  4. Replies: 6
    Last Post: 01-02-2011, 06:15 PM
  5. Replies: 2
    Last Post: 04-10-2010, 06:09 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts