Results 1 to 6 of 6
  1. #1


    Member Since
    Mar 15, 2012
    Posts
    2
    Self-Assigned IP address
    Hello,

    I cannot connect to my wireless internet. It has been working fine for weeks and today it will not connect. It says I have full bars but then I cannot access the internet.

    It says Self-Assigned IP address. May not be able to connect to the internet. I have done some looking around online but no one seems to have a solution.

    I know the internet is working as I am connected via Ethernet. This has happened once before at a hotel and I could not fix it. As I live here, though, I really need my wireless working.

    Can anyone help?

    Thank ou

  2. #2

    mrplow's Avatar
    Member Since
    Oct 01, 2007
    Location
    UK
    Posts
    6,910
    Specs:
    27" iMac i7 (2011) 10.11, Mac Mini i5 (2014), iPhone6s, Apple Watch, iPad Pro 9.7, AppleTV (4)
    I know the internet is working as I am connected via Ethernet. This has happened once before at a hotel and I could not fix it. As I live here, though, I really need my wireless working.
    1. Sorry I'm a bit confused are you connected to your router by ethernet or wifi?
    2. Is this your home internet connection? If so Power cycle your router then reboot your Mac
    3. Which Mac model do you have and which version of OSX?
    Not been around these parts for a while. Trying to change that . .

    Please use the reputation system if you think you've been helped - bottom left of this post

  3. #3


    Member Since
    Mar 15, 2012
    Posts
    2
    Thanks for writing back.

    I am connected via Ethernet at the moment. But the wifi has worked until today.
    I am on a Macbook Pro Version 10.5.8
    I have already rebooted the router (is that what you mean by power cycle?) and restarted by computer. It's just not working.

    Any other suggestions?

  4. #4

    mrplow's Avatar
    Member Since
    Oct 01, 2007
    Location
    UK
    Posts
    6,910
    Specs:
    27" iMac i7 (2011) 10.11, Mac Mini i5 (2014), iPhone6s, Apple Watch, iPad Pro 9.7, AppleTV (4)
    Yes power cycle/reboot. But by removing the power not reboot from the web interface

    OK.
    1. do you have any other wireless devices? Do they connect OK?
    2. have you had any OSX or router updates/changes in the past day or so?
    3. What sort of wireless encryption is the router using? WEP/WPA etc.
    Not been around these parts for a while. Trying to change that . .

    Please use the reputation system if you think you've been helped - bottom left of this post

  5. #5


    Member Since
    Jan 23, 2012
    Location
    Guerrero, Mexico
    Posts
    43
    Specs:
    Mac mini 2.3GHz Intel Core i5 2GB RAM 500GB HD OS X Lion 10.7.3
    Quote Originally Posted by MAC75005 View Post
    Thanks for writing back.

    I am connected via Ethernet at the moment. But the wifi has worked until today.
    I am on a Macbook Pro Version 10.5.8
    I have already rebooted the router (is that what you mean by power cycle?) and restarted by computer. It's just not working.

    Any other suggestions?
    Hi Mac75005,

    Yesterday I could not connect to the internet and I had that "self-assigned IP address" message coming up.

    I tried two things, the second option is what worked for me, but I also tried the first

    RESET YOUR MAC'S FIRE WALL:
    1.Go to Macintosh HD/Library/Preferences/ folder and move the files called "com.apple.alf.plist," and "com.apple.alf.plist.lock" to the trash.
    2. Restart your computer. (when restarting you may be prompted to allow incoming connections to numerous programs and services, you can accept these and can later go to the Firewall settings and deny or remove them later..
    3. Try connecting to the network again.

    GET NETWORK ASSISTANCE:
    1. Open Network Preferences
    2. Click on the "Assist me..." button on the bottom center of the window
    3. Click "Assistant"
    4. Leave the "Location Name" it suggests (mine yesterday was "Location (3/24/12 12:22 AM)"
    5. Click "Continue"
    6. Check the "I use a DSL modem to connect to the Internet." option
    7. Click Continue
    8. Click Continue in the next "Ready to Connect?" screen
    9. Enjoy Wi-fi again!

  6. #6


    Member Since
    Dec 11, 2010
    Location
    Chicago
    Posts
    1,482
    Specs:
    late 2012 mini w/SSD
    You should answer Mr Plow's questions.
    Also, have you looked at the Airport pull-down at the top of your desktop to see whether you are connected to YOUR router?
    When you disconnect the ethernet for WiFi troubleshooting, do you give it 3-4 minutes to complete the connection, before re-plugging ethernet?
    When you've re-booted/power-cycled the router, did you have ethernet to the computer unplugged?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Self-assigned IP address/no IP address, internet connection issue
    By leechalmers in forum Internet, Networking, and Wireless
    Replies: 7
    Last Post: 06-07-2013, 11:33 PM
  2. Self-Assigned IP Address
    By Cormag001 in forum Internet, Networking, and Wireless
    Replies: 4
    Last Post: 12-30-2011, 02:02 AM
  3. Self assigned ip address
    By hollymaya in forum Internet, Networking, and Wireless
    Replies: 11
    Last Post: 05-24-2011, 04:03 PM
  4. Self-Assigned IP address
    By raechul in forum Internet, Networking, and Wireless
    Replies: 10
    Last Post: 04-05-2011, 11:49 AM
  5. Self Assigned IP Address
    By BGvlm620 in forum Internet, Networking, and Wireless
    Replies: 7
    Last Post: 06-19-2010, 11:46 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •