I have a 13" MacBook Pro 7,1 and a Netgear WNDR 4500 router with two USB ports on it. To use one of the USB ports for a printer you need to install the software on their website. I installed the printer software on my mac running 10.7 Lion and when I rebooted my machine I couldn't log on. Whenever I boot now I see a loading bar that takes about five minutes to load and then I get to the login screen for my macbook. When I try to log in the screen turns gray and then goes back to the login screen. I don't have a password for my account but if I put in a wrong password the usual thing happens. I then tried to boot in safe mode and the same thing happens. I booted to my recovery partition and tried to restore from my time machine backup and I couldn't select the partition that OS X is installed on. So I decided that I'd try a Lion reinstall, and I can't select the partition that OS X is on to reinstall. I then opened up disk utility and tried to repair the partition that OS X is on but the repair always fails. I then decided that I would delete my OS X partition and do a complete reinstall but disk utility won't let me erase the partition that OS X is on. I don't want to wipe the entire disk because I have a bootcamp partition set up with Windows that I would like to keep. I have no Idea what to do now.