Mac Forums

Mac Forums (
-   OS X - Operating System (
-   -   Hidden files on desktop (

sophie.21 03-14-2012 07:04 PM

Hidden files on desktop
When i look at my desktop I cant see anything but when i open up my hard drive to look at all my documents and click desktop folder there are over 1000 things but i cant click any of them. sometimes if the mouse is in the corner of the desktop it drags something out but i really dont know how.

When i try to delete them from the folder a pop up message says "this is being used by another application" but nothing else is running...

I've tried desktop finder and switching the visibility to invisible but they come up in the desktop folder as visible items - not invisible. (although i do have invisible ones that i cant delete either...)

I tried terminal but i don't really know what that is or how to use it... someone gave me a command to type in but it didnt work when I did.

Please help!!

vansmith 03-14-2012 07:24 PM

What command did they make you type? When you look at the Desktop through a Finder window, do you recognize the files?

Give this a try: go to the Go menu > hold down "option" > go to Library > Preferences > move "" somewhere safe (like your home folder) > restart your Mac.

sophie.21 05-17-2012 11:07 PM

I can't see any options in the go menu.... i keep trying to delete them and if i drag some randomly show up out of the corner but it takes forever to delete them.. they are all old files/photos that i put in the trash but are hidden on the desktop now!

MariaPeter 05-23-2012 05:14 AM

* Launch the Terminal and enter these commands exactly as shown. The first command activates the ability to see the hidden files:

defaults write AppleShowAllFiles TRUE Now you must relaunch the Finder by killing it, this is how the changes take effect:

killall Finder

* You can quickly show all hidden files in any Mac OS X save dialogue box by hitting Command+Shift+Period

chas_m 05-23-2012 05:18 AM

I think I may know what's going on.

Try this, Sophie ... in the Finder, go to the View menu in the menubar, choose "View Options" and make sure the very last item says "Sorted by: None" (if it already says this, change it to "Snap to Grid")

Then restart the machine.

All times are GMT -4. The time now is 06:16 AM.

Powered by vBulletin
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.