Mac Forums

Mac Forums (http://www.mac-forums.com/forums/)
-   OS X - Operating System (http://www.mac-forums.com/forums/os-x-operating-system/)
-   -   Mystery: Macbook losing connection within browser, even after reinstall of Mac OS (http://www.mac-forums.com/forums/os-x-operating-system/266569-mystery-macbook-losing-connection-within-browser-even-after-reinstall-mac-os.html)

TheSkeptic 02-14-2012 05:05 AM

Mystery: Macbook losing connection within browser, even after reinstall of Mac OS
 
So I'm facing a seemingly impossible mystery that started a week ago on the day I returned from a trip: I am regularly losing my internet connection within my browser windows on my MacBook Pro. Let me explain what I mean by this:

- While loading web pages, my browser suddenly stops loading them and behaves as though I am not connected to the internet.
- While the problem is occurring, other things, like IM messengers, system updates being downloaded, etc continue functioning as normal without any interruption to the connection.
- There is no visible disconnection from the wireless router.
- I can continuously ping google while this problem is occurring, without interruption.
- The problem persists regardless of which browser I use: Chrome, Safari or FireFox
- Usually the problems occurs with all websites, occasionally it seems limited to some sites (google won't load, bing will)
- When I reset my wireless connection, the problem is instantly solved, though it commonly re-occurs within minutes.
- Often but not always, after the connection has resumed, any tabs that 'failed' will continue to act as though the problem is continuing, though new tabs have started connecting to sites again. (So: I can copy and paste the URL into a different tab, and it will work again in that one, but still not in the original. This is not a solution to the problem, this is only after I've temporarily 'fixed' it by reconnecting to the wireless)
- No virus scanners have detected anything unusual
- No other computers on the network, wired or wireless, including another Macbook Pro, are having this issue, so it must be this Macbook, not the network.
- I just connected my macbook to the ethernet and disconnected from the wireless, and the problem, contrary to my expectations, continued! Thus it is not related to the wireless router.

And here's what really gets me:
- After a week of troubleshooting (with an experienced System Admin who works with Macs on a daily basis), we finally decided to completely reinstall Mac OS. The problem persisted and was present from the very first moment, long before I had transferred anything back on, or downloaded anything, or visited any odd sites, or changed any settings.

The Macbook Pro worked fine during my trip, the only noteworthy thing that happened was that, during one of the last days in my hotel, after having done nothing unusual with my macbook, some websites told me I could not connect because a "computer on my network may be compromised" or something. That evening I could not manage to log on to the hotel wireless. I called their network support, and they passed my IP straight through. After that it worked just fine. I had no connection issues like the ones I have now until I arrived at home.

The only things that happened in between the hotel and home are that I went to the airport, the macbook passed through a scanner of course, and I met Bill Murray. So what's wrong? Did Bill Murray curse my Macbook?

bzzlink 02-27-2012 11:36 AM

Don't get your hopes up, I don't know the answer.

Just wanted to tell you that you are not alone. Have the exact same problem with a early 2011 Macbook Pro 13" it runs snow leopard.

It's driving me crazy, was about to do a clean install, so my heart sank when I read that you have tried that.

My next step is to upgrade to Lion to see if that helps, which version are you running?

I can also tell you with somewhat certainty that mine may or may not have been in contact with Murray or his son.

rabbitjetta 02-27-2012 11:15 PM

Mine does the same thing what version of safari do you have. I am running the beta of safari for lion (5.2) and it seems to have fixed the issue.

TheSkeptic 02-29-2012 12:01 AM

Thanks for responding at least :) I've found no solution yet and am wondering whether I should take it in to see if there's a hardware issue. Oh, and bad news, I was already running Lion :/


All times are GMT -4. The time now is 11:12 AM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.