New To Mac-Forums?

Welcome to our community! Join the discussion today by registering your FREE account. If you have any problems with the registration process, please contact us!

Get your questions answered by community gurus Advice and insight from world-class Apple enthusiasts Exclusive access to members-only contests, giveaways and deals

Join today!

 
Start a Discussion
 

Mac-Forums Brief

Subscribe to Mac-Forums Brief to receive special offers from Mac-Forums partners and sponsors

Join the conversation RSS
OS X - Operating System General OS operation information and support

need to install 10.6 for new printer.


Post Reply New Thread Subscribe

 
Thread Tools
gerrymama

 
Member Since: Dec 20, 2011
Posts: 2
gerrymama is on a distinguished road

gerrymama is offline
My new printer canon pixma mx882 will not install on my Mac OS x 10.4.11. Finally a message saying I need 10.6. I am not computer friendly and have totally assembled my new printer and now my mac will not let it finish loading the software. Is it goiing to cost me $$ for the new upgrade? and will I have to reload other programs I already have?? Again I am a senior and am not too computer knowledgeable. Thank you for any help.
QUOTE Thanks
gsahli

 
Member Since: Dec 11, 2010
Posts: 1,026
gsahli is a jewel in the roughgsahli is a jewel in the roughgsahli is a jewel in the rough

gsahli is offline
Upgrading to Snow Leopard (10.6) costs $29. But, you haven't told us enough info - is your Mac an Intel or PowerPC cpu Mac? If it's PowerPC, you can't upgrade to Snow Leopard.
QUOTE Thanks
gerrymama

 
Member Since: Dec 20, 2011
Posts: 2
gerrymama is on a distinguished road

gerrymama is offline
Thank you..I have a MAC OS X Version 10.4.11; 2.16 GHz Intel Core 2 Duo
QUOTE Thanks
Snowleopard

 
Member Since: Dec 15, 2009
Posts: 47
Snowleopard is on a distinguished road

Snowleopard is offline
Should be an easy upgrade to snow leopard here, does'nt cost too much.

09' Apple iMAC 3.06Ghz
'10 Apple MacBook Pro (unibody) 2.4 GHz
QUOTE Thanks
chas_m

 
chas_m's Avatar
 
Member Since: Jan 22, 2010
Location: Victoria, BC
Posts: 16,425
chas_m has a reputation beyond reputechas_m has a reputation beyond reputechas_m has a reputation beyond reputechas_m has a reputation beyond reputechas_m has a reputation beyond reputechas_m has a reputation beyond reputechas_m has a reputation beyond reputechas_m has a reputation beyond reputechas_m has a reputation beyond reputechas_m has a reputation beyond reputechas_m has a reputation beyond repute
Mac Specs: 2009 MBP, Black speakers, Black Benq second monitor, black(ish) iPhone 5s, Black 2012 iPad, etc.

chas_m is offline
Be aware that if you have installed third-party software (like for example Microsoft Word) or really old software (like, say, AppleWorks), you will probably need to budget for upgrading those things too.

If you've kept your software up-to-date, then no worries.
QUOTE Thanks
technologist

 
Member Since: Mar 30, 2004
Location: USA
Posts: 4,744
technologist has a reputation beyond reputetechnologist has a reputation beyond reputetechnologist has a reputation beyond reputetechnologist has a reputation beyond reputetechnologist has a reputation beyond reputetechnologist has a reputation beyond reputetechnologist has a reputation beyond reputetechnologist has a reputation beyond reputetechnologist has a reputation beyond reputetechnologist has a reputation beyond reputetechnologist has a reputation beyond repute
Mac Specs: 12" Apple PowerBook G4 (1.5GHz)

technologist is offline
If he's only upgrading to Snow Leopard (10.6) then there's no reason that older software, including AppleWorks or Office 2004, won't work. It's Lion (10.7) that breaks those apps.
QUOTE Thanks
chas_m

 
chas_m's Avatar
 
Member Since: Jan 22, 2010
Location: Victoria, BC
Posts: 16,425
chas_m has a reputation beyond reputechas_m has a reputation beyond reputechas_m has a reputation beyond reputechas_m has a reputation beyond reputechas_m has a reputation beyond reputechas_m has a reputation beyond reputechas_m has a reputation beyond reputechas_m has a reputation beyond reputechas_m has a reputation beyond reputechas_m has a reputation beyond reputechas_m has a reputation beyond repute
Mac Specs: 2009 MBP, Black speakers, Black Benq second monitor, black(ish) iPhone 5s, Black 2012 iPad, etc.

chas_m is offline
Every new version (including 10.6) of OS X breaks *some* apps. Just because Rosetta is still supported in 10.6 doesn't mean apps won't break.

To wit: Mac OS X 10.6 Snow Leopard compatibility table - Snow Leopard Compatibility
QUOTE Thanks

Post Reply New Thread Subscribe


« how to reinstal macbook pro without dvd os x leopard | Help needed.. Icon folders gone!! »
Thread Tools

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off
Forum Jump

Similar Threads
Thread
Thread Starter
Forum
Replies
Last Post
Add Printer dialog disabled & empty - no toolbar permutations OS X - Operating System 13 12-06-2011 12:41 PM
Fresh install for 10.6 upgrade? Drew384 OS X - Operating System 4 08-16-2011 07:10 PM
HP PSC 1610 printer will not install after Leopard update mosaleah OS X - Operating System 3 01-04-2010 07:24 PM
Install OSX 10.6 to Old Macbook seo singapore OS X - Operating System 7 12-31-2009 12:05 AM
Driver install for HP Photosmart 7550 printer dkopp1961 Switcher Hangout 3 03-17-2005 03:23 PM

All times are GMT -4. The time now is 12:49 AM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
X

Welcome to Mac-Forums.com

Create your username to jump into the discussion!

New members like you have made this community the ultimate source for your Mac since 2003!


(4 digit year)

Already a member?