Results 1 to 3 of 3
  1. #1

    Member Since
    Nov 18, 2011
    External Hardrive is not readable suddenly
    So I recently bought a Wester Digital, 2 TB, Firewire Hard drive, so I can store my video projects on it for safe keeping. The other night however, I plugged in my hard drive and I got a message saying "The disk you inserted is not readable by this computer." I've tried fixing it through the Disk Utility but repair is not an option on the window, but the hard drive is appearing on the disk utility as "WD 2 TB". I really cannot lose these files and I dont want to pay a ton of money to get the files recovered. Is there something I am not doing correctly? I am not a fluid Mac user, I do not know all their secrets. If there is any advice someone could give me I would greatly appreciate it!


  2. #2

    chscag's Avatar
    Member Since
    Jan 23, 2008
    Fort Worth, Texas
    27" iMac i5, 3.2 GHz, iPad 3, iPhone 5c, iPhone 6+, 3 iPods, El Capitan
    Unfortunately, you're likely doing everything correctly but dealing with a defective hard drive. What I suggest trying first is data recovery software. IMO, the best, and what I use is Data Rescue 3. It's pricey though ($99), however, you can download a trial copy first to see if it will work for you.

  3. #3

    Maxtcc's Avatar
    Member Since
    Oct 20, 2011
    27" i7 imac
    This has happened to me with two WD hard drives. The good news is there is a chance that if you turn it off and walk away for a few hours and nurse a coffee or a beer or something. come back reboot your mac, and then turn on the WD and wait It may come back. I tried this four times with one of my failed WDs and the fourth time was the charm. I Then swiftly ran to the store bought another drive and copied all the info I was desperate for onto the new one and it worked.
    On the second WD drive, this did not work for me after seven tries. So with nothing to loose I took the drive out of its enclosure and took the bare drive with a multi drive cable , (IDE, sata, esata) and plugged it in to my iMac and found that all the info was there and waiting for me to take off and onto another drive.
    I believe the onboard controller was at fault. ( I still use this drive in a spare enclosure , not the original.)

    I hope that this can work for you too, I know the pain and torment of loosing TB of irreplaceable info.

    By the Way the failed drives were WD elements drives. I replaced them with WD Free agent drives.

    P.S> because it was a hardware failure none of the data recovery software worked to do anything and I was afraid to loose the data, so that is why I tried to physically read for data before going there. Once a long time ago I went straight to dat recovery software, but I didn't know what I was doing and ended up erasing everything I was trying to save.

    If you are nervous then try a friend or go to a tech person somewhere, if you really need the info someone will be able to get it , if you are willing to pay the price. Just stay away from doing something you don't know how to do or are willing to risk all that data.
    my $0.02
    Good Luck

Thread Information

Users Browsing this Thread

There are currently 2 users browsing this thread. (0 members and 2 guests)

Similar Threads

  1. exFAT external HD not readable
    By The-Canuckster in forum Switcher Hangout
    Replies: 3
    Last Post: 01-27-2015, 08:25 AM
  2. Replies: 4
    Last Post: 06-09-2013, 10:32 PM
  3. External Hard Drive not readable on Mac
    By kmanforever in forum Other Hardware and Peripherals
    Replies: 5
    Last Post: 01-12-2013, 07:17 PM
  4. External HD not Readable
    By Lefty Loco in forum Other Hardware and Peripherals
    Replies: 2
    Last Post: 09-14-2012, 08:40 AM
  5. External HDD not readable
    By daveyuk1 in forum Apple Notebooks
    Replies: 1
    Last Post: 09-12-2009, 09:29 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts