Results 1 to 5 of 5
  1. #1
    usb ethernet adpater internet connection issues

    Member Since
    Nov 14, 2011
    Posts
    3
    usb ethernet adpater internet connection issues
    I'm trying to extend our network to an outbuilding using powerline network adapters. However, upon attempting a connection I realised that my ethernet port wasn't working. So I purchased an apple usb ethernet adapter hoping that would work.

    But I can't even get a normal working internet connection using it when the ethernet cable is connected straight into my router (macbook (10.4.11) - usb ethernet adapter - ethernet cable - ethernet port on back of netgear dg834pm router) nevermind via the powerline adapters.

    I've tried the following:
    - downloading a driver for the usb ethernet adapter (Sustainable Softworks - News | USB-To-Ethernet Adaptors for Mac OS X),
    - using another macbook (10.5)
    - using various ethernet cables,
    - using network diagnostics,
    - trying various manual configurations
    - renewing the DHCP lease
    - deleting all network locations, wireless networks, known networks, keychains etc.
    - searching the internet!!!!

    The furthest I have got is after downloading the driver and manually assigning an IP address. I now have a flashing port light on my router and a network status green light saying that "Ethernet adapter (en2) is currently active and has the IP address 192.168.0.9.". But upon opening safari no internet. In network diagnostics a green light for airport, airport settings and network settings but a red light for ISP, internet and server.

    My airport configuration works fine.

    I don't really know what I'm doing so all help greatly appreciated! My husband is desparate to get internet in his office at bottom of garden and we can't afford cabling all the way down there, so I really need a solution re power line networking. Thanks in advance.

  2. #2
    usb ethernet adpater internet connection issues

    Member Since
    Dec 11, 2010
    Posts
    1,352
    Very few of us have done what you're trying, so be patient...
    Is en2 the ethernet adapter you added in Port Configurations? You normally need to add a New port configuration when you add hardware (might be called USB adapter (en3) or something similar).

    Built-in ethernet can only refer to the built-in ethernet port...

  3. #3
    usb ethernet adpater internet connection issues
    dtravis7's Avatar
    Member Since
    Jan 04, 2005
    Location
    Modesto, Ca.
    Posts
    28,482
    Specs:
    iMac late 2007 10.11.b4, iMac 2008 10.10.5, Macbook2007 10.7.5, Mac Mini 10.7.5, iPhone 3GS Note 8!!
    Are you sure the built in Ethernet port on the Macbook is dead? That is the first thing I would attack. What Mac is this for sure? Specs please and you say OSX Tiger 10.4.11??

    I will try and help but need to know a few things.

    And you bought an Apple USB Ethernet adapter? The one for the Mac Book Air?

  4. #4
    usb ethernet adpater internet connection issues

    Member Since
    Nov 14, 2011
    Posts
    3
    Thanks for your replies gsahli and dtravis7. In answer to your questions:

    The installation of the driver from (Sustainable Softworks - News | USB-To-Ethernet Adaptors for Mac OS X), automatically set up the new port for USB ethernet as en2. So it is now a different port to 'built in ethernet' which is a separate option in port configurations in network settings. As I was still not getting an internet connection after installing the driver I tried manually configuring. The following information sums up the current settings:


    Ethernet Adaptor (en2):

    Type: Ethernet
    Hardware: Ethernet
    BSD Device Name: en2
    IPv4 Addresses: 192.168.0.9
    IPv4:
    Addresses: 192.168.0.9
    Configuration Method: Manual
    Router: 192.168.0.1
    Subnet Masks: 255.255.255.0
    IPv6:
    Configuration Method: Automatic
    Proxies:
    Proxy Configuration Method: Manual
    ExcludeSimpleHostnames: 0
    FTP Passive Mode: Yes
    Auto Discovery Enabled: No

    Dtravis7, no I am not sure that the ethernet port on the macbook is dead. All I know is that I have used several ethernet wires none of which appear to be recognised by the router but the same wires are now being recognised using the USB ethernet adapter - at least as far as the router ethernet port now flashes, even though I can't get an internet connection. I have also tried various fixes to check that the ethernet port is not dead (like resetting the PRAM). This is the current information from system profiler for built in ethernet:

    Built-in Ethernet:
    Type: Ethernet
    BSD Device Name: en0
    Hardware (MAC) Address: 00:17:f2:f0:ce:53
    IPv4:
    Configuration Method: DHCP
    IPv6:
    Configuration Method: Automatic
    AppleTalk:
    Configuration Method: Node
    DNS:
    Server Addresses: 192.168.0.1
    Proxies:
    Proxy Configuration Method: 2
    ExcludeSimpleHostnames: 0
    FTP Passive Mode: 1
    Auto Discovery Enabled: 0
    Ethernet:
    Media Subtype: autoselect

    Regarding my macbook information:

    Model Name: MacBook
    Model Identifier: MacBook2,1
    Processor Name: Intel Core 2 Duo
    Processor Speed: 2 GHz
    Number Of Processors: 1
    Total Number Of Cores: 2
    L2 Cache (per processor): 4 MB
    Memory: 2 GB
    Bus Speed: 667 MHz
    Boot ROM Version: MB21.00A5.B07
    SMC Version: 1.13f3

    System Software Overview:

    System Version: Mac OS X 10.4.11 (8S2167)
    Kernel Version: Darwin 8.11.1
    Boot Volume: Macintosh HD

    and yes the usb ethernet adapter is an apple one for macbook air but I read in lots of places that it works on other macbooks no problem. This is an extract from the website I got the driver from:

    "With the announcement of the MacBook Air, Apple began shipping their own USB-to-Ethernet adaptor and driver (AppleUSBEthernet). I understand Apple's USB-to-Ethernet adaptor should work on other Macs running Leopard 10.5.2 or later (Daniel Sumorok has verified this). It can also be used on systems running Mac OS X 10.3.9 or later by installing our latest USBAx8817x driver. Apple's driver is not designed to support 3rd party USB-to-Ethernet adaptors or prevoius OS versions. We have modified our own driver to take precedence over Apple's driver when it is installed, and recognize the Apple USB Ethernet Adaptor."

    The driver they mention is the one I installed.

    I hope this information helps you to help me!

    Lorraine

  5. #5
    usb ethernet adpater internet connection issues

    Member Since
    Nov 14, 2011
    Posts
    3
    Can anyone help me?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Ethernet is active but no internet connection (although Wi-fi works)
    By Pluistronaut in forum Internet, Networking, and Wireless
    Replies: 3
    Last Post: 11-03-2012, 05:49 PM
  2. Internet Connection Problems, Wireless and Ethernet
    By Neil79 in forum Internet, Networking, and Wireless
    Replies: 6
    Last Post: 03-15-2012, 05:12 PM
  3. USB Ethernet connection
    By kikiko in forum Internet, Networking, and Wireless
    Replies: 1
    Last Post: 07-11-2010, 10:20 AM
  4. Ethernet connection and boot issues
    By dal566 in forum Internet, Networking, and Wireless
    Replies: 1
    Last Post: 02-04-2010, 01:00 AM
  5. internet/ethernet connection/setup
    By customcomputerd in forum Apple Notebooks
    Replies: 0
    Last Post: 03-08-2005, 07:37 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •