Results 1 to 6 of 6
  1. #1

    Member Since
    Oct 08, 2011
    osx wont accept admin password
    Help Please!! I have a 5 year old IMac running Leapard. recently the OS started to misbehave so I reinstalled the OS and restored the whole machine from my time machine backup. this worked fine!! However my log in is now only "standard" and when I try to do anything that requires admin privileges, the OS does not recognize my name and password .

    This is what I have done to date.

    changed password by booting up with OS DVD
    changed password from system preferences
    checked admin name from ID on the Terminal

    I know my name is correct from the terminal'
    I also know my password is correct from the hint given on third attempt

    Can any one help, machine wont back up or let me install anything, I'm pretty stuffed here

  2. #2

    chscag's Avatar
    Member Since
    Jan 23, 2008
    Fort Worth, Texas
    27" iMac i5, 3.2 GHz, iPad 3, iPhone 5c, iPhone 6+, 3 iPods, El Capitan
    Boot the machine in Single User mode (command s) and create a new user direct from the command line (terminal). See this Link. Create the new user with Admin rights.

    Log on to the new user admin account. Move everything from the old user account to the new one. After verifying that everything is working, delete the old user account.

  3. #3

    Member Since
    Oct 08, 2011
    thank you for your response, but wont i need the original user name and log on in order to migrate everything from one account to the other.

    what do you think of installing snow leopard on top, do you thin this could fix the failure to recognize the correct name and password

  4. #4

    EvenStranger's Avatar
    Member Since
    Dec 09, 2010
    Currently 13" Late 2010 MBA, 4GB/128GB; Early 2011 13" MBP, dual core i7 2.7ghz, 4gb ram, 500gb hd
    Once you have created the new Administrator account, log in as Administrator, open Accounts (Users and Groups), unlock the pane, select your old account and click the checkbox to Allow user to administer this computer. Close window, log out and log back in as yourself, and you should now have administrator privileges again. Unlock a system pref to make sure.

  5. #5

    Member Since
    Oct 08, 2011
    tried to create new administrator, but machine does not respond to "command s" on start up, so i cannot start machine in single user mode, tried to run the script from the given link in my standard log in , password request comes up but machine will not let me enter one, ie no key strokes are being registered under the password input...any ideas...

  6. #6

    Member Since
    Oct 08, 2011
    fixed!!! using very nice solution...

    boot up in single user mode

    What you have to do is!!!

    Follow exactly.type

    mount -uw /
    Press enter and then.
    rm /var/db/.AppleSetupDone
    Press enter again then type
    shutdown -h now

    Follow those steps exactly and then it will work.

    This allows you to create a new administrator account as if the computer is new. use a new log in name and password this is important....when you boot up and log on it will appear that all data is lost, but if you log out you will see your old log in which will let you in with your old password. but your new admin name and password will allow admin access to your old account, this link explains all:

    How To Create A New Administrator Account - Hack Mac

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Installer in 10.10.3 wont't accept password
    By beskeptical in forum OS X - Operating System
    Replies: 2
    Last Post: 04-30-2015, 01:58 AM
  2. Terminal WONT accept my Password ?? Why . . . ?? Help please !!!!
    By TattooedMac in forum OS X - Operating System
    Replies: 13
    Last Post: 01-23-2014, 10:00 AM
  3. i get the sign on page but it wont accept my password
    By chociceandchips in forum Switcher Hangout
    Replies: 3
    Last Post: 08-17-2009, 06:33 PM
  4. just installed leopard wont accept password
    By boso in forum OS X - Operating System
    Replies: 4
    Last Post: 01-13-2008, 03:08 PM
  5. Wont accept system password.
    By johnnymacuser in forum OS X - Operating System
    Replies: 0
    Last Post: 02-28-2007, 01:20 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts