Mac Forums

Mac Forums (
-   OS X - Operating System (
-   -   Ejected/outdated OSX Install Disk (Disk Utility unavailable for repair) (

Timtraveller 09-28-2011 04:29 AM

Ejected/outdated OSX Install Disk (Disk Utility unavailable for repair)

I've been running my MacBook Pro faithfully since 2006 with only the free online upgrades prompted by the machine (now at 10.4.11). I ran OnyX now which found some problems on the computer true, it's become a bit unstable lately and it told me to run Disk Utility from the Install Disk. The disk needs to be repaired.

The only problem is that the Install Disk is version 10.4.6 which may be the reason why the disk is ejected when I try to start from it (pressing "C").

Just the other day I replaced the optic drive, I don't know if some outdated firmware (etc) issue could relate to this (I still can't burn, for example, so that needs to be looked up anyway). It reads the Install CD normally though, just won't start from it: I insert CD, wait 'til it no longer spins, then I restart computer and hold "C" down but it ejects the disk after chewing on it for a while. I didn't try starting from the old optic drive because it's been very unreliable for the past half year anyway and hadn't run OnyX until now.

How can I access this Disk Utility? I have it on my computer of course, but I understand it should be run from the Install Disk as otherwise it'd make a knot of itself.


2 GHz Intel Core Duo
2 GB, 667 MHz, DDR2 SDRAM

(I noticed there's a similar thread about starting from install disk but with a bit different specifications, feel free to merge mine to that one if appropriate.)

chscag 09-28-2011 01:17 PM

Try this method of repair:

Boot the machine in Single User Mode = Hold down the Command Key and S key as soon as you hear the chime. That will give you a DOS like command line interface.

Now type the following: fsck -y

That will run a verify - repair on the hard drive same as Disk Utility. If you get a response back that the disk was modified, run the same thing again. Keep doing that until you get a response that the MacIntosh HD appears to be OK.

Timtraveller 10-03-2011 02:09 PM


Thanks for the reply! It seems I'd forgotten to turn on notifications (now they're on), so I didn't get to see it until now.

I did the procedure but got this reply:

fsck_hfs: Volume is journaled. No checking performed.
fsck_hfs: Use the -f option to force checking.

Should I force it?

cradom 10-03-2011 02:42 PM

Yes. The command is fsck -fy
Run it until it says disk is OK.

Timtraveller 10-04-2011 04:22 AM

Many thanks cradom & chscag, worked fine!

Can I use this to repair an external HDD as well? I've got one that doesn't tend to unmount without running "lsof | egrep [drive name]" and "kill -9 [process number]" from Terminal... obviously I'm going to replace this HDD very soon with a newer one, but in the meantime I'd still like to use it. It needs this still after I've repaired the laptop, so the problem should be on the external HDD.

The same unmounting problem has also appeared on some occasion on my 1 TB HDD from last year, so maybe I should run the disk utility on that one as well, unless it was just something related to the laptop's problems.

cradom 10-04-2011 02:44 PM

By running that command are you getting a process number for an app? Seems like something has open files on the external and you're killing it.
This might help with that: HAMSoft Engineering: What's Keeping Me?

Timtraveller 10-04-2011 02:54 PM


Yes, I get a process number, then by typing "kill -9 [process number]" I can unmount the volume. I don't know why those processes keep going but figured it might be a disk problem on the external HDD. Usually it's a matter of image files that I've viewed with Preview.

Thanks for the hint of the program, but since I'm doing the same via Terminal anyway it doesn't really matter *just thought if the same fsck -y command could be used for external disks as well, while at it *but I believe I might all the same use the regular Disk Utility in OSX. Hadn't thought about that!

gsahli 10-04-2011 03:25 PM

Back to the question about starting up from your 10.4.6 Install DVD. It should work no matter what version the hard drive has - if it doesn't startup, you should consider - that the DVD isn't the correct one for your model Mac? or that the DVD drive still isn't right.

Timtraveller 10-04-2011 03:36 PM


The disc is original –*but I'll have to work on the optic drive that I replaced recently. It still doesn't burn discs so there's something wrong with it anyway. It does play DVDs though, which my old drive no longer did (probably due to dust that wouldn't leave with compressed air).

Ifixit were asking me for comments regarding the replaced optic drive so they might have also some hints about replaced drives that remain buggy. It's a used optic drive but certified as tested.

Thanks for pointing out that the disk must work regardless of the OS version, it helps me to continue searching for the solution with the optic drive.

But I think this thread is complete, thanks!

(Strange, this forum spells out my dashes as hyphen+asterisk.)

All times are GMT -4. The time now is 06:30 PM.

Powered by vBulletin
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.