New To Mac-Forums?

Welcome to our community! Join the discussion today by registering your FREE account. If you have any problems with the registration process, please contact us!

Get your questions answered by community gurus Advice and insight from world-class Apple enthusiasts Exclusive access to members-only contests, giveaways and deals

Join today!

 
Start a Discussion
 

Mac-Forums Brief

Subscribe to Mac-Forums Brief to receive special offers from Mac-Forums partners and sponsors

Join the conversation RSS
OS X - Operating System General OS operation information and support

Mac OS X


Post Reply New Thread Subscribe

 
Thread Tools
AppleCider

 
AppleCider's Avatar
 
Member Since: Aug 21, 2011
Location: The evil side of your mind.
Posts: 133
AppleCider will become famous soon enough
Mac Specs: iMac Early 2008, 2.4 GHz Intel Core 2 Duo, 3 GB 800 MHz DDR2 SDRAM ATI Radeon HD 2400 XT 128 MB

AppleCider is offline
EDIT: whoops, sorry for making the title MAC OS X.
My bad.

Hey guys,

Just signed up, after around a year of using mac forums as my main source of info for software problems, and I need some help.

I have an iMac that I use for work, and I also have a second account with parental controls enabled. I have had so many problems trying to get it to work like a normal Mac, so instead of listing a million threads, I thought to compile them into one.

1: When adding time to the account, when the window pops up asking you for more time, selecting "rest of the day" doesn't work. After I put in my admin password and username, it pops right back up again.

2: If I enable an application that is not allowed to be opened, it logs me out.

3: my lesser (one using the controlled account) was trying to start dabbling in Xcode. I installed it from the Mac app store, and had a hard time getting it to work. A window popped up asking for permission to allow some random application, and it was spazzing out. It was popping up again and again without me doing anything. I had to put my password in several times before it would work. I had to go through this with a few other applications, and then everything seemed fine. He went online and found some beginners tutorials on youtube, and soon had a small little calculator/counter thing made. He clicked run, and the build instantly failed, and yet more prompts for admin passwords came up. I enabled them all, and we clicked build again. It worked, and opened up the iPhone simulator, which asked me for even MORE admin passwords for random applications. One came up called springboard, and it wouldn't let me do "always allow", or it would just pop up again. I had to do allow once. THEN, finally, we were at a virtual iPhone screen. He clicked on his application, and it asked to allow it to open. I did my password thingy, then it seemed to open, but all that showed was a white screen.

4. When he uses the internet, every page he goes to including google.com, ask him to put in a admin password because the site has secure pages.

5. On both accounts, the computer lags greatly. I just installed lion two days ago, and the animations all lag for things like launchpad.

any help on anyone of these?

thanks a ton.
QUOTE Thanks
AppleCider

 
AppleCider's Avatar
 
Member Since: Aug 21, 2011
Location: The evil side of your mind.
Posts: 133
AppleCider will become famous soon enough
Mac Specs: iMac Early 2008, 2.4 GHz Intel Core 2 Duo, 3 GB 800 MHz DDR2 SDRAM ATI Radeon HD 2400 XT 128 MB

AppleCider is offline
No one? aw...

... If one falls flat on their face, at least they were moving in the right direction...

Forward...
QUOTE Thanks
vansmith

 
vansmith's Avatar
 
Member Since: Oct 19, 2008
Location: Toronto
Posts: 17,824
vansmith has a reputation beyond reputevansmith has a reputation beyond reputevansmith has a reputation beyond reputevansmith has a reputation beyond reputevansmith has a reputation beyond reputevansmith has a reputation beyond reputevansmith has a reputation beyond reputevansmith has a reputation beyond reputevansmith has a reputation beyond reputevansmith has a reputation beyond reputevansmith has a reputation beyond repute
Mac Specs: 2012 13" MBP (2.5 i5, 8GB)

vansmith is online now
You need to wait more than 17 minutes for a response.

Try disabling parental controls to see if the issue is resolved. If it is, re-enable it but add restrictions to the account one at a time (add, login to check, add...) to see which one is causing you the most trouble.

Important Links: Community Guidelines : Use the reputation system if you've been helped.
M-F Blog :: Write for the blog
Writing a Quality Post
QUOTE Thanks
AppleCider

 
AppleCider's Avatar
 
Member Since: Aug 21, 2011
Location: The evil side of your mind.
Posts: 133
AppleCider will become famous soon enough
Mac Specs: iMac Early 2008, 2.4 GHz Intel Core 2 Duo, 3 GB 800 MHz DDR2 SDRAM ATI Radeon HD 2400 XT 128 MB

AppleCider is offline
All it is is "limit applications". Everything works fine without it on.

It seems to be not only blocking actual applications, but those in the applications that are required for certain purposes.

... If one falls flat on their face, at least they were moving in the right direction...

Forward...
QUOTE Thanks
AppleCider

 
AppleCider's Avatar
 
Member Since: Aug 21, 2011
Location: The evil side of your mind.
Posts: 133
AppleCider will become famous soon enough
Mac Specs: iMac Early 2008, 2.4 GHz Intel Core 2 Duo, 3 GB 800 MHz DDR2 SDRAM ATI Radeon HD 2400 XT 128 MB

AppleCider is offline
Sorry for bumping again, but I really need this resolved.

It didn't happen in snow leopard if that means anything to anyone.

... If one falls flat on their face, at least they were moving in the right direction...

Forward...
QUOTE Thanks
Dysfunction

 
Dysfunction's Avatar
 
Member Since: Mar 17, 2008
Location: Tucson, AZ
Posts: 6,638
Dysfunction has a brilliant futureDysfunction has a brilliant futureDysfunction has a brilliant futureDysfunction has a brilliant futureDysfunction has a brilliant futureDysfunction has a brilliant futureDysfunction has a brilliant futureDysfunction has a brilliant futureDysfunction has a brilliant futureDysfunction has a brilliant futureDysfunction has a brilliant future
Mac Specs: 2008 and 2011 15" mbps, late 11 iMac, iPhone 4s, and too many ipods and other stuff

Dysfunction is offline
Quote:
Originally Posted by Sajid Ansari View Post
All it is is "limit applications". Everything works fine without it on.

It seems to be not only blocking actual applications, but those in the applications that are required for certain purposes.
I'm going from memory here, but I believe this is actually working as designed. First, you set the rule to limit applications. This then requires that you specify ONLY ALLOWED applications. As far as I know, Parental Controls is not smart enough to deduce which other processes are going to be called by the parent.

That said, the OTHER behavior is (IMO) unusual. Being logged out after entering your administrative password shouldn't happen. It should also allow you to 'always allow'.

I would create a NEW account, try the parental controls on that one and see if the results are identical. In addition, I would make sure that you have the 10.7.1 update applied to this machine. If all else fails, I'd do a clean install of the operating system (and to be honest, I'm not sure I'd use migration assistant to move the users back either, which would mean manual restore from backup, at least for me)

mike
This machine kills fascists
Got # ? phear the command line!
QUOTE Thanks
AppleCider

 
AppleCider's Avatar
 
Member Since: Aug 21, 2011
Location: The evil side of your mind.
Posts: 133
AppleCider will become famous soon enough
Mac Specs: iMac Early 2008, 2.4 GHz Intel Core 2 Duo, 3 GB 800 MHz DDR2 SDRAM ATI Radeon HD 2400 XT 128 MB

AppleCider is offline
Well... Thats not good. He was really looking forward to putting something out on the app store.

Its my work computer, so fresh install is out of the question at this point.
I think that Mac parental controls are really lacking in the bugginess section.

... If one falls flat on their face, at least they were moving in the right direction...

Forward...
QUOTE Thanks
AppleCider

 
AppleCider's Avatar
 
Member Since: Aug 21, 2011
Location: The evil side of your mind.
Posts: 133
AppleCider will become famous soon enough
Mac Specs: iMac Early 2008, 2.4 GHz Intel Core 2 Duo, 3 GB 800 MHz DDR2 SDRAM ATI Radeon HD 2400 XT 128 MB

AppleCider is offline
All of the sudden, again in my parental controlled account, using google chrome is very hard, because every thirty seconds or so, I get a pop up saying:

Google Chrome attempted to access a secure website

Parental Controls restricts access to secure websites. To add this website to your approved list, click Add Website. To do this, you need an administrator password.

The site thats blocked is not a site, just an IP. So I allow it, and copy the IP to the browser. Then I get this:

{attached image below}.


any help on this one? He can barely use the internet now, and its only on Lion.

I'm very dissatisfied with Lion, its slowed down my computer, and caused lots of problems.
Attached Images
File Type: png Screen Shot 2011-08-22 at 9.41.50 PM.png (41.4 KB, 33 views)

... If one falls flat on their face, at least they were moving in the right direction...

Forward...
QUOTE Thanks
cwa107

 
cwa107's Avatar
 
Member Since: Dec 20, 2006
Location: Middletown, Pennsylvania
Posts: 26,494
cwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond repute
Mac Specs: 15" MBP, Core i7/2GHz, 8GB RAM, 480GB Crucial M500 SSD

cwa107 is offline
Did you prep the machine at all before you installed Lion? (i.e. run a backup, run routine maintenance, check/repair permissions, check/repair disk, use a tool to get all of your third party apps up-to-date, etc?).

If not, now would be a good time to do those things.

I can't speak to the parental controls issue as it's not something I use. But I agree that doing a clean install tends to work better than a straight upgrade. I found this to be the case with my own machine. I did choose to migrate my data/docs/settings/apps back in with the Migration Assistant using a Time Machine backup, and it was fine.

Liquid and computers don't mix. It might seem simple, but we see an incredible amount of people post here about spills. Keep drinks and other liquids away from your expensive electronics!
QUOTE Thanks
cwa107

 
cwa107's Avatar
 
Member Since: Dec 20, 2006
Location: Middletown, Pennsylvania
Posts: 26,494
cwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond repute
Mac Specs: 15" MBP, Core i7/2GHz, 8GB RAM, 480GB Crucial M500 SSD

cwa107 is offline
Sounds like you're just dissatisfied with Apple's Parental Controls in general (and by the way, let's keep it to one thread - we don't need two on the same topic, so I merged this into the last one).

Consider just turning it off and using something like K9 Web Protection. It's free and will appropriately restrict the Internet if that's all you're trying to do.

Liquid and computers don't mix. It might seem simple, but we see an incredible amount of people post here about spills. Keep drinks and other liquids away from your expensive electronics!
QUOTE Thanks
chscag

 
chscag's Avatar
 
Member Since: Jan 23, 2008
Location: Fort Worth, Texas
Posts: 39,437
chscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond repute
Mac Specs: 27" iMac i5, 3.2 GHz, iPad 3, iPhone 5c, 3 iPods, OS X Mavericks

chscag is offline
No slow downs with Lion here. And if Chrome is giving you problems, switch to another browser. Safari, Firefox, Opera, your choice.
QUOTE Thanks
AppleCider

 
AppleCider's Avatar
 
Member Since: Aug 21, 2011
Location: The evil side of your mind.
Posts: 133
AppleCider will become famous soon enough
Mac Specs: iMac Early 2008, 2.4 GHz Intel Core 2 Duo, 3 GB 800 MHz DDR2 SDRAM ATI Radeon HD 2400 XT 128 MB

AppleCider is offline
Same thing with all browsers.

I need it do restrict all the same things apple parental controls do. It worked like a charm in snow, it's this lion upgrade.

No, I joined this forum after installing lion, and I dint know maintenance was neccesary.

EDIT:

Ok, this is getting out of hand.


Ive been figeting around with the parental controlled account, and its impossible to use the internet without having a window pop up asking for permission to some random IP. So what I did, was I copied the IP, allowed access, and then pasted the IP to a new tab. I got a message saying that this could be a fake site and someone is trying to get me to visit a fake site. I click continue anyway, and it brings me to google homepage, except its says SSL beta. I click "back to normal" and it seems to work. Then after a while, the random IP's come back. I wish there was a way to turn off this feature, the one thats blocking it from accessing secure sites.

... If one falls flat on their face, at least they were moving in the right direction...

Forward...
QUOTE Thanks
AppleCider

 
AppleCider's Avatar
 
Member Since: Aug 21, 2011
Location: The evil side of your mind.
Posts: 133
AppleCider will become famous soon enough
Mac Specs: iMac Early 2008, 2.4 GHz Intel Core 2 Duo, 3 GB 800 MHz DDR2 SDRAM ATI Radeon HD 2400 XT 128 MB

AppleCider is offline
Deleted by me. Double post.

... If one falls flat on their face, at least they were moving in the right direction...

Forward...
QUOTE Thanks

Post Reply New Thread Subscribe


« Pixelated Thumbnails | MAC MAIL don't find names or emails i sent »
Thread Tools

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off
Forum Jump

Similar Threads
Thread
Thread Starter
Forum
Replies
Last Post
Five ways Apple can improve the Mac App Store OneMoreThing... Apple Rumors and Reports 0 07-16-2011 08:42 PM
Is Apple ready to play cat and mouse with malware developers? OneMoreThing... Apple Rumors and Reports 3 06-04-2011 10:10 PM
The conversations you should get into with anti Mac folk 6string Schweb's Lounge 13 05-12-2011 04:28 PM

All times are GMT -4. The time now is 10:55 AM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
X

Welcome to Mac-Forums.com

Create your username to jump into the discussion!

New members like you have made this community the ultimate source for your Mac since 2003!


(4 digit year)

Already a member?