Page 1 of 2 12 LastLast
Results 1 to 15 of 21
  1. #1


    Member Since
    Aug 05, 2011
    Posts
    64
    how stop Lion opening apps on startup
    Hi guys

    Is there a way to stop Lion starting a lot of apps on startup leopard did not start all these apps on startup, it makes startup very slow.

    It starts safari, mail, thunderbird, firefox, parallels desktop,

  2. #2

    chscag's Avatar
    Member Since
    Jan 23, 2008
    Location
    Keller, Texas
    Posts
    49,450
    Specs:
    Late 2013 27" iMac, iPad 3, iPhone 6s+, iPhone 6+, 3 iPods, Sierra
    I'm wondering why that many applications are starting up when you boot Lion? Even carrying over settings and a new installation does not place applications into the startup category.

    Open your System Preferences, go to the System row and click on the "Users & Groups icon. Click on the "Login Items" tab. If those applications are listed there, click on the small minus button at the bottom and remove them one by one.

    Also... make sure that you have not selected any of those apps from starting up by choosing the "Open at Login" option from the Dock icons. Check each application on the Dock to make sure. (right click on the icon and select options)

  3. #3

    cwa107's Avatar
    Member Since
    Dec 20, 2006
    Location
    Lake Mary, Florida
    Posts
    26,947
    Specs:
    15" MBP, Core i7/2GHz, 8GB RAM, 480GB Crucial M500 SSD
    Are you aware that when you go to shut down, there is a checkbox that you must click if you don't want your apps automatically re-starting?

    Liquid and computers don't mix. It might seem simple, but we see an incredible amount of people post here about spills. Keep drinks and other liquids away from your expensive electronics!

    https://youtu.be/KHZ8ek-6ccc

  4. #4

    chscag's Avatar
    Member Since
    Jan 23, 2008
    Location
    Keller, Texas
    Posts
    49,450
    Specs:
    Late 2013 27" iMac, iPad 3, iPhone 6s+, iPhone 6+, 3 iPods, Sierra
    Yes and that too. I forgot all about that option.

  5. #5


    Member Since
    Aug 05, 2011
    Posts
    64
    Thanks for your replies, cwa107 i did this with the checkbox and it worked fine, still very slow startup close down after lion update.

    Is there a work around so this checkbox remembers this seting next time i close down?

  6. #6

    chscag's Avatar
    Member Since
    Jan 23, 2008
    Location
    Keller, Texas
    Posts
    49,450
    Specs:
    Late 2013 27" iMac, iPad 3, iPhone 6s+, iPhone 6+, 3 iPods, Sierra
    No work around. The box must be unchecked each time. There is an Apple script available that does the unchecking for you automatically, however, I have found it's not any more convenient to run the script so I'm not recommending it.

  7. #7


    Member Since
    Aug 20, 2011
    Posts
    1
    Thanks for your help
    CWA107, I joined this site for two reasons: 1. Thank you for helping me and others in figuring out why unwanted apps. were opening up at start up. Man, this was a big help. I could not for the life of me figure out why several apps. opened at startup. You had the answer and a screen shot of the resolution.
    2. This seems a fair site for individuals who enjoy Apple products.: Thanks again.

  8. #8


    Member Since
    Dec 15, 2011
    Posts
    6
    Same issue
    I dont have anything on user/account as login programs but when I turn it off I dont get the option to check or uncheck anything. Nay other way to avoid having programs show up when I start?

    Also, do you know how to uninstall applications? In case they still show up when I turn it on one of them I hardly ever even use!

    thanx

  9. #9


    Member Since
    Aug 05, 2011
    Posts
    64
    I solved this problem by format, install Snow Leopard.
    So no more problems with Lion.My imac is good and fast again
    and no silly start all programs.

  10. #10


    Member Since
    Jan 22, 2010
    Location
    Victoria, BC
    Posts
    20,911
    Specs:
    Mid-2012 MBP (16GB, 1TB HD), Monoprice 24-inch second monitor, iPhone 5s 32GB, iPad Air 2 64GB
    An easier way to "solve" this "problem" would be to learn how to properly quit programs (hint: red button in corner doesn't quit programs).

    If the programs are quit before you shutdown/restart, guess what? They don't re-open when you start up!

    Remarkable really.

  11. #11


    Member Since
    Aug 05, 2011
    Posts
    64
    I think i will wait a year or so, maybe Lion will be ok,
    and even then it will be on slow startup shutdown.

    I much prefer Snow Leopard.

  12. #12


    Member Since
    Jan 02, 2012
    Posts
    1
    • Launch System Preferences and click on the “General” icon

    • At the bottom of the “Number of recent items” list, uncheck the checkbox next to “Restore windows when quitting and re-opening apps”

  13. #13

    cwa107's Avatar
    Member Since
    Dec 20, 2006
    Location
    Lake Mary, Florida
    Posts
    26,947
    Specs:
    15" MBP, Core i7/2GHz, 8GB RAM, 480GB Crucial M500 SSD
    Quote Originally Posted by dtavangar View Post
    • Launch System Preferences and click on the “General” icon

    • At the bottom of the “Number of recent items” list, uncheck the checkbox next to “Restore windows when quitting and re-opening apps”
    That only works for individual applications (i.e. you quit an application, when you come back, the application is as you left it).

    It does NOT have any effect on whether apps that had been active at shut down will relaunch at boot-up.
    Liquid and computers don't mix. It might seem simple, but we see an incredible amount of people post here about spills. Keep drinks and other liquids away from your expensive electronics!

    https://youtu.be/KHZ8ek-6ccc

  14. #14


    Member Since
    Jan 13, 2012
    Posts
    1
    It does NOT have any effect on whether apps that had been active at shut down will relaunch at boot-up.

    I just wanted to put in my two cents by verifying the above. While it's not a major bug, it is a little annoying to have the OS continually "remember" the apps you forgot to log out of upon start-up by relaunching them. For the record, I've clicked the option in the General Settings and I've clicked the option to not remember apps upon log-out...neither of these features makes the OS remember to knock it off the next time you reboot.

    I think this matter should be addressed in the next release by giving the user the ability to turn off application recall. Why this was even installed as a default with no work-around for the average user is beyond me.

  15. #15

    chscag's Avatar
    Member Since
    Jan 23, 2008
    Location
    Keller, Texas
    Posts
    49,450
    Specs:
    Late 2013 27" iMac, iPad 3, iPhone 6s+, iPhone 6+, 3 iPods, Sierra
    See this LINK for a work around. If you're not comfortable with using Terminal, this is not for you.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. stop mail opening on startup, Lion
    By negativepitch in forum OS X - Operating System
    Replies: 13
    Last Post: 02-17-2013, 03:07 AM
  2. How do I stop apps from opening on login???
    By sherrypaul in forum OS X - Operating System
    Replies: 2
    Last Post: 03-07-2012, 01:57 PM
  3. How do I stop OS X Lion from automatically opening things?
    By jschenone in forum OS X - Operating System
    Replies: 2
    Last Post: 02-09-2012, 01:35 PM
  4. How Do I Stop Lion from Re-opening Old Windows?
    By frankdigiacomo in forum OS X - Operating System
    Replies: 2
    Last Post: 09-11-2011, 10:20 AM
  5. How to stop itunes always opening when CD inserted?
    By Justin in forum Switcher Hangout
    Replies: 1
    Last Post: 01-16-2007, 10:41 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •