New To Mac-Forums?

Welcome to our community! Join the discussion today by registering your FREE account. If you have any problems with the registration process, please contact us!

Get your questions answered by community gurus Advice and insight from world-class Apple enthusiasts Exclusive access to members-only contests, giveaways and deals

Join today!

 
Start a Discussion
 

Mac-Forums Brief

Subscribe to Mac-Forums Brief to receive special offers from Mac-Forums partners and sponsors

Join the conversation RSS
OS X - Operating System General OS operation information and support

mapped network drive issue (in Lion)


Post Reply New Thread Subscribe

 
Thread Tools
jparsley

 
Member Since: Aug 01, 2011
Posts: 3
jparsley is on a distinguished road

jparsley is offline
Hello,

I have an issue that may be unique, I'm not sure.

Here is what I have noticed in Lion: When I Connect to Server with an address such as the following: smb://Server1/Share2/Subfolder3 that Lion puts Share2 in the finder. I'm fairly sure it didn't work that way in Snow Leopard. I remember it putting Subfolder3 as the mapped drive in Finder.

In most situations this is just annoying because if you are wanting to save something in the particular folder you had originally mapped, you now have to fish through your share to find the folder.

I have a situation that is a little different. On our network we have a home$ share that has everyone's home drive in the company. People don't have read ability on the home$ share because they don't need to know who has a home drive nor see any files that are located there. For them to access it, they have to go directly to their specific home drive. Now, when you map smb://server/home$/user it opens up their user folder initially but as I mentioned above only home$ will show in finder. When a user tries to go through finder to navigate to their folder (or save something) they can't because they get an error when they click on home$ that they don't have permissions. Windows users do not have this problem. Snow Leopard users do not have this problem. No one does but those who have upgraded to Lion. The only way to even view the home drive is to look at it through Terminal or use Go to Folder and type in /home$/user after mapping. This work ok for wanting to view or open items, but fails when you want to save something.

At this point, we don't want to change anything on the servers. How can I get around this in Lion? Can I create an alias somehow to this share than you can access? If so, how? I don't know how to make an alias in this situation. It doesn't show this folder anywhere in Finder to be able to drag it anywhere.

Any help will be very appreciated.

Thanks.
QUOTE Thanks
jparsley

 
Member Since: Aug 01, 2011
Posts: 3
jparsley is on a distinguished road

jparsley is offline
I called apple support on this. Is seems to be limited to the share being on a windows server. He duplicated the issue and confirmed it to be a bug. He said hopefully a patch will be released soon.



Just thought I'd let anyone know who might be looking to resolve this issue.
QUOTE Thanks
rlager

 
Member Since: Aug 05, 2011
Posts: 4
rlager is on a distinguished road

rlager is offline
Well it's good to know I'm not crazy . We are having the exact same issue with a Macbook Air that was upgraded to Lion recently. Just out of curiosity - what version of file server is being used in your configuration. We currently are using a Windows 2003 box, but are going to be hopefully migrating to a Windows 2008 box this weekend.

I'm not sure if it will maike a difference, but it's good to know that support is aware of it and working on a fix.

Thanks!

rlager
QUOTE Thanks
jparsley

 
Member Since: Aug 01, 2011
Posts: 3
jparsley is on a distinguished road

jparsley is offline
Hi rlager,

The server I was working with runs Server 2003 in a virtual environment.

If you want, you can suggest feedback to Apple. The apple rep asked that I report it there even though he was going to. Maybe the more people that report the problem the more widespread it will appear to them.

Apple - Feedback
QUOTE Thanks
rlager

 
Member Since: Aug 05, 2011
Posts: 4
rlager is on a distinguished road

rlager is offline
Hi!

I'll try to get that feedback submitted tonight. Our migration to the Windows 2008 server was postponed of course so I can't report on whether or not it made a difference.

Thanks

rlager
QUOTE Thanks
rlager

 
Member Since: Aug 05, 2011
Posts: 4
rlager is on a distinguished road

rlager is offline
Just FYI - I submitted that feedback this morning. Here's hoping for an early fix! .
QUOTE Thanks
owenshill

 
Member Since: Aug 12, 2011
Posts: 1
owenshill is on a distinguished road

owenshill is offline
We're having the same issue in an enterprise environment. It looks like a permissions issue. Here's hoping for a speedy fix.

PS: I sent the feedback to Apple tonight as well. Maybe if they get enough...
QUOTE Thanks
rlager

 
Member Since: Aug 05, 2011
Posts: 4
rlager is on a distinguished road

rlager is offline
More FYI - with most of our migration to 2008 R2 for this particular server completed - it appears as though the issue remains. I'm going to wait until they've fully completed it to say that the issue is still there but it looks to be the case.

Just out of curiosity...for the users in your organizations that are having this issue - are their accounts local admins?
QUOTE Thanks
veniculum

 
Member Since: Mar 30, 2009
Location: NJ
Posts: 19
veniculum is on a distinguished road
Mac Specs: New "unibody" macbook pro 2.4Ghz, 250 SSD, 4GbDDR3 RAM; Mac OS X Leopard, Parallels (Vista Ult, XP)

veniculum is offline
I'm having the same problem here on my corporate network. Users have a home share/folder which is pushed out via Active Directory. So here's what I've seen:
With 10.6.x, the share/folder would be mounted just like it is on a Windows PC. On the three or four machines that I've upgraded to 10.7, either 1) the share tries to mount...although, as was mentioned above, it doesn't mount to the share, but to the server itself, and then I have to select the share manually...or 2) nothing mounts at all.

On the machines where the share tries to mount (after selecting it), a 'Login item' is added (in the system preferences)...it's an 'unknown' Login Item with a yellow exclamation on it. I can't delete it because it's greyed out (so I can't check it, and I can't click the -minus button.
Then, of course, the machines where it isn't mounting at all, the only way to get it to mount is to do the 'apple/K' and manually type in the entire path. At that point, you can drag the mounted share into the login items box, and it will mount on next login.

This isn't a make or break problem....but it is an issue nonetheless...particularly when I use logmein. I can't reboot my Mac using logmein, because when the machine comes back up, the logmein session will not show the window that pops up asking me to select my network share. Without clicking my share, in that box, I can't continue to login...and therefore I'm stuck in that position...until I come back into the office and manually click the share listed in that box/window.

I appreciate any feedback/updates
Thanks
QUOTE Thanks
trevori

 
Member Since: Aug 26, 2011
Posts: 3
trevori is on a distinguished road

trevori is offline
I'm having a similar issue. I'm a complete Mac newbie, but have set up a Readynas etc on my Windows environment at home. When I try to connect to the NAS, I'm getting these exact issues. I've at least sorted out the NAS so I can connect on Lion, but I'm not sure I'm doing the right thing or not on the Mac side.
QUOTE Thanks
87vert

 
Member Since: Apr 09, 2010
Posts: 21
87vert is on a distinguished road
Mac Specs: Powermac G5 - Dual 2.0 - 6GB Ram

87vert is offline
any updates on this being fixed? or a workaround?

21.5" iMac 3.06 | 8GB Ram | 500 GB Hdd
11" MacBook Air
QUOTE Thanks
philldo

 
Member Since: Nov 03, 2011
Posts: 1
philldo is on a distinguished road

philldo is offline
I have noticed the same problem within our network and we found a FIX!

Our symptoms:
When mounting a network drive via Finder (cmd+k), //server/share/folder it would only mount //server/share as the /folder has specific permissions on it

Mounting via cmd line worked perfectly fine:
mount -t smbfs //server/share/folder /local/folder

Our fix:
It seems the 'default view' in Finder when mounting a network drive is 'columns'. If you change the view to anything else (Icons/List/Cover Flow) it displays everything within the network share that you're trying to access perfectly.

Anyone confused as I am yet ?

Hope that helps!
QUOTE Thanks
Kristofer

 
Member Since: Jan 22, 2012
Posts: 2
Kristofer is on a distinguished road

Kristofer is offline
Same issue here with greyed out "Login Item" which I cant touch.
A coinsidence perhaps, but when we moved the home folders to a new server it left a shortcut in the dock called "User Name's Network Home" which cant be removed and appears again after su root killall Dock and removing all Library Preference files.
That has led me to believe that this is an Account Setting cached somewhere and that finding that cache or entry will solve both things at once.

Thats that, anyone managed to find a solution to it?
QUOTE Thanks
Cormack

 
Member Since: Apr 03, 2012
Posts: 1
Cormack is on a distinguished road

Cormack is offline
OK, this isn't clean or particularly secure but it works.

I've been having the same problem as discussed here, and found that the solution was to use the following terminal commands:

mkdir /Volumes/<sharename>
mount -t smbfs //<username>:<password>@<server>/<sharepath> /Volumes/<sharename>

So for example, a user with details: username - jsmith , password - pword
trying to connect to the share /users/jsmith on the server myserver.mydomain.com
would do the following:

mkdir /Volumes/jsmith
mount -t smbfs //jsmith:pword@myserver.mydomain.com/users/jsmith /Volumes/jsmith

To make this easier for the user to connect, I've installed QuicKeys (Startly - QuicKeys*4 for Mac OS X) and created a shortcut using the "Terminal Command" step.

Works well, but obviously the password is unencrypted and in plain sight within the command.

If you're not using QuicKeys and just plugging this directly to the terminal, you can miss out the :<password> bit and it will prompt you, but the way QuicKeys runs it this doesn't seem to work (I'm a QuicKeys novice - if anyone knows how to get around this, I'd love to hear!)
QUOTE Thanks

Post Reply New Thread Subscribe


« Mac: iCal support - Adding Mac plugin application | iLife '06 ? »
Thread Tools

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off
Forum Jump

Similar Threads
Thread
Thread Starter
Forum
Replies
Last Post
How to: Upgrade Hard Drive 2009 Macbook Pro 13 s2odin Apple Notebooks 9 12-04-2010 01:06 PM
HELP!! - External Hard Drive Issue timnancyk Other Hardware and Peripherals 1 12-01-2010 02:51 PM
Wireless Network and Macbook Pro Issue mmorrismjm Internet, Networking, and Wireless 5 09-29-2008 06:06 AM
Looking for a good 'network' Time Machine Drive markw10 OS X - Operating System 1 11-30-2007 08:46 AM
DIY: Trick out your Intel Mini kaidomac Apple Desktops 53 02-17-2007 02:40 AM

All times are GMT -4. The time now is 11:03 PM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
X

Welcome to Mac-Forums.com

Create your username to jump into the discussion!

New members like you have made this community the ultimate source for your Mac since 2003!


(4 digit year)

Already a member?