New To Mac-Forums?

Welcome to our community! Join the discussion today by registering your FREE account. If you have any problems with the registration process, please contact us!

Get your questions answered by community gurus • Advice and insight from world-class Apple enthusiasts • Exclusive access to members-only contests, giveaways and deals

Join today!

 
Start a Discussion
 

Mac-Forums Brief

Subscribe to Mac-Forums Brief to receive special offers from Mac-Forums partners and sponsors

Join the conversation RSS
OS X - Operating System General OS operation information and support

Log In Problem


Post Reply New Thread Subscribe

 
Thread Tools
Chalky

 
Member Since: Nov 16, 2009
Posts: 60
Chalky is on a distinguished road

Chalky is offline
Hi,

Since I got my iMac it's just been me using it with no log in.

I've now added daughter an account. When I attempt to log in nothing happens just the background screen.

Ellie can log in fine and I can then switch user to me with no problem.

I can have it set that I automatically log in with no problem.

It is simply when I switch the machine on, log in window appears with both our names, I input my password and then nothing just the background screen as I said.

Anyone know a solution?
QUOTE Thanks
Lifeisabeach

 
Lifeisabeach's Avatar
 
Member Since: Sep 30, 2007
Location: Wilmington, NC
Posts: 7,013
Lifeisabeach has a reputation beyond reputeLifeisabeach has a reputation beyond reputeLifeisabeach has a reputation beyond reputeLifeisabeach has a reputation beyond reputeLifeisabeach has a reputation beyond reputeLifeisabeach has a reputation beyond reputeLifeisabeach has a reputation beyond reputeLifeisabeach has a reputation beyond reputeLifeisabeach has a reputation beyond reputeLifeisabeach has a reputation beyond reputeLifeisabeach has a reputation beyond repute
Mac Specs: iMac i3 (mid-2010) + OS 10.9; TV 3; iPhone 5S; iPad 4

Lifeisabeach is offline
Quote:
Originally Posted by Chalky View Post
Hi,

Since I got my iMac it's just been me using it with no log in.

I've now added daughter an account. When I attempt to log in nothing happens just the background screen.

Ellie can log in fine and I can then switch user to me with no problem.

I can have it set that I automatically log in with no problem.

It is simply when I switch the machine on, log in window appears with both our names, I input my password and then nothing just the background screen as I said.

Anyone know a solution?
Hmmmm…. this is a tough one. Well first thing to try is repairing permissions. You can use Onyx to do this.

If that doesn't work, use the Cleaning tools in Onyx to remove the various cache files.

If that fails, locate the following pair of preference files and drag them to your Desktop:
Macintosh HD/Library/Preferences/com.apple.loginwindow.plist
Macintosh HD/Library/Preferences/loginwindow.plist

On rebooting, OS X will make fresh copies of these. If this fixes it, trash the originals you moved to your Desktop. If it doesn't fix it, you can put the originals back, or just trash them if you are satisfied with how it is logging on with the defaults for now.

If none of these work out, please let us know so we can keep nipping at it. If it does work, please let us know for future reference.
QUOTE Thanks
Chalky

 
Member Since: Nov 16, 2009
Posts: 60
Chalky is on a distinguished road

Chalky is offline
Hi, tried all the options you mention but still the same, Ellie can log in ok, I can't have to switch user once Ellie logged in.
QUOTE Thanks
Lifeisabeach

 
Lifeisabeach's Avatar
 
Member Since: Sep 30, 2007
Location: Wilmington, NC
Posts: 7,013
Lifeisabeach has a reputation beyond reputeLifeisabeach has a reputation beyond reputeLifeisabeach has a reputation beyond reputeLifeisabeach has a reputation beyond reputeLifeisabeach has a reputation beyond reputeLifeisabeach has a reputation beyond reputeLifeisabeach has a reputation beyond reputeLifeisabeach has a reputation beyond reputeLifeisabeach has a reputation beyond reputeLifeisabeach has a reputation beyond reputeLifeisabeach has a reputation beyond repute
Mac Specs: iMac i3 (mid-2010) + OS 10.9; TV 3; iPhone 5S; iPad 4

Lifeisabeach is offline
Quote:
Originally Posted by Chalky View Post
Hi, tried all the options you mention but still the same, Ellie can log in ok, I can't have to switch user once Ellie logged in.
Ok. Let's try moving this preference file from your USER Library:
yourhomefolder/Library/Preferences/loginwindow.plist

Drop that on your Desktop, then reboot. If the problem is solved, delete the one you moved. If it is NOT solved, then put it back and read on.

If the prior tip didn't solve this, then we can try something a little more radical as a test, but be sure you understand this entirely before doing so. Move the entire Preferences folder for your user to the Desktop, then reboot. Do NOT delete it. The goal here is to prove if the problem is a preference file at all. Regardless of if it solves it or not, you'll want to restore the original folder because you will reset a lot of preferences in the system and many apps back to defaults.

If the above doesn't work, put the folder back, then repeat for the Preferences folder in the root Library:
Macintosh HD/Library/Preferences
Drop it on your Desktop, then reboot. Plan on putting it back like before, even if it fixes the problem or not. Let us know how any of this works out.
QUOTE Thanks
Chalky

 
Member Since: Nov 16, 2009
Posts: 60
Chalky is on a distinguished road

Chalky is offline
No joy. I could only copy the folders to desktop, kept getting message that OS X needs them cannot delete or modify.

I have read that this might be caused by an update in Leopard, anyway it looks like I'm not on my own with this. Maybe wait and see if Lion cures it?
QUOTE Thanks
northrnchimp

 
northrnchimp's Avatar
 
Member Since: Jun 13, 2010
Location: England
Posts: 217
northrnchimp will become famous soon enough
Mac Specs: rMBP 13 2.5GHz 121GB SSD

northrnchimp is offline
Create a new account, test to see if the same problem occurs, if not then copy your docs over to it.
QUOTE Thanks
Lifeisabeach

 
Lifeisabeach's Avatar
 
Member Since: Sep 30, 2007
Location: Wilmington, NC
Posts: 7,013
Lifeisabeach has a reputation beyond reputeLifeisabeach has a reputation beyond reputeLifeisabeach has a reputation beyond reputeLifeisabeach has a reputation beyond reputeLifeisabeach has a reputation beyond reputeLifeisabeach has a reputation beyond reputeLifeisabeach has a reputation beyond reputeLifeisabeach has a reputation beyond reputeLifeisabeach has a reputation beyond reputeLifeisabeach has a reputation beyond reputeLifeisabeach has a reputation beyond repute
Mac Specs: iMac i3 (mid-2010) + OS 10.9; TV 3; iPhone 5S; iPad 4

Lifeisabeach is offline
Quote:
Originally Posted by Chalky View Post
No joy. I could only copy the folders to desktop, kept getting message that OS X needs them cannot delete or modify.

I have read that this might be caused by an update in Leopard, anyway it looks like I'm not on my own with this. Maybe wait and see if Lion cures it?
It might, it might not. I had an odd issue with my wife's account some time back in that she couldn't log in through any method. After trying everything in the book, and some things not in the book, I finally had to re-import her user to fix it. Here's exactly what you should do as a last-ditch effort:
  1. Make a complete backup of your system from another admin user (not your malfunctioning one). You can use SuperDuper to make an exact clone of your system on an external drive. Or if you have the space, partition your drive and clone it to the new partition.
  1. Once cloned and verified, delete the user account you are having problems with; reboot; then re-migrate that user account back from the cloned copy that you made.

Hopefully this will fix your problem. Short of this, I can only recommend making a new user and manually migrating your data over.
QUOTE Thanks
Chalky

 
Member Since: Nov 16, 2009
Posts: 60
Chalky is on a distinguished road

Chalky is offline
Cheers guys, will give the final options a try. If they don't work I might wait till Lion is out later this month (?) and I might do a clean re-install of everything. Could do with a tidy up.
QUOTE Thanks

Post Reply New Thread Subscribe


« Mouse and keyboard not working. | Startup disk full, can't figure out why »
Thread Tools

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off
Forum Jump

Similar Threads
Thread
Thread Starter
Forum
Replies
Last Post
Final Cut Pro Log and Transfer problem!!! help! dpitty Movies and Video 2 09-10-2010 02:45 AM
2009 MBP - Possible Trackpad Problem tricky10 Apple Notebooks 6 09-09-2010 08:01 AM
iPhone onscreen volume control problem smuggerific iOS and Apps 1 04-19-2010 11:18 AM
Final Cut Pro Log and Capture Problem 217xchrisx Movies and Video 0 01-22-2010 02:24 PM
Huge Graphics Problem With Magic Garage Band mattcooper87 OS X - Apps and Games 0 08-21-2007 09:23 AM

All times are GMT -4. The time now is 06:08 AM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
X

Welcome to Mac-Forums.com

Create your username to jump into the discussion!

New members like you have made this community the ultimate source for your Mac since 2003!


(4 digit year)

Already a member?